Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   blocking packages when emerge gnome-light (http://www.linux-archive.org/gentoo-user/82663-blocking-packages-when-emerge-gnome-light.html)

paul 05-05-2008 09:08 PM

blocking packages when emerge gnome-light
 
I am sure that this is all explained somewhere but I cannot find it
easily.

When running "emerge -av gnome-light" I get :
[blocks B ] <gnome-base/control-center-2.22 (is blocking
gnome-base/gnome-settings-daemon-2.22.1)
[blocks B ] dev-util/gtk-doc-am (is blocking
dev-util/gtk-doc-1.8-r2)


I am not asking anyone to wade through my make.conf and various portage
files but if someone who knows the system obviously better than I do
could please point me in the direction of how to fix this issue I would
be grateful.

My requirements are "install gnome-light 2.22.0 or later".


Thanks

Paul
--
Transplants Save Lives - http://www.uktransplant.org.uk/

Below is make.conf and the output of the emerge command:

# These settings were set by the catalyst build script that
automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
#CFLAGS="-O2 -pipe"
#see http://gentoo-wiki.com/Safe_Cflags#Athlon_64_X2_.28AMD.29
ACCEPT_KEYWORDS="~amd64"
#do not use -O2 as this caused segmentation faults in building gcc-4.1.2
CFLAGS="-march=k8 -pipe -msse3 -Wno-error "
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
GENTOO_MIRRORS="http://www.mirorservice.org/sites/www.ibiblio.org/gentoo
http://distfiles.gentoo.org
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
INPUT_DEVICES="evdev keyboard mouse"
VIDEO_CARDS="fglrx"
LINGUAS="en"
# 2007 June 5
# For HPLIP added foomaticdb, scanner, snmp
# For xsane added gimp
USE="acl asf -kde qt4 dbus bluetooth gnome hal startup-notification X
samba nsplugin acpi
mp3 apm lm_sensors subversion java bzip2 fpx graphviz gs jbig jpeg

jpeg2k mpeg png tiff truetype wmf opengl expat gtk
xcomposite alsa -arts dvd dxr3 imagemagick encode ieee1394 ogg xvid
vcd
wavpack win32codecs cddb mng svg midi symlink vorbis slp usb dvb
dvb_cards_usb-dib0700
foomaticdb scanner snmp gimp type1 mp3 flac ladspa
libsamplerate 3dnow sndfile cairo nsplugin mysql opengl uk_rt
uk_bleb "

# put my own ebuilds into /usr/local/portage
PORTDIR_OVERLAY="/usr/local/portage"
# source the layman configuration tool that allow installation of
overlays
source /usr/portage/local/layman/make.conf

# Setup Portage elog
PORTAGE_ELOG_CLASSES="info warn error log"
PORTAGE_ELOG_SYSTEM="save"

# See HOWTO_Use_Portage_Correctly
EMERGE_DEFAULT_OPTS=--deep

# Now that I have 2 cpu core
MAKEOPTS="-j3"
APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon
authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
authz_groupfile authz_host authz_owner authz_user autoindex cache dav
dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter
file_cache filter headers ident imagemap include info log_config logio
mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer
proxy_connect proxy_http rewrite setenvif so speling status unique_id
userdir usertrack vhost_alias"


paul-gentoo ~ # emerge -av gnome-light

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] app-arch/unzip-5.52-r2 [5.52-r1] 0 kB
[ebuild N ] dev-util/gtk-doc-am-1.10-r1 395 kB
[ebuild U ] www-client/mozilla-launcher-1.59 [1.58] 7 kB
[ebuild U ] x11-libs/libxklavier-3.5 [3.3] USE="-doc" 439 kB
[ebuild U ] media-libs/gstreamer-0.10.19 [0.10.17] USE="nls -debug
-test" 2,168 kB
[ebuild U ] dev-perl/XML-Parser-2.36 [2.34-r1] 225 kB
[ebuild U ] x11-wm/metacity-2.22.0 [2.20.2] USE="-debug -xinerama"
2,024 kB
[ebuild N ] x11-themes/gtk-engines-2.14.1 USE="-accessibility
-debug -static" 655 kB
[ebuild U ] dev-perl/XML-LibXML-1.66 [1.65] 271 kB
[ebuild U ] dev-libs/liboil-0.3.14 [0.3.12] USE="-doc" 801 kB
[ebuild U ] x11-libs/libXv-1.0.4 [1.0.3] USE="-debug" 224 kB
[ebuild U ] media-libs/libmad-0.15.1b-r5 [0.15.1b-r4] USE="-debug" 0
kB
[ebuild U ] x11-libs/libXScrnSaver-1.1.3 [1.1.2] USE="-debug" 215
kB
[ebuild U ] media-libs/gst-plugins-base-0.10.19 [0.10.17] USE="nls
-debug" 1,866 kB
[ebuild N ] x11-themes/gnome-themes-2.22.0 USE="-accessibility
-debug" 1,461 kB
[ebuild U ] media-plugins/gst-plugins-gconf-0.10.7 [0.10.6]
USE="-debug" 1,706 kB
[ebuild N ] media-plugins/gst-plugins-dvb-0.10.6 1,736 kB
[ebuild N ] media-plugins/gst-plugins-fluendo-mpegdemux-0.10.15 281
kB
[ebuild N ] media-libs/gst-plugins-bad-0.10.6 USE="-debug" 0 kB
[ebuild U ] media-plugins/gst-plugins-esd-0.10.7 [0.10.6] 0 kB
[ebuild N ] media-libs/gst-plugins-ugly-0.10.7 USE="-debug" 848 kB
[ebuild N ] media-plugins/gst-plugins-a52dec-0.10.7 0 kB
[ebuild N ] media-plugins/gst-plugins-dvdread-0.10.7 0 kB
[ebuild U ] media-plugins/gst-plugins-flac-0.10.7 [0.10.6] 0 kB
[ebuild U ] media-libs/gst-plugins-good-0.10.7 [0.10.6] USE="-debug"
0 kB
[ebuild U ] media-plugins/gst-plugins-mad-0.10.7 [0.10.6] 0 kB
[ebuild U ] gnome-base/gnome-menus-2.22.1 [2.20.3] USE="python
-debug" 452 kB
[ebuild U ] x11-libs/vte-0.16.13 [0.16.12] USE="opengl python -debug
-doc" 1,089 kB
[ebuild U ] kde-base/arts-3.5.9 [3.5.8] USE="alsa esd mp3 vorbis
-artswrappersuid -debug -jack -kdeenablefinal -nas -xinerama" 951 kB
[ebuild N ] media-plugins/gst-plugins-mpeg2dec-0.10.7 0 kB
[ebuild U ] media-plugins/gst-plugins-meta-0.10-r2 [0.10] USE="X
alsa dvb%* dvd%* esd flac%* mad%* mpeg%* ogg%* oss vorbis%* xv -a52%
-ffmpeg% -mythtv% -theora%" 0 kB
[ebuild N ] dev-libs/libgweather-2.22.1.1 USE="-debug" 7,468 kB
[ebuild U ] gnome-base/libgnomekbd-2.22.0 [2.20.0-r1] USE="-debug"
397 kB
[ebuild U ] gnome-extra/evolution-data-server-2.22.1 [1.12.3]
USE="ipv6 kerberos ldap ssl -debug -doc -gnome-keyring% -krb4 (-keyring
%)" 7,424 kB
[ebuild N ] x11-terms/gnome-terminal-2.22.1 USE="-debug" 1,759 kB
[ebuild U ] www-client/mozilla-firefox-2.0.0.14 [2.0.0.12]
USE="gnome* ipv6 java -bindist -debug -filepicker -iceweasel -mozdevelop
-moznopango -restrict-javascript -xforms -xinerama -xprint" LINGUAS="en%
* -af -ar -be -bg -ca -cs -da -de -el -en_GB -en_US% -es -es_AR -es_ES
-eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku
-lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT
-ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 36,663 kB
[ebuild N ] gnome-extra/yelp-2.22.1-r1 USE="-beagle -debug -lzma
-xulrunner" 973 kB
[ebuild U ] gnome-base/gnome-panel-2.22.1.3 [2.20.3] USE="eds -debug
-doc -networkmanager%" 3,176 kB
[ebuild U ] gnome-base/control-center-2.22.1 [2.20.3] USE="alsa eds
esd hal -debug" 2,124 kB
[ebuild N ] gnome-base/gnome-settings-daemon-2.22.1 USE="alsa esd
gstreamer -debug" 1,152 kB
[ebuild N ] gnome-base/gnome-session-2.22.1.1 USE="branding ipv6
tcpd -debug" 832 kB
[ebuild N ] gnome-base/gnome-light-2.22.0 0 kB
[blocks B ] <gnome-base/control-center-2.22 (is blocking
gnome-base/gnome-settings-daemon-2.22.1)
[blocks B ] dev-util/gtk-doc-am (is blocking
dev-util/gtk-doc-1.8-r2)

Total: 42 packages (26 upgrades, 16 new, 2 blocks), Size of downloads:
79,768 kB

!!! Error: The above package list contains packages which cannot be
installed
!!! at the same time on the same system.

For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

paul-gentoo ~ #



--
Transplants Save Lives - http://www.uktransplant.org.uk/

_______ __
( _ ) paul@pkami.e7even.com
| | | | __ __ _ _ 07972184336
| | | | / / /| | | | > 01235 523470
| | | |( () < | |_| |/ ^
|_| |_| \__/\_ \___//_/ \_




--
gentoo-user@lists.gentoo.org mailing list

Tim 05-06-2008 12:57 AM

blocking packages when emerge gnome-light
 
paul wrote:
> I am sure that this is all explained somewhere but I cannot find it
> easily.
>
> When running "emerge -av gnome-light" I get :
> [blocks B ] <gnome-base/control-center-2.22 (is blocking
> gnome-base/gnome-settings-daemon-2.22.1)
> [blocks B ] dev-util/gtk-doc-am (is blocking
> dev-util/gtk-doc-1.8-r2)
>
>
> I am not asking anyone to wade through my make.conf and various portage
> files but if someone who knows the system obviously better than I do
> could please point me in the direction of how to fix this issue I would
> be grateful.
>
> My requirements are "install gnome-light 2.22.0 or later".
>
>
> Thanks
>
> Paul
Paul,

What this means is that you have some software installed on your system
already that prevents you from getting gnome-light. In this case, it
looks like you have the two packages gtk-doc-am and control-center,
which are preventing gnome-settings daemon and gtk-doc, respectively,
from being installed.

The usual way of fixing this problem is to do an emerge -avC on the
packages that are blocking to remove them and allow your gnome-light
installation to proceed. However, remember that some other packages
currently installed on your system may depend on these packages, so you
may not want to go into this blindly. I'm not an expert on the setup of
gnome dependencies, so I can't recommend this course of action
unreservedly; it's just a thought.

In the future, you'll get better (and likely more courteous) responses
if you start your own thread, rather than taking over someone else's.
You would also do well to look through the Gentoo Handbook - there's a
wonderful section at

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=1

that talks at length about blocked packages and what to do to resolve
your issues.

-Tim
--
gentoo-user@lists.gentoo.org mailing list

Ian Graeme Hilt 05-06-2008 02:02 AM

blocking packages when emerge gnome-light
 
On Mon, May 05, 2008 at 10:08:49PM +0100, paul wrote:
[...]
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
[...]

Did you even read this?

<quote>
It is also possible that two packages that are yet to be
installed are blocking each other. In this rare case, you should
find out why you need to install both. In most cases you can do
with one of the packages alone. If not, please file a bug on
Gentoo's bugtracking system.
</quote>

and since you are running unstable,

<quote>
~arch keyword means that the application is not tested
sufficiently to be put in the stable branch. Wait a few days or
weeks and try again.
</quote>

If you don't believe me, visit these links:
<http://packages.gentoo.org/package/gnome-base/control-center?full_cat>
<http://packages.gentoo.org/package/gnome-base/gnome-settings-daemon?full_cat>
<http://packages.gentoo.org/package/dev-util/gtk-doc?full_cat>

--
Ian Graeme Hilt
ian.hilt (at) gmail.com
GnuPG key: 0x4AFC1EE3
--
gentoo-user@lists.gentoo.org mailing list

paul 05-10-2008 09:44 AM

blocking packages when emerge gnome-light
 
On Mon, 2008-05-05 at 19:57 -0500, Tim wrote:
> paul wrote:
> > I am sure that this is all explained somewhere but I cannot find it
> > easily.
> >
> > When running "emerge -av gnome-light" I get :
> > [blocks B ] <gnome-base/control-center-2.22 (is blocking
> > gnome-base/gnome-settings-daemon-2.22.1)
> > [blocks B ] dev-util/gtk-doc-am (is blocking
> > dev-util/gtk-doc-1.8-r2)
> >
> >
> > I am not asking anyone to wade through my make.conf and various portage
> > files but if someone who knows the system obviously better than I do
> > could please point me in the direction of how to fix this issue I would
> > be grateful.
> >
> > My requirements are "install gnome-light 2.22.0 or later".
> >
> >
> > Thanks
> >
> > Paul
> Paul,
>
> What this means is that you have some software installed on your system
> already that prevents you from getting gnome-light. In this case, it
> looks like you have the two packages gtk-doc-am and control-center,
> which are preventing gnome-settings daemon and gtk-doc, respectively,
> from being installed.
>
> The usual way of fixing this problem is to do an emerge -avC on the
> packages that are blocking to remove them and allow your gnome-light
> installation to proceed. However, remember that some other packages
> currently installed on your system may depend on these packages, so you
> may not want to go into this blindly. I'm not an expert on the setup of
> gnome dependencies, so I can't recommend this course of action
> unreservedly; it's just a thought.
>
> In the future, you'll get better (and likely more courteous) responses
> if you start your own thread, rather than taking over someone else's.
> You would also do well to look through the Gentoo Handbook - there's a
> wonderful section at
>
> http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=1
>
> that talks at length about blocked packages and what to do to resolve
> your issues.
>
> -Tim


Thanks Tim

I have now fixed the problem. My confusion was caused by the fact that
when I tried "emerge --unmerge gtk-doc-am" I was told that gtk-doc-am
was not installed. It turns out that gtk-doc was installed and so
running the command "emerge -avC gtk-doc" as you suggested did the job.

I have raised bug 221195 to help clarify the situation.


--
Transplants Save Lives - http://www.uktransplant.org.uk/

_______ __
( _ ) paul@pkami.e7even.com
| | | | __ __ _ _ 07972184336
| | | | / / /| | | | > 01235 523470
| | | |( () < | |_| |/ ^
|_| |_| \__/\_ \___//_/ \_




--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 01:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.