Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Problem with autoconf when building samba (x86_64/AMD64, as stable and experimental packages)... (http://www.linux-archive.org/gentoo-user/81095-problem-autoconf-when-building-samba-x86_64-amd64-stable-experimental-packages.html)

kernel 05-03-2008 06:42 AM

Problem with autoconf when building samba (x86_64/AMD64, as stable and experimental packages)...
 
downgrade to autoconf-2.61-r1

autoconf-2.62 is buggy, you can find various bug reports on bugzilla


On 5/3/08, "Mateusz A. Mierzwiński" <mateuszmierzwinski@o2.pl> wrote:
# emerge -v samba



These are the packages that would be merged, in order:



Calculating dependencies... done!

[ebuild ┬*N ┬* ┬*] net-fs/samba-3.0.28a ┬*USE="acl ads async cups fam ipv6 ldap pam python readline syslog winbind -automount -caps -doc -examples -quotas (-selinux) -swat" LINGUAS="pl -ja" 0 kB



Total: 1 package (1 new), Size of downloads: 0 kB



>>> Verifying ebuild Manifests...



>>> Emerging (1 of 1) net-fs/samba-3.0.28a to /

* samba-3.0.28a.tar.gz RMD160 SHA1 SHA256 size ;-) ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ ok ]

* checking ebuild checksums ;-) ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬*[ ok ]

* checking auxfile checksums ;-) ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ ok ]

* checking miscfile checksums ;-) ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬*[ ok ]

* checking samba-3.0.28a.tar.gz ;-) ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬*[ ok ]

>>> Unpacking source...

>>> Unpacking samba-3.0.28a.tar.gz to /var/tmp/portage/net-fs/samba-3.0.28a/work

* Applying 3.0.26a-lazyldflags.patch ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ ok ]

* Applying 3.0.26a-invalid-free-fix.patch ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬*[ ok ]

* Applying 3.0.28-libcap_detection.patch ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ ok ]

* Applying 3.0.28-fix_broken_readdir_detection.patch ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ ok ]

* Running autoconf -I. -Ilib/replace ... ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ┬* [ !! ]



* Failed Running autoconf !

*

* Include in your bugreport the contents of:

*

* ┬* /var/tmp/portage/net-fs/samba-3.0.28a/temp/autoconf-13269.out



*

* ERROR: net-fs/samba-3.0.28a failed.

* Call stack:

* ┬* ┬* ┬* ┬* ┬* ┬* ┬* ebuild.sh, line ┬* 49: ┬*Called src_unpack

* ┬* ┬* ┬* ┬* ┬* ┬* environment, line 3646: ┬*Called eautoconf '-I.' '-Ilib/replace'

* ┬* ┬* ┬* ┬* ┬* ┬* environment, line 1297: ┬*Called autotools_run_tool 'autoconf' '-I.' '-Ilib/replace'

* ┬* ┬* ┬* ┬* ┬* ┬* environment, line ┬*593: ┬*Called die

* The specific snippet of code:

* ┬* ┬* ┬* ┬* ┬* die "Failed Running $1 !";

* ┬*The die message:

* ┬* Failed Running autoconf !

*

* If you need support, post the topmost build error, and the call stack if relevant.

* A complete build log is located at '/var/tmp/portage/net-fs/samba-3.0.28a/temp/build.log'.

* The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-3.0.28a/temp/environment'.




***** autoconf *****

***** autoconf -I. -Ilib/replace



configure.in:341: error: AC_REQUIRE: circular dependency of AC_AIX

lib/replace/autoconf-2.60.m4:182: AC_USE_SYSTEM_EXTENSIONS is expanded from...

../../lib/autoconf/specific.m4:451: AC_AIX is expanded from...

lib/replace/autoconf-2.60.m4:182: AC_USE_SYSTEM_EXTENSIONS is expanded from...

configure.in:341: the top level

autom4te-2.62: /usr/bin/m4 failed with exit status: 1




--
Easy things should be easy, hard things should at least be possilbe.
Powered by Gentoo Linux


All times are GMT. The time now is 08:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.