FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-02-2008, 12:43 AM
Volker Armin Hemmann
 
Default SMB protocol for Krusader

On Freitag, 2. Mai 2008, Abraham Gyorgy wrote:
> Hello Gentoo users,
>
> I'm trying to enable smb:// support for Krusader. Searching the net I got a
> solution: I have to emerge kde-base/kdebase-kioslaves. (on Ubuntu I had to
> install a very similarly named package to do this).
>
> But unfortunately doing this isnt a good idea, because:
>
> lapitopi gyuszk # emerge -pv kdebase-kioslaves
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild N ] kde-base/kdialog-3.5.8 USE="-arts -debug -kdeenablefinal
> -kdehiddenvisibility -xinerama" 23,633 kB
> [ebuild N ] kde-base/kdebase-kioslaves-3.5.8 USE="-arts -debug -hal
> -kdeenablefinal -kdehiddenvisibility -ldap -openexr -samba -xinerama" 20 kB
> [blocks B ] =kde-base/kdebase-kioslaves-3.5* (is blocking
> kde-base/kdebase-3.5.8-r6)
> [blocks B ] =kde-base/kdebase-3.5* (is blocking
> kde-base/kdebase-kioslaves-3.5.8, kde-base/kdialog-3.5.8)
> [blocks B ] =kde-base/kdialog-3.5* (is blocking
> kde-base/kdebase-3.5.8-r6)
>
> Total: 2 packages (2 new, 3 blocks), Size of downloads: 23,653 kB
>
>
> Maybe kdebase has a use flag for kioslaves...?
>
> lapitopi gyuszk # emerge -pv kdebase
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
> [ebuild R ] kde-base/kdebase-3.5.8-r6 USE="cups pam xscreensaver -arts
> -branding -debug -hal -ieee1394 -java -joystick -kdeenablefinal
> -kdehiddenvisibility -ldap -lm_sensors -logitech-mouse -openexr -opengl
> -samba -xcomposite -xinerama" 23,671 kB
>
>
> No.
>
> Information: I'm running Gentoo amd64, everything up-to-date. Installed
> monolythic kde (emerge kde).
> Can anybody help? Thanks a lot.

there is no flag, because kio-slaves are an integral part of KDE and always
installed with kdebase. So you don't need to install anything.
BUT you need to re-emerge kdebase with the samba useflag. lmsensors, opengl,
hal, java, kdehiddenvisibility, xcomposity would be good ideas too.


--
gentoo-user@lists.gentoo.org mailing list
 
Old 05-02-2008, 07:38 AM
Alan McKinnon
 
Default SMB protocol for Krusader

On Friday 02 May 2008, Abraham Gyorgy wrote:
> Hello Gentoo users,
>
> I'm trying to enable smb:// support for Krusader. Searching the net I
> got a solution: I have to emerge kde-base/kdebase-kioslaves. (on
> Ubuntu I had to install a very similarly named package to do this).
>
> But unfortunately doing this isnt a good idea, because:
>
> lapitopi gyuszk # emerge -pv kdebase-kioslaves
>
> These are the packages that would be merged, in order:

Read the kde upgrade guide at the usual place. You are trying to install
individual packages together with monolithic packages.

--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list
 
Old 05-02-2008, 11:01 AM
"Abraham Gyorgy"
 
Default SMB protocol for Krusader

Well thanks.

lapitopi gyuszk # emerge -pv kdebase

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild* N*** ] sys-apps/xinetd-2.3.14* USE="perl tcpd" 295 kB

[ebuild* N*** ] net-fs/samba-3.0.28* USE="acl cups ipv6 pam python readline -ads -async -automount -caps -doc -examples -fam -ldap -quotas (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl" 17,735 kB

[ebuild** R** ] kde-base/kdebase-3.5.8-r6* USE="cups pam samba* xscreensaver -arts -branding -debug -hal -ieee1394 -java -joystick -kdeenablefinal -kdehiddenvisibility -ldap -lm_sensors -logitech-mouse -openexr -opengl -xcomposite -xinerama" 23,671 kB


Total: 3 packages (2 new, 1 reinstall), Size of downloads: 41,700 kB
lapitopi gyuszk #

I think it's going to work.

2008/5/2, Volker Armin Hemmann <volker.armin.hemmann@tu-clausthal.de>:
On Freitag, 2. Mai 2008, Abraham Gyorgy wrote:
> Hello Gentoo users,
>
> I'm trying to enable smb:// support for Krusader. Searching the net I got a
> solution: I have to emerge kde-base/kdebase-kioslaves. (on Ubuntu I had to

> install a very similarly named package to do this).
>
> But unfortunately doing this isnt a good idea, because:
>
> lapitopi gyuszk # emerge -pv kdebase-kioslaves
>
> These are the packages that would be merged, in order:

>
> Calculating dependencies... done!
> [ebuild**N****] kde-base/kdialog-3.5.8**USE="-arts -debug -kdeenablefinal
> -kdehiddenvisibility -xinerama" 23,633 kB
> [ebuild**N****] kde-base/kdebase-kioslaves-3.5.8**USE="-arts -debug -hal

> -kdeenablefinal -kdehiddenvisibility -ldap -openexr -samba -xinerama" 20 kB
> [blocks B**** ] =kde-base/kdebase-kioslaves-3.5* (is blocking
> kde-base/kdebase-3.5.8-r6)
> [blocks B**** ] =kde-base/kdebase-3.5* (is blocking

> kde-base/kdebase-kioslaves-3.5.8, kde-base/kdialog-3.5.8)
> [blocks B**** ] =kde-base/kdialog-3.5* (is blocking
> kde-base/kdebase-3.5.8-r6)
>
> Total: 2 packages (2 new, 3 blocks), Size of downloads: 23,653 kB

>
>
> Maybe kdebase has a use flag for kioslaves...?
>
> lapitopi gyuszk # emerge -pv kdebase
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!

> [ebuild** R** ] kde-base/kdebase-3.5.8-r6**USE="cups pam xscreensaver -arts
> -branding -debug -hal -ieee1394 -java -joystick -kdeenablefinal
> -kdehiddenvisibility -ldap -lm_sensors -logitech-mouse -openexr -opengl

> -samba -xcomposite -xinerama" 23,671 kB
>
>
> No.
>
> Information: I'm running Gentoo amd64, everything up-to-date. Installed
> monolythic kde (emerge kde).
> Can anybody help? Thanks a lot.



there is no flag, because kio-slaves are an integral part of KDE and always
installed with kdebase. So you don't need to install anything.
BUT you need to re-emerge kdebase with the samba useflag. lmsensors, opengl,

hal, java, kdehiddenvisibility, xcomposity would be good ideas too.



--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 06:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org