FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 04-30-2008, 12:27 AM
John covici
 
Default strange blocks b behavior

I was trying to do an --update --deep --with-bdeps=y world today and
got the following strange message:
[blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
dev-libs/libgweather-2.22.1.1)

Now I have neither of these on my system, so what is the matter -- is
portage insane? I think I have a couple of more like that as well.

Thanks.


--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 03:07 AM
Ian Graeme Hilt
 
Default strange blocks b behavior

On Tuesday 29 April 2008 08:27:57 pm John covici wrote:
> I was trying to do an --update --deep --with-bdeps=y world
> today and got the following strange message:
> [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> dev-libs/libgweather-2.22.1.1)

Looks like you're running unstable. In this case you're supposed
to know what to do. <http://packages.gentoo.org/categories/> may
have some helpful information.

--
Ian Graeme Hilt <ian.hilt@gmail.com>
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 06:00 AM
John covici
 
Default strange blocks b behavior

on Tuesday 04/29/2008 Ian Graeme Hilt(ian.hilt@gmail.com) wrote
> On Tuesday 29 April 2008 08:27:57 pm John covici wrote:
> > I was trying to do an --update --deep --with-bdeps=y world
> > today and got the following strange message:
> > [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> > dev-libs/libgweather-2.22.1.1)
>
> Looks like you're running unstable. In this case you're supposed
> to know what to do. <http://packages.gentoo.org/categories/> may
> have some helpful information.

Hmm, I did find the changelog for one of the packages in question, but
it still makes no sense to me what is happening here -- I am not
running completely unstable, just what portage tells me to unmask,
otherwise the update does not go through at all.

Am I missing something here?

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 06:53 AM
Alan McKinnon
 
Default strange blocks b behavior

On Wednesday 30 April 2008, John covici wrote:
> I was trying to do an --update --deep --with-bdeps=y world today and
> got the following strange message:
> [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> dev-libs/libgweather-2.22.1.1)
>
> Now I have neither of these on my system, so what is the matter -- is
> portage insane? I think I have a couple of more like that as well.

Do you mean that you don't have these packages installed, or that they
are not even in portage? For the second case, re-sync. For the first
case, you need to find out what is pulling those packages in, and make
the necessary changes. This may help, you can also rerun your emerge
world with the "--tree" option to see what is going on:

alan@nazgul ~ $ equery depends -a gnome-applets
[ Searching for packages depending on gnome-applets... ]
gnome-base/gnome-2.20.3 (>=gnome-base/gnome-applets-2.20.1)
gnome-base/gnome-2.22.0 (>=gnome-base/gnome-applets-2.22.0)
gnome-base/gnome-2.22.1 (>=gnome-base/gnome-applets-2.22.1)
gnome-extra/shermans-aquarium-2.2.0 (>=gnome-base/gnome-applets-2)

alan@nazgul ~ $ equery depends -a libgweather
[ Searching for packages depending on libgweather... ]
gnome-base/gnome-2.22.0 (>=dev-libs/libgweather-2.22.0)
gnome-base/gnome-2.22.1 (>=dev-libs/libgweather-2.22.1.1)
gnome-base/gnome-applets-2.22.0 (>=dev-libs/libgweather-2.21.1)
gnome-base/gnome-applets-2.22.1 (>=dev-libs/libgweather-2.22.1)
gnome-base/gnome-panel-2.22.0 (>=dev-libs/libgweather-2.21.2)
gnome-base/gnome-panel-2.22.1.1 (>=dev-libs/libgweather-2.22.1)
gnome-base/gnome-panel-2.22.1.2 (>=dev-libs/libgweather-2.22.1)
gnome-base/gnome-panel-2.22.1.3 (>=dev-libs/libgweather-2.22.1)

Are you sure you didn't emerge gnome?


--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 11:24 AM
John covici
 
Default strange blocks b behavior

on Wednesday 04/30/2008 Alan McKinnon(alan.mckinnon@gmail.com) wrote
> On Wednesday 30 April 2008, John covici wrote:
> > I was trying to do an --update --deep --with-bdeps=y world today and
> > got the following strange message:
> > [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> > dev-libs/libgweather-2.22.1.1)
> >
> > Now I have neither of these on my system, so what is the matter -- is
> > portage insane? I think I have a couple of more like that as well.
>
> Do you mean that you don't have these packages installed, or that they
> are not even in portage? For the second case, re-sync. For the first
> case, you need to find out what is pulling those packages in, and make
> the necessary changes. This may help, you can also rerun your emerge
> world with the "--tree" option to see what is going on:
>
> alan@nazgul ~ $ equery depends -a gnome-applets
> [ Searching for packages depending on gnome-applets... ]
> gnome-base/gnome-2.20.3 (>=gnome-base/gnome-applets-2.20.1)
> gnome-base/gnome-2.22.0 (>=gnome-base/gnome-applets-2.22.0)
> gnome-base/gnome-2.22.1 (>=gnome-base/gnome-applets-2.22.1)
> gnome-extra/shermans-aquarium-2.2.0 (>=gnome-base/gnome-applets-2)
>
> alan@nazgul ~ $ equery depends -a libgweather
> [ Searching for packages depending on libgweather... ]
> gnome-base/gnome-2.22.0 (>=dev-libs/libgweather-2.22.0)
> gnome-base/gnome-2.22.1 (>=dev-libs/libgweather-2.22.1.1)
> gnome-base/gnome-applets-2.22.0 (>=dev-libs/libgweather-2.21.1)
> gnome-base/gnome-applets-2.22.1 (>=dev-libs/libgweather-2.22.1)
> gnome-base/gnome-panel-2.22.0 (>=dev-libs/libgweather-2.21.2)
> gnome-base/gnome-panel-2.22.1.1 (>=dev-libs/libgweather-2.22.1)
> gnome-base/gnome-panel-2.22.1.2 (>=dev-libs/libgweather-2.22.1)
> gnome-base/gnome-panel-2.22.1.3 (>=dev-libs/libgweather-2.22.1)
>
> Are you sure you didn't emerge gnome?
>

Hi. The first case is the correct one -- the packages are in portage,
but the version numbers listed are not on the system -- this is what I
meant -- so I have two packages blocking each other the blocking
versions are not on the system at all which seems strange to me.
I will try the -tree option and see what I get.


--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 11:35 AM
Alan McKinnon
 
Default strange blocks b behavior

On Wednesday 30 April 2008, John covici wrote:
> Hi. *The first case is the correct one -- the packages are in
> portage, but the version numbers listed are not on the system -- this
> is what I meant -- so I have two packages blocking each other the
> blocking versions are not on the system at all which seems strange to
> me. I will try the -tree option and see what I get.

That happens with unstable packages sometimes - DEPEND conflicts.

If you use unstable, you are expected to figure out what is going on,
then file a bug at bugs.gentoo.org :-)

--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 12:43 PM
Neil Bothwick
 
Default strange blocks b behavior

On Wed, 30 Apr 2008 07:24:59 -0400, John covici wrote:

> > > I was trying to do an --update --deep --with-bdeps=y world today
> > > and got the following strange message:
> > > [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> > > dev-libs/libgweather-2.22.1.1)

> Hi. The first case is the correct one -- the packages are in portage,
> but the version numbers listed are not on the system -- this is what I
> meant

Note the < for gnome-applets, this means that a version less than 2.22.0
is causing the blockage. This could be caused by a number of things, for
example earlier version of gnome-applets included libgweather but it is
now in a separate package, so it would conflict with those earlier
versions.

If you have a earlier gnome-applets installed, unmerge it then run the
world update. If it is not pulled in my the update, merge it manually
afterwards.


--
Neil Bothwick

I wonder how much deeper would the ocean be without sponges.
 
Old 04-30-2008, 01:14 PM
John covici
 
Default strange blocks b behavior

on Wednesday 04/30/2008 Neil Bothwick(neil@digimed.co.uk) wrote
> On Wed, 30 Apr 2008 07:24:59 -0400, John covici wrote:
>
> > > > I was trying to do an --update --deep --with-bdeps=y world today
> > > > and got the following strange message:
> > > > [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> > > > dev-libs/libgweather-2.22.1.1)
>
> > Hi. The first case is the correct one -- the packages are in portage,
> > but the version numbers listed are not on the system -- this is what I
> > meant
>
> Note the < for gnome-applets, this means that a version less than 2.22.0
> is causing the blockage. This could be caused by a number of things, for
> example earlier version of gnome-applets included libgweather but it is
> now in a separate package, so it would conflict with those earlier
> versions.
>
> If you have a earlier gnome-applets installed, unmerge it then run the
> world update. If it is not pulled in my the update, merge it manually
> afterwards.
>

I see, its tricky, but I guess it has a logic of its own.

Thanks.

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 03:03 PM
John covici
 
Default strange blocks b behavior

on Wednesday 04/30/2008 John covici(covici@ccs.covici.com) wrote
> on Wednesday 04/30/2008 Neil Bothwick(neil@digimed.co.uk) wrote
> > On Wed, 30 Apr 2008 07:24:59 -0400, John covici wrote:
> >
> > > > > I was trying to do an --update --deep --with-bdeps=y world today
> > > > > and got the following strange message:
> > > > > [blocks B ] <gnome-base/gnome-applets-2.22.0 (is blocking
> > > > > dev-libs/libgweather-2.22.1.1)
> >
> > > Hi. The first case is the correct one -- the packages are in portage,
> > > but the version numbers listed are not on the system -- this is what I
> > > meant
> >
> > Note the < for gnome-applets, this means that a version less than 2.22.0
> > is causing the blockage. This could be caused by a number of things, for
> > example earlier version of gnome-applets included libgweather but it is
> > now in a separate package, so it would conflict with those earlier
> > versions.
> >
> > If you have a earlier gnome-applets installed, unmerge it then run the
> > world update. If it is not pulled in my the update, merge it manually
> > afterwards.
> >
>
> I see, its tricky, but I guess it has a logic of its own.
>
> Thanks.

But now I have still more problems with blocking --
[blocks B ] <media-libs/gst-plugins-ugly-0.10.6-r1 (is blocking
media-libs/gstreamer-0.10.19)
[blocks B ] dev-util/gtk-doc-am (is blocking
dev-util/gtk-doc-1.8-r2)
I don't have either of the blocking packages on my system in any
version! And one of them doesnot have a < so there is something I
don't understand here.


--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-30-2008, 03:06 PM
Neil Bothwick
 
Default strange blocks b behavior

On Wed, 30 Apr 2008 11:03:29 -0400, John covici wrote:

> But now I have still more problems with blocking --
> [blocks B ] <media-libs/gst-plugins-ugly-0.10.6-r1 (is blocking
> media-libs/gstreamer-0.10.19)
> [blocks B ] dev-util/gtk-doc-am (is blocking
> dev-util/gtk-doc-1.8-r2)

Please show the whole output of your world update command, with the
--tree option added. By taking the error message out of context, you make
it difficult to see what is happening.


--
Neil Bothwick

Anything worth fighting for is worth fighting dirty for.
 

Thread Tools




All times are GMT. The time now is 11:31 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org