Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   emerge virtual/emacs fails (http://www.linux-archive.org/gentoo-user/77770-emerge-virtual-emacs-fails.html)

Roger Mason 04-28-2008 12:00 PM

emerge virtual/emacs fails
 
Hello,

Has anyone else run into this:

emerge virtual/emacs

[snip]

>>> Unpacking m4-1.4.11.tar.lzma to /var/tmp/portage/m4-1.4.11/work
unpack m4-1.4.11.tar.lzma: file format not recognized. Ignoring.
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/m4-1.4.11 ...

!!! ERROR: sys-devel/m4-1.4.11 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
m4-1.4.11.ebuild, line 23: Called econf '--enable-nls'
'--enable-changeword'
ebuild.sh, line 543: Called die

!!! no configure script found
!!! If you need support, post the topmost build error, and the call
!!! stack if relevant.

I looked on bugzilla, where it was suggested to run:

emerge -1 app-arch/lzma-utils

I did that but the error on m4 persists.

If anyone has a workaround, please pass it on.

Thanks,
Roger
--
gentoo-user@lists.gentoo.org mailing list

Justin 04-28-2008 12:14 PM

emerge virtual/emacs fails
 
Roger Mason schrieb:

Hello,

Has anyone else run into this:

emerge virtual/emacs

[snip]



Unpacking m4-1.4.11.tar.lzma to /var/tmp/portage/m4-1.4.11/work


unpack m4-1.4.11.tar.lzma: file format not recognized. Ignoring.


Source unpacked.
Compiling source in /var/tmp/portage/m4-1.4.11 ...



!!! ERROR: sys-devel/m4-1.4.11 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
m4-1.4.11.ebuild, line 23: Called econf '--enable-nls'
'--enable-changeword'
ebuild.sh, line 543: Called die

!!! no configure script found
!!! If you need support, post the topmost build error, and the call
!!! stack if relevant.

I looked on bugzilla, where it was suggested to run:

emerge -1 app-arch/lzma-utils

I did that but the error on m4 persists.

If anyone has a workaround, please pass it on.

Thanks,
Roger


First try to do

rm -rv /var/tmp/portage/*


and emerge it again.

Roger Mason 04-28-2008 08:03 PM

emerge virtual/emacs fails
 
Justin <justin@j-schmitz.net> writes:

>>
>> !!! ERROR: sys-devel/m4-1.4.11 failed.
>>
>> I looked on bugzilla, where it was suggested to run:
>>
>> emerge -1 app-arch/lzma-utils
>>
>> I did that but the error on m4 persists.
>>
>> If anyone has a workaround, please pass it on.
>>
>> Thanks,
>> Roger
>>
> First try to do
>
> rm -rv /var/tmp/portage/*
>
>
> and emerge it again.

Thanks Justin, unfortunately that did not work: I have exactly the
same error.

Cheers,
Roger
--
gentoo-user@lists.gentoo.org mailing list

Justin 04-29-2008 07:52 AM

emerge virtual/emacs fails
 
Roger Mason schrieb:

Hello,

Has anyone else run into this:

emerge virtual/emacs

[snip]



Unpacking m4-1.4.11.tar.lzma to /var/tmp/portage/m4-1.4.11/work

Something is wrong with your portage PATHs, because it wants to unpack
to /var/tmp/portage/m4-1.4.11/work and not to
/var/tmp/portage/sys-devel/m4-1.4.11/work! (noticed the sys-devel!?)


Check your make.conf, the output of emerge --info and the output of
printenv if there are some settings going wrong.

dany2a 04-30-2008 12:06 PM

emerge virtual/emacs fails
 
Roger Mason wrote:
>
> [snip]
> unpack m4-1.4.11.tar.lzma: file format not recognized. Ignoring.
> [snip]
> emerge -1 app-arch/lzma-utils
>
> I did that but the error on m4 persists.
>
> If anyone has a workaround, please pass it on.
>
>
You've got to update portage first, looks like you have an older portage
version, that cannot handle lzma. Had the same prob and updating portage was
the fix (besides installing lzma-utils).
emerge -a1 portage

--
View this message in context: http://www.nabble.com/emerge-virtual-emacs-fails-tp16937589p16978720.html
Sent from the gentoo-user mailing list archive at Nabble.com.

--
gentoo-user@lists.gentoo.org mailing list

Roger Mason 05-01-2008 05:02 PM

emerge virtual/emacs fails
 
dany2a <dany2a@web.de> writes:

> You've got to update portage first, looks like you have an older portage
> version, that cannot handle lzma. Had the same prob and updating portage was
> the fix (besides installing lzma-utils).
> emerge -a1 portage

That was it.

Thanks very much.

Cheers,
Roger
--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 10:24 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.