FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 04-24-2008, 12:26 PM
Daniel D Jones
 
Default QCA

emerge -uDvat world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[ebuild NS ] app-crypt/qca-1.0-r2 0 kB
[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Total: 1 package (1 in new slot, 1 block), Size of downloads: 0 kB

!!! Error: The above package list contains packages which cannot be installed
!!! at the same time on the same system.


Can anyone tell me what's causing this? qca version 2 is installed. I can
unmerge and then re-emerge it. Why is the system trying to install version
1? If it's a dependency, shouldn't the depending file be listed?

Thanks in advance.

--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-24-2008, 12:43 PM
Dirk Heinrichs
 
Default QCA

Am Donnerstag, 24. April 2008 schrieb ext Daniel D Jones:
> emerge -uDvat world
>
> These are the packages that would be merged, in reverse order:
>
> Calculating world dependencies... done!
> [ebuild NS ] app-crypt/qca-1.0-r2 0 kB
> [blocks B ] <app-crypt/qca-1.0-r3 (is blocking
> app-crypt/qca-2.0.0-r2)
>
> Total: 1 package (1 in new slot, 1 block), Size of downloads: 0 kB
>
> !!! Error: The above package list contains packages which cannot be
> installed !!! at the same time on the same system.
>
> Can anyone tell me what's causing this? qca version 2 is installed. I
> can unmerge and then re-emerge it. Why is the system trying to install
> version 1? If it's a dependency, shouldn't the depending file be listed?

qca-2.0 is causing this. It's blocking <qca-1.0-r3. So update 1.0 from r2 to
r3.

As for the deps, a quick grep through the portage tree showed some KDE
packages as well as "psi".

HTH...

Dirk
--
Dirk Heinrichs | Tel: +49 (0)162 234 3408
Configuration Manager | Fax: +49 (0)211 47068 111
Capgemini Deutschland | Mail: dirk.heinrichs@capgemini.com
Wanheimerstraße 68 | Web: http://www.capgemini.com
D-40468 Düsseldorf | ICQ#: 110037733
GPG Public Key C2E467BB | Keyserver: www.keyserver.net
 
Old 04-24-2008, 01:03 PM
Alan McKinnon
 
Default QCA

On Thursday 24 April 2008, Daniel D Jones wrote:
> emerge -uDvat world
>
> These are the packages that would be merged, in reverse order:
>
> Calculating world dependencies... done!
> [ebuild NS ] app-crypt/qca-1.0-r2 0 kB
> [blocks B ] <app-crypt/qca-1.0-r3 (is blocking
> app-crypt/qca-2.0.0-r2)
>
> Total: 1 package (1 in new slot, 1 block), Size of downloads: 0 kB
>
> !!! Error: The above package list contains packages which cannot be
> installed !!! at the same time on the same system.
>
>
> Can anyone tell me what's causing this? qca version 2 is installed.
> I can unmerge and then re-emerge it. Why is the system trying to
> install version 1? If it's a dependency, shouldn't the depending
> file be listed?

qca is recently slotted. The latest version in SLOT 0 works with SLOT 2,
but nothing earlier.

run 'equery depends qca' to find out if you really do need it and what
is pulling it in (or emerge -t). You can always:

emerge -avC qca:0 ; emerge -av qca:0

to fix it if you do want it


--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 09:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org