FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 04-16-2008, 07:28 PM
Michael Schmarck
 
Default Circular dependencies when USE=gnome and emerging world

Hello.

I'm installing a new machine and use 2008.0_beta1 i686 stage3. I
use the 2008.0/desktop profile.

When I do "emerge -DuvatN world", I get an error to the effect,
that there are circular dependencies. Please see below.

I'd like to know, if anyone else ran into this problem and how it
got solved. At the end of the message, you'll also find emerge --info.

Thanks a lot!

winnb000488 etc # USE="gnome" emerge -DuvptN world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge ] gnome-base/nautilus-2.22.2 USE="X -beagle -debug gnome -tracker"
[nomerge ] gnome-base/libgnome-2.22.0 USE="-debug -doc -esd"
[nomerge ] gnome-base/gnome-vfs-2.22.0 USE="acl avahi -debug doc fam gnutls hal -ipv6 -kerberos samba ssl"
[nomerge ] gnome-base/gnome-mount-0.6 USE="-debug gnome"
[nomerge ] gnome-base/libgnomeui-2.22.1 USE="-debug -doc jpeg"
[ebuild N ] gnome-base/libbonoboui-2.22.0 USE="X -debug -doc"
[ebuild N ] gnome-base/libgnome-2.22.0 USE="-debug -doc -esd"
[ebuild N ] gnome-base/gnome-vfs-2.22.0 USE="acl avahi -debug doc fam gnutls hal -ipv6 -kerberos samba ssl"
[ebuild N ] net-dns/avahi-0.6.22-r1 USE="autoipd bookmarks dbus doc gdbm gtk -howl-compat -ipv6 mdnsresponder-compat -mono python qt3 qt4 -test"
[ebuild N ] app-doc/doxygen-1.5.5 USE="-debug -doc -nodot qt3 -tetex"
[ebuild N ] media-gfx/graphviz-2.18 USE="doc -examples gnome gtk -java jpeg nls perl png python -ruby -tcl -tk"
[ebuild N ] gnome-base/libgnomeui-2.22.1 USE="-debug -doc jpeg"
[ebuild N ] dev-python/twisted-web-0.7.0
[ebuild N ] dev-python/twisted-2.5.0 USE="crypt gtk -serial"
[ebuild N ] dev-python/pyopenssl-0.7 USE="doc"
[ebuild N ] dev-tex/latex2html-2002.2.1_pre20041025-r1 USE="gif png"
[ebuild N ] x11-libs/qt-4.3.4-r1 USE="-accessibility cups dbus -debug -doc -examples -firebird gif -glib jpeg -mng -mysql -nas -nis -odbc opengl pch png -postgres qt3support -sqlite -sqlite3 ssl tiff xinerama zlib" INPUT_DEVICES="-wacom"
[ebuild N ] net-fs/samba-3.0.28a USE="acl -ads -async -automount -caps cups doc -examples fam -ipv6 ldap pam python -quotas readline (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl"
[nomerge ] gnome-base/gnome-mount-0.6 USE="-debug gnome"
[nomerge ] gnome-base/nautilus-2.22.2 USE="X -beagle -debug gnome -tracker"
[nomerge ] gnome-base/gvfs-0.2.3 USE="avahi bluetooth -cdda -debug doc fuse gnome -gphoto2 hal keyring -samba"
[nomerge ] net-dns/avahi-0.6.22-r1 USE="autoipd bookmarks dbus doc gdbm gtk -howl-compat -ipv6 mdnsresponder-compat -mono python qt3 qt4 -test"
[nomerge ] sys-apps/dbus-1.2.1 USE="X -debug doc (-selinux)"
[nomerge ] app-doc/doxygen-1.5.5 USE="-debug -doc -nodot qt3 -tetex"
[ebuild N ] x11-libs/qt-3.3.8-r4 USE="cups -debug -doc -examples -firebird gif -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc opengl -postgres -sqlite xinerama"
[ebuild N ] virtual/ghostscript-0
[ebuild N ] app-text/ghostscript-gpl-8.62 USE="X -bindist -cjk cups -djvu gtk -jpeg2k"
[ebuild N ] net-print/cups-1.3.7-r1 USE="X acl avahi dbus -java jpeg -kerberos ldap nls pam perl -php png ppds python samba -slp ssl -static tiff zeroconf" LINGUAS="de -en -es -et -fr -he -it -ja -pl -sv -zh_TW"
[ebuild N ] dev-python/dbus-python-0.82.4 USE="-test"
[ebuild N ] gnome-base/gnome-keyring-2.22.1 USE="-debug doc hal pam -test"
[ebuild N ] sys-apps/dbus-1.2.1 USE="X -debug doc (-selinux)"
[nomerge ] gnome-base/nautilus-2.22.2 USE="X -beagle -debug gnome -tracker"
[nomerge ] gnome-base/libgnomeui-2.22.1 USE="-debug -doc jpeg"
[nomerge ] x11-libs/gtk+-2.12.9-r2 USE="X cups -debug -doc jpeg tiff -vim-syntax xinerama"
[nomerge ] x11-base/xorg-server-1.4.0.90-r3 USE="-3dfx -debug -dmx dri hal -ipv6 -kdrive -minimal (-nptl) sdl xorg -xprint" INPUT_DEVICES="-acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick keyboard -magellan -microtouch mouse -mutouch -palmax -penmount -spaceorb -summa synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="-amd -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc nv nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa vga -via -vmware -voodoo -xgi"
[ebuild N ] x11-apps/xinit-1.0.8-r2 USE="-debug hal -minimal pam"
[ebuild N ] sys-auth/consolekit-0.2.3 USE="-debug pam"
[ebuild N ] sys-apps/hal-0.5.10 USE="acpi -apm crypt -debug dell -disk-partition -doc laptop (-selinux)"
[ebuild N ] dev-libs/dbus-glib-0.74 USE="-debug -doc (-selinux)"
[ebuild N ] gnome-base/libgnomecanvas-2.20.1.1 USE="X -debug -doc"
[nomerge ] net-print/foomatic-filters-ppds-20070501
[nomerge ] net-print/foomatic-filters-3.0.20070501 USE="cups"
[nomerge ] net-print/cups-1.3.7-r1 USE="X acl avahi dbus -java jpeg -kerberos ldap nls pam perl -php png ppds python samba -slp ssl -static tiff zeroconf" LINGUAS="de -en -es -et -fr -he -it -ja -pl -sv -zh_TW"
[nomerge ] net-dns/avahi-0.6.22-r1 USE="autoipd bookmarks dbus doc gdbm gtk -howl-compat -ipv6 mdnsresponder-compat -mono python qt3 qt4 -test"
[nomerge ] dev-python/twisted-2.5.0 USE="crypt gtk -serial"
[ebuild N ] dev-python/pygtk-2.12.1 USE="X -doc -examples"
[ebuild N ] x11-base/xorg-server-1.4.0.90-r3 USE="-3dfx -debug -dmx dri hal -ipv6 -kdrive -minimal (-nptl) sdl xorg -xprint" INPUT_DEVICES="-acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick keyboard -magellan -microtouch mouse -mutouch -palmax -penmount -spaceorb -summa synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="-amd -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc nv nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa vga -via -vmware -voodoo -xgi"
[nomerge ] gnome-base/libbonoboui-2.22.0 USE="X -debug -doc"
[nomerge ] gnome-base/libgnomecanvas-2.20.1.1 USE="X -debug -doc"
[ebuild N ] gnome-base/gail-1.22.1 USE="-debug -doc"
[ebuild N ] gnome-base/libglade-2.6.2 USE="-debug -doc"
[ebuild N ] gnome-base/gconf-2.22.0 USE="-debug doc ldap"
[ebuild N ] x11-libs/gtk+-2.12.9-r2 USE="X cups -debug -doc jpeg tiff -vim-syntax xinerama"
[nomerge ] gnome-base/gnome-mount-0.6 USE="-debug gnome"
[nomerge ] x11-libs/libnotify-0.4.4 USE="doc"
[nomerge ] x11-misc/notification-daemon-0.3.7 USE="-debug"
[nomerge ] x11-libs/gtk+-2.12.9-r2 USE="X cups -debug -doc jpeg tiff -vim-syntax xinerama"
[nomerge ] net-print/cups-1.3.7-r1 USE="X acl avahi dbus -java jpeg -kerberos ldap nls pam perl -php png ppds python samba -slp ssl -static tiff zeroconf" LINGUAS="de -en -es -et -fr -he -it -ja -pl -sv -zh_TW"
[ebuild N ] x11-misc/xdg-utils-1.0.2-r1 USE="-doc"
[nomerge ] gnome-base/nautilus-2.22.2 USE="X -beagle -debug gnome -tracker"
[ebuild N ] gnome-base/libbonobo-2.22.0 USE="-debug -doc"
[ebuild N ] gnome-base/orbit-2.14.12 USE="-debug -doc"
[ebuild N ] dev-libs/libIDL-0.8.10 USE="-debug"
[nomerge ] net-dns/avahi-0.6.22-r1 USE="autoipd bookmarks dbus doc gdbm gtk -howl-compat -ipv6 mdnsresponder-compat -mono python qt3 qt4 -test"
[nomerge ] dev-python/pygtk-2.12.1 USE="X -doc -examples"
[ebuild N ] dev-python/pygobject-2.14.1 USE="-debug -doc -examples"
[nomerge ] x11-misc/xdg-utils-1.0.2-r1 USE="-doc"
[ebuild N ] x11-misc/shared-mime-info-0.23-r1
[nomerge ] x11-libs/qt-4.3.4-r1 USE="-accessibility cups dbus -debug -doc -examples -firebird gif -glib jpeg -mng -mysql -nas -nis -odbc opengl pch png -postgres qt3support -sqlite -sqlite3 ssl tiff xinerama zlib" INPUT_DEVICES="-wacom"
[nomerge ] net-print/cups-1.3.7-r1 USE="X acl avahi dbus -java jpeg -kerberos ldap nls pam perl -php png ppds python samba -slp ssl -static tiff zeroconf" LINGUAS="de -en -es -et -fr -he -it -ja -pl -sv -zh_TW"
[nomerge ] net-fs/samba-3.0.28a USE="acl -ads -async -automount -caps cups doc -examples fam -ipv6 ldap pam python -quotas readline (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl"
[ebuild N ] app-admin/gamin-0.1.9-r1 USE="-debug python"
[nomerge ] gnome-base/gnome-mount-0.6 USE="-debug gnome"
[nomerge ] gnome-base/eel-2.22.1 USE="X -debug"
[nomerge ] gnome-base/gail-1.22.1 USE="-debug -doc"
[ebuild N ] dev-libs/atk-1.22.0 USE="-debug -doc"
[nomerge ] gnome-base/nautilus-2.22.2 USE="X -beagle -debug gnome -tracker"
[nomerge ] gnome-base/eel-2.22.1 USE="X -debug"
[nomerge ] gnome-base/libgnomeui-2.22.1 USE="-debug -doc jpeg"
[ebuild N ] x11-libs/pango-1.20.2 USE="X -debug -doc"
[ebuild N ] dev-libs/glib-2.16.3 USE="-debug -doc fam -hardened (-selinux) xattr"
!!! Error: circular dependencies:

('ebuild', '/', 'gnome-base/gail-1.22.1', 'merge') depends on
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/atk-1.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libbonoboui-2.22.0', 'merge') depends on
('ebuild', '/', 'gnome-base/libbonobo-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomecanvas-2.20.1.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.22.0', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnome-2.22.0', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') depends on
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/orbit-2.14.12', 'merge') (hard)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') depends on
('ebuild', '/', 'app-text/ghostscript-gpl-8.62', 'merge') (medium)
('ebuild', '/', 'x11-misc/shared-mime-info-0.23-r1', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/libbonobo-2.22.0', 'merge') depends on
('ebuild', '/', 'gnome-base/orbit-2.14.12', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-python/twisted-2.5.0', 'merge') depends on
('ebuild', '/', 'dev-python/pyopenssl-0.7', 'merge') (hard)
('ebuild', '/', 'dev-python/pygtk-2.12.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') depends on
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') (hard)
('ebuild', '/', 'x11-misc/shared-mime-info-0.23-r1', 'merge') (hard)
('ebuild', '/', 'dev-libs/atk-1.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnome-2.22.0', 'merge') depends on
('ebuild', '/', 'gnome-base/libbonobo-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.22.0', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') depends on
('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)
('ebuild', '/', 'dev-python/pygtk-2.12.1', 'merge') depends on
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/atk-1.22.0', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-python/pygobject-2.14.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') depends on
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/atk-1.22.0', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-tex/latex2html-2002.2.1_pre20041025-r1', 'merge') depends on
('ebuild', '/', 'app-text/ghostscript-gpl-8.62', 'merge') (hard)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') (hard)
('ebuild', '/', 'sys-apps/hal-0.5.10', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.74', 'merge') (hard)
('ebuild', '/', 'media-gfx/graphviz-2.18', 'merge') depends on
('ebuild', '/', 'gnome-base/libgnomeui-2.22.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.74', 'merge') depends on
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomeui-2.22.1', 'merge') depends on
('ebuild', '/', 'gnome-base/gnome-keyring-2.22.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libbonoboui-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnome-2.22.0', 'merge') (hard)
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomecanvas-2.20.1.1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.22.0', 'merge') depends on
('ebuild', '/', 'sys-apps/hal-0.5.10', 'merge') (hard)
('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)
('ebuild', '/', 'net-dns/avahi-0.6.22-r1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') (hard)
('ebuild', '/', 'net-fs/samba-3.0.28a', 'merge') (hard)
('ebuild', '/', 'x11-misc/shared-mime-info-0.23-r1', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.74', 'merge') (hard)
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') depends on
('ebuild', '/', 'app-doc/doxygen-1.5.5', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') depends on
('ebuild', '/', 'sys-apps/hal-0.5.10', 'merge') (hard)
('ebuild', '/', 'x11-apps/xinit-1.0.8-r2', 'merge') (hard)
('ebuild', '/', 'x11-libs/qt-3.3.8-r4', 'merge') depends on
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') (hard)
('ebuild', '/', 'x11-misc/xdg-utils-1.0.2-r1', 'merge') depends on
('ebuild', '/', 'x11-misc/shared-mime-info-0.23-r1', 'merge') (medium)
('ebuild', '/', 'net-fs/samba-3.0.28a', 'merge') depends on
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') (hard)
('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') (hard)
('ebuild', '/', 'dev-python/dbus-python-0.82.4', 'merge') depends on
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.74', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomecanvas-2.20.1.1', 'merge') depends on
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') (hard)
('ebuild', '/', 'gnome-base/gail-1.22.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') (hard)
('ebuild', '/', 'sys-auth/consolekit-0.2.3', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.74', 'merge') (hard)
('ebuild', '/', 'dev-libs/libIDL-0.8.10', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'x11-libs/pango-1.20.2', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') depends on
('ebuild', '/', 'net-dns/avahi-0.6.22-r1', 'merge') (hard)
('ebuild', '/', 'app-text/ghostscript-gpl-8.62', 'merge') (medium-soft)
('ebuild', '/', 'net-fs/samba-3.0.28a', 'merge') (medium-soft)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') (medium-soft)
('ebuild', '/', 'x11-misc/xdg-utils-1.0.2-r1', 'merge') (medium)
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'x11-apps/xinit-1.0.8-r2', 'merge') depends on
('ebuild', '/', 'sys-auth/consolekit-0.2.3', 'merge') (hard)
('ebuild', '/', 'app-admin/gamin-0.1.9-r1', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-python/pyopenssl-0.7', 'merge') depends on
('ebuild', '/', 'dev-tex/latex2html-2002.2.1_pre20041025-r1', 'merge') (hard)
('ebuild', '/', 'app-text/ghostscript-gpl-8.62', 'merge') depends on
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'dev-python/twisted-web-0.7.0', 'merge') depends on
('ebuild', '/', 'dev-python/twisted-2.5.0', 'merge') (hard)
('ebuild', '/', 'net-dns/avahi-0.6.22-r1', 'merge') depends on
('ebuild', '/', 'dev-python/pygtk-2.12.1', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'dev-python/dbus-python-0.82.4', 'merge') (hard)
('ebuild', '/', 'x11-libs/qt-4.3.4-r1', 'merge') (hard)
('ebuild', '/', 'app-doc/doxygen-1.5.5', 'merge') (hard)
('ebuild', '/', 'gnome-base/libglade-2.6.2', 'merge') (hard)
('ebuild', '/', 'dev-python/twisted-web-0.7.0', 'merge') (hard)
('ebuild', '/', 'dev-python/twisted-2.5.0', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'x11-libs/qt-3.3.8-r4', 'merge') (hard)
('ebuild', '/', 'dev-python/pygobject-2.14.1', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-keyring-2.22.1', 'merge') depends on
('ebuild', '/', 'sys-apps/hal-0.5.10', 'merge') (hard)
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'x11-libs/gtk+-2.12.9-r2', 'merge') (hard)
('ebuild', '/', 'gnome-base/gconf-2.22.0', 'merge') (hard)
('ebuild', '/', 'x11-libs/qt-4.3.4-r1', 'merge') depends on
('ebuild', '/', 'net-print/cups-1.3.7-r1', 'merge') (hard)
('ebuild', '/', 'sys-apps/dbus-1.2.1', 'merge') (hard)
('ebuild', '/', 'app-doc/doxygen-1.5.5', 'merge') depends on
('ebuild', '/', 'app-text/ghostscript-gpl-8.62', 'merge') (hard)
('ebuild', '/', 'media-gfx/graphviz-2.18', 'merge') (hard)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') (hard)
('ebuild', '/', 'x11-libs/qt-3.3.8-r4', 'merge') (hard)
('ebuild', '/', 'gnome-base/orbit-2.14.12', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)
('ebuild', '/', 'dev-libs/libIDL-0.8.10', 'merge') (hard)
('ebuild', '/', 'dev-libs/atk-1.22.0', 'merge') depends on
('ebuild', '/', 'dev-libs/glib-2.16.3', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.

winnb000488 etc # emerge --info
Portage 2.1.5_rc4 (default/linux/x86/2008.0/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.24-tuxonice-r5.r08.mit-ide-mod_2 i686)
================================================== ===============
System uname: 2.6.24-tuxonice-r5.r08.mit-ide-mod_2 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Timestamp of tree: Wed, 16 Apr 2008 12:45:01 +0000
app-shells/bash: 3.2_p33
dev-lang/python: 2.4.4-r6, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.2.2
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.62
sys-devel/automake: 1.5, 1.10.1
sys-devel/binutils: 2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/gentoo-release /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
DISTDIR="/Gentoo/Portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="buildpkg ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://ftp.heanet.ie/pub/gentoo/ http://ftp.gentoo.or.kr/ http://distfiles.gentoo.org/ http://www.ibiblio.org/pub/Linux/distributions/gentoo "
LANG="de_CH.UTF-8"
LDFLAGS=""
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/Gentoo/Portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/Gentoo/Portage/build"
PORTDIR="/Gentoo/Portage/tree"
PORTDIR_OVERLAY="/Gentoo/Portage/local-tree/misc"
SYNC="rsync://winds06:10873/gentoo-portage"
USE="X acl acpi alsa avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dmi doc dri dvd dvdr dvdread encode fam firefox fortran gdbm gif gnutls gpm gstreamer gtk hal iconv isdnlog jpeg kde kdeenablefinal kdehiddenvisibility keyring ldap libnotify mad midi mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl pam pcmcia pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg tcpd tiff truetype unicode vorbis wifi win32codecs x86 xattr xine xinerama xml xorg xv zlib" ALSA_CARDS="hda-intel intel8x0 intel8x0m usb-audio usb-usx3y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfil
e authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="ptp2 directory" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nv nvidia vga none"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Michael Schmarck
--
Distinctive, adj.:
A different color or shape than our competitors.


--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-17-2008, 05:30 AM
Michael Schmarck
 
Default Circular dependencies when USE=gnome and emerging world

Justin Findlay <justin@jfindlay.us> wrote:

> On AD 2008 April 16 Wednesday 09:28:48 PM +0200, Michael Schmarck wrote:
>> Hello.
>>
>> I'm installing a new machine and use 2008.0_beta1 i686 stage3. I
>> use the 2008.0/desktop profile.
>>
>> When I do "emerge -DuvatN world", I get an error to the effect,
>> that there are circular dependencies. Please see below.
>>
>> I'd like to know, if anyone else ran into this problem and how it
>> got solved. At the end of the message, you'll also find emerge --info.
>>
>> Thanks a lot!
>>
>> winnb000488 etc # USE="gnome" emerge -DuvptN world
>
> I'd try the merge world without setting USE="gnome" first, and then
> later enable it by putting gnome in your /etc/make.conf USE setting.

gnome is in the desktop profile of 2008.0.

> If
> you want to be more clever about it/save some time, you can try to
> figure out the problematic packages

*THAT* was the point of my question I hoped that somebody else
already ran into this issue and solved

> and just temporarily disable gnome
> on them via /etc/portage/package.mask/,

You mean package.use, don't you?

Best regards,
Michael

--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-26-2008, 02:59 PM
Enrico Weigelt
 
Default Circular dependencies when USE=gnome and emerging world

* Michael Schmarck <michael.schmarck@habmalnefrage.de> wrote:

Hi,

> When I do "emerge -DuvatN world", I get an error to the effect,
> that there are circular dependencies. Please see below.

you might try to build the leafs of the tree step by step and
report back which of the packages are actually broken.


cu
--
---------------------------------------------------------------------
Enrico Weigelt == metux IT service - http://www.metux.de/
---------------------------------------------------------------------
Please visit the OpenSource QM Taskforce:
http://wiki.metux.de/public/OpenSource_QM_Taskforce
Patches / Fixes for a lot dozens of packages in dozens of versions:
http://patches.metux.de/
---------------------------------------------------------------------
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 10:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org