FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 09-25-2012, 10:19 PM
Silvio Siefke
 
Default Problems with update

Hello,

i want run the update and emerge ever give message:

gentoo-desk doxygen # emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=gnome-base/gvfs-1.10.1[udisks,udev]" have been masked.
!!! One of the following masked packages is required to complete your request:
- gnome-base/gvfs-1.14.0::gentoo (masked by: package.mask, ~x86 keyword)
/usr/portage/profiles/package.mask:
# Alexandre Rostovtsev <tetromino@gentoo.org> (25 Sep 2012)
# GNOME 3.6 mask
# Core libraries to be unmasked first:

- gnome-base/gvfs-1.12.3::gentoo (masked by: ~x86 keyword)
- gnome-base/gvfs-1.12.2-r1::gentoo (masked by: ~x86 keyword)

(dependency required by "xfce-base/thunar-1.4.0[udev]" [installed])
(dependency required by "xfce-extra/thunar-volman-0.8.0" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I understand not, on my laptop is the same configuration, the same
use flags and there is no problem. When i set the Keyword then i must
take udev, gvfs, zlib and some other programs in unmask and at end
run the update not.

Someone a idea? Thanx for help.

Silvio

make.conf http://nopaste.info/ac26f483de.html
package.use http://nopaste.info/484c02131b.html
package.unmask http://nopaste.info/31b7988985.html
package.accept_keywords http://nopaste.info/a9b89cea61.html
 
Old 09-26-2012, 07:54 AM
Michael Hampicke
 
Default Problems with update

Am 26.09.2012 00:19, schrieb Silvio Siefke:
> Hello,
>
> i want run the update and emerge ever give message:
>
> gentoo-desk doxygen # emerge --update --newuse --deep --with-bdeps=y @world
> Calculating dependencies... done!
>
> !!! All ebuilds that could satisfy ">=gnome-base/gvfs-1.10.1[udisks,udev]" have been masked.
> !!! One of the following masked packages is required to complete your request:
> - gnome-base/gvfs-1.14.0::gentoo (masked by: package.mask, ~x86 keyword)
> /usr/portage/profiles/package.mask:
> # Alexandre Rostovtsev <tetromino@gentoo.org> (25 Sep 2012)
> # GNOME 3.6 mask
> # Core libraries to be unmasked first:
>
> - gnome-base/gvfs-1.12.3::gentoo (masked by: ~x86 keyword)
> - gnome-base/gvfs-1.12.2-r1::gentoo (masked by: ~x86 keyword)
>
> (dependency required by "xfce-base/thunar-1.4.0[udev]" [installed])
> (dependency required by "xfce-extra/thunar-volman-0.8.0" [installed])
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
> For more information, see the MASKED PACKAGES section in the emerge
> man page or refer to the Gentoo Handbook.

Try disabling the "udisks" useflag for gnome-base/gvfs
 
Old 09-26-2012, 10:52 AM
Silvio Siefke
 
Default Problems with update

On Wed, 26 Sep 2012 09:54:40 +0200
Michael Hampicke <gentoo-user@hadt.biz> wrote:

> Try disabling the "udisks" useflag for gnome-base/gvfs

Have the prob is same. Why i must unmask gvfs, i understand it not.
When i set autounmask=y and autounmask-write portage write this
configuration:

/etc/portage/package.use
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-$
=sys-fs/lvm2-2.02.88 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-$
>=dev-libs/libgcrypt-1.5.0-r2 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-$
=sys-apps/util-linux-2.21.2 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-$
>=dev-libs/popt-1.16-r1 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-$
=dev-libs/libgpg-error-1.10 static-libs
#required by xfce-base/thunar-1.4.0[udev], required by @selected, required by @$
=gnome-base/gvfs-1.12.3 udisks udev

/etc/portage/package.accept_keywords
#required by sys-fs/udisks-1.99.0-r1, required by gnome-base/gvfs-1.12.3[udisks], required by @selected, required by @world (argument)
=sys-auth/polkit-0.107-r1 ~x86
#required by gnome-base/gvfs-1.12.3[udisks], required by @selected, required by @world (argument)
=sys-fs/udisks-1.99.0-r1 ~x86
#required by x11-libs/vte-0.30.1-r3, required by dev-util/anjuta-3.2.2, required by @selected, required by @world (argument)
=dev-libs/glib-2.32.4 ~x86
#required by sys-fs/udev-191[openrc], required by sys-fs/udisks-1.99.0-r1, required by gnome-base/gvfs-1.12.3[udisks], required by @selected, r$
=sys-fs/udev-init-scripts-16 ~x86
#required by sys-fs/udev-191, required by sys-fs/udev-init-scripts-16
=sys-apps/kmod-10 ~x86
#required by sys-apps/kmod-10[zlib], required by sys-fs/udev-191, required by sys-fs/udev-init-scripts-16
=sys-libs/zlib-1.2.7 ~x86
#required by xfce-base/thunar-1.4.0[dbus,xfce_plugins_trash], required by @selected, required by @world (argument)
=gnome-base/gvfs-1.12.3 ~x86
#required by sys-fs/udisks-1.99.0-r1, required by gnome-base/gvfs-1.12.3[udisks], required by @selected, required by @world (argument)
=dev-util/gdbus-codegen-2.32.4 ~x86
#required by sys-fs/udev-191[hwdb], required by sys-fs/udev-init-scripts-16
=sys-apps/hwids-20120922 ~x86
#required by sys-fs/udev-init-scripts-16
=sys-fs/udev-191 ~x86
#required by sys-auth/polkit-0.107-r1, required by sys-fs/udisks-1.99.0-r1, required by gnome-base/gvfs-1.12.3[udisks], required by @selected, $
=dev-lang/spidermonkey-1.8.5-r1 ~x86

I do not understand why Portage goes this way. I have in make.conf
-static-libs. Now I have to put unmask and static-libs use. Rely
primarily static-libs at the end require more and more programs.
Where hides the error? Thank you for help.


Silvio
 

Thread Tools




All times are GMT. The time now is 08:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org