FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 08-11-2012, 03:02 AM
Andrew Lowe
 
Default Still got problems with help2man and Perl

Hi all,

******

HAAAA!!! No problems now. Whilst writing this, and doing the steps, the
problem has now resolved. Read on if you have any interest in Perl and
portage going feral.....


******

I made a post about a week ago regarding this, got a few replies,
accidentally deleted said replies, had work get in the way, etc etc - a
typical week in other words. Anyway, I've tracked down the replies in
the archives and had a bit of a fiddle. So to recap:


1) Did an "emerge --sync" this morning.

2) Perl 2.16 was built, successfully

3) help2man was next up. During the config stage, "Check this, checking
that...", it fails with:


"configure: error: perl module Locale::gettext required"

According to emerge I have V1.50.0 of Locale-gettext installed.

4) Googling mentions running perl-cleaner so I give

"perl-cleaner --reallyall"

a try and end up with:

*******************

.
..
...
....
....
....
....
[ebuild R ] virtual/perl-Module-Build-0.400.200 0 kB
[ebuild R ] dev-perl/File-BaseDir-0.30.0 USE="-test" 0 kB
[ebuild R ] dev-perl/Error-0.170.180 USE="-test" 0 kB
[ebuild R ] dev-perl/File-DesktopEntry-0.40.0 USE="-test" 0 kB
[ebuild UD ] dev-lang/perl-5.12.3-r1 [5.16.1] USE="berkdb gdbm
-build% -debug -doc -ithreads" 0 kB

[ebuild R ] dev-perl/DBI-1.622.0 USE="-test" 0 kB
[ebuild R ] dev-perl/Locale-gettext-1.50.0 0 kB
[ebuild R ] dev-perl/File-MimeInfo-0.160.0 USE="-test" 0 kB
[ebuild R ] dev-vcs/subversion-1.7.5 USE="berkdb kde nls perl
webdav-neon -apache2 -ctypes-python -debug -doc -dso -extras
-gnome-keyring -java -python -ruby -sasl -vim-syntax -webdav-serf" 0 kB
[ebuild R ] dev-vcs/git-1.7.8.6 USE="blksha1 curl iconv perl
python subversion threads webdav -cgi -cvs -doc -emacs -gtk (-ppcsha1)
-tk -xinetd" 0 kB

[ebuild R ] dev-perl/DBD-mysql-4.20.0 USE="-embedded" 0 kB

Total: 117 packages (12 upgrades, 1 downgrade, 4 new, 100 reinstalls),
Size of downloads: 2,491 kB


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

(dev-lang/perl-5.12.3-r1::gentoo, ebuild scheduled for merge) pulled
in by
~dev-lang/perl-5.12.3 required by
(virtual/perl-Sys-Syslog-0.27::gentoo, installed)


(dev-lang/perl-5.16.1::gentoo, installed) pulled in by
=dev-lang/perl-5.16* required by
(virtual/perl-libnet-1.220.0-r1::gentoo, installed)

(and 9 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.62::gentoo (masked by:
AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at
'/usr/portage/licenses/AdobeFlash-10.3'.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

* perl-cleaner is stopping here:
* Fix the problem and start perl-cleaner again.


*******************

Basically, if I'm reading this correctly, it appears that that
perl-cleaner wants to downgrade perl, 5.16 -> 5.12 and there is some
sort of slot conflict.


5) Would it be safe to mask 5.12 of Perl? From what I'm seeing,
perl-Sys-Syslog-0.27 seems to want it.


6) Checking version of perl-Sys-Syslog reveals that I have 0.27 and
there is a 0.29 that no updates seem to be catching. So I'll manually
update that - done successfully.


7) Perl-cleaner again - It worked this time.

8) "emerge -NuD world" again - SUCCESS, help2man done and now onto the
200 odd KDE thingies that want to be updated......


Looks like I'm now good to go

Regards,
Andrew
 

Thread Tools




All times are GMT. The time now is 08:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org