Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Printer isn't working. Help, please! (http://www.linux-archive.org/gentoo-user/686047-printer-isnt-working-help-please.html)

Alan Mackenzie 07-21-2012 05:58 PM

Printer isn't working. Help, please!
 
Evening, Experts!

My printer isn't printing.

More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
the printer. When I click on "Find New Printers" it comes back with
"Available Printers - No Printers Found.".

My system has been like this since I converted back from mdev to udev.
Though I have just built Linux 3.3.8 in the hope that a new kernel build
would help. ;-(.

Help would be most appreciated.

TIA!

--
Alan Mackenzie (Nuremberg, Germany).

Michael Mol 07-21-2012 11:44 PM

Printer isn't working. Help, please!
 
On Sat, Jul 21, 2012 at 1:58 PM, Alan Mackenzie <acm@muc.de> wrote:
> Evening, Experts!
>
> My printer isn't printing.
>
> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
> the printer. When I click on "Find New Printers" it comes back with
> "Available Printers - No Printers Found.".
>
> My system has been like this since I converted back from mdev to udev.
> Though I have just built Linux 3.3.8 in the hope that a new kernel build
> would help. ;-(.
>
> Help would be most appreciated.

What kind of printer? How is it connected to the computer?

What USE flags do you have enabled for the CUPS build? If you
re-emerge CUPS, it will spit some warnings at you if it detects
problems with your kernel configuration.

--
:wq

Nilesh Govindrajan 07-22-2012 03:16 AM

Printer isn't working. Help, please!
 
On Sun, Jul 22, 2012 at 5:14 AM, Michael Mol <mikemol@gmail.com> wrote:
> On Sat, Jul 21, 2012 at 1:58 PM, Alan Mackenzie <acm@muc.de> wrote:
>> Evening, Experts!
>>
>> My printer isn't printing.
>>
>> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
>> the printer. When I click on "Find New Printers" it comes back with
>> "Available Printers - No Printers Found.".
>>
>> My system has been like this since I converted back from mdev to udev.
>> Though I have just built Linux 3.3.8 in the hope that a new kernel build
>> would help. ;-(.
>>
>> Help would be most appreciated.
>
> What kind of printer? How is it connected to the computer?
>
> What USE flags do you have enabled for the CUPS build? If you
> re-emerge CUPS, it will spit some warnings at you if it detects
> problems with your kernel configuration.
>
> --
> :wq
>

Personally I prefer enabling USB printer support in kernel instead of
cups (both of them are mutually exclusive!). Because, cupsd sometimes
chokes when you shut off and on the printer many times. Once that
happened I switched to kernel support and never faced the problem
again.

Nilesh Govindrajan 07-22-2012 03:17 AM

Printer isn't working. Help, please!
 
On Sun, Jul 22, 2012 at 8:46 AM, Nilesh Govindrajan
<contact@nileshgr.com> wrote:
> On Sun, Jul 22, 2012 at 5:14 AM, Michael Mol <mikemol@gmail.com> wrote:
>> On Sat, Jul 21, 2012 at 1:58 PM, Alan Mackenzie <acm@muc.de> wrote:
>>> Evening, Experts!
>>>
>>> My printer isn't printing.
>>>
>>> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
>>> the printer. When I click on "Find New Printers" it comes back with
>>> "Available Printers - No Printers Found.".
>>>
>>> My system has been like this since I converted back from mdev to udev.
>>> Though I have just built Linux 3.3.8 in the hope that a new kernel build
>>> would help. ;-(.
>>>
>>> Help would be most appreciated.
>>
>> What kind of printer? How is it connected to the computer?
>>
>> What USE flags do you have enabled for the CUPS build? If you
>> re-emerge CUPS, it will spit some warnings at you if it detects
>> problems with your kernel configuration.
>>
>> --
>> :wq
>>
>
> Personally I prefer enabling USB printer support in kernel instead of
> cups (both of them are mutually exclusive!). Because, cupsd sometimes
> chokes when you shut off and on the printer many times. Once that
> happened I switched to kernel support and never faced the problem
> again.

If you have HP printer, install hplip package. Read cups logs in
/var/log/cups or whatever.

Thanasis 07-22-2012 04:15 AM

Printer isn't working. Help, please!
 
on 07/21/2012 08:58 PM Alan Mackenzie wrote the following:
> Evening, Experts!
>
> My printer isn't printing.
>
> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
> the printer. When I click on "Find New Printers" it comes back with
> "Available Printers - No Printers Found.".
>
> My system has been like this since I converted back from mdev to udev.
> Though I have just built Linux 3.3.8 in the hope that a new kernel build
> would help. ;-(.
>
> Help would be most appreciated.
>
> TIA!
>

Edit /etc/cups/cupsd.conf and set "Browsing On",
afterwards re-start or reload cups.

Alan Mackenzie 07-22-2012 09:07 AM

Printer isn't working. Help, please!
 
On Sat, Jul 21, 2012 at 07:44:51PM -0400, Michael Mol wrote:
> On Sat, Jul 21, 2012 at 1:58 PM, Alan Mackenzie <acm@muc.de> wrote:
> > Evening, Experts!

> > My printer isn't printing.

> > More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
> > the printer. When I click on "Find New Printers" it comes back with
> > "Available Printers - No Printers Found.".

> > My system has been like this since I converted back from mdev to udev.
> > Though I have just built Linux 3.3.8 in the hope that a new kernel build
> > would help. ;-(.

> > Help would be most appreciated.

> What kind of printer? How is it connected to the computer?

It's an old Samsung ML-1450, connected by a USB cable. The printer, of
itself, works fine. It prints on my "mdev system".

> What USE flags do you have enabled for the CUPS build?

# emerge -pv cups gives:

[ebuild R ] net-print/cups-1.5.2-r4 USE="X acl dbus filters jpeg
ldap pam perl png python ssl threads tiff usb -avahi -debug -gnutls -java
-kerberos -slp -static-libs -xinetd" LINGUAS="-da -de -es -eu -fi -fr -id
-it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB

In particular, I've got usb set there. In my kernel config,

# CONFIG_USB_PRINTER is not set

, although I've tried setting it too, to no avail.

> If you re-emerge CUPS, it will spit some warnings at you if it detects
> problems with your kernel configuration.

It gave me no warnings.

> --
> :wq

--
Alan Mackenzie (Nuremberg, Germany).

Paul Hartman 07-24-2012 02:48 PM

Printer isn't working. Help, please!
 
On Sat, Jul 21, 2012 at 12:58 PM, Alan Mackenzie <acm@muc.de> wrote:
> Evening, Experts!
>
> My printer isn't printing.
>
> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
> the printer. When I click on "Find New Printers" it comes back with
> "Available Printers - No Printers Found.".
>
> My system has been like this since I converted back from mdev to udev.
> Though I have just built Linux 3.3.8 in the hope that a new kernel build
> would help. ;-(.
>
> Help would be most appreciated.
>
> TIA!

I had to blacklist the usblp module for CUPS to work with my printer. FWIW. :)

Nilesh Govindrajan 07-25-2012 02:42 AM

Printer isn't working. Help, please!
 
On Jul 24, 2012 8:19 PM, "Paul Hartman" <paul.hartman+gentoo@gmail.com> wrote:

>

> On Sat, Jul 21, 2012 at 12:58 PM, Alan Mackenzie <acm@muc.de> wrote:

> > Evening, Experts!

> >

> > My printer isn't printing.

> >

> > More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find

> > the printer. *When I click on "Find New Printers" it comes back with

> > "Available Printers - No Printers Found.".

> >

> > My system has been like this since I converted back from mdev to udev.

> > Though I have just built Linux 3.3.8 in the hope that a new kernel build

> > would help. *;-(.

> >

> > Help would be most appreciated.

> >

> > TIA!

>

> I had to blacklist the usblp module for CUPS to work with my printer. FWIW. :)

>


I think compiling without usb support is more sensible there.

Dale 07-25-2012 02:54 AM

Printer isn't working. Help, please!
 
Paul Hartman wrote:
> On Sat, Jul 21, 2012 at 12:58 PM, Alan Mackenzie <acm@muc.de> wrote:
>> Evening, Experts!
>>
>> My printer isn't printing.
>>
>> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
>> the printer. When I click on "Find New Printers" it comes back with
>> "Available Printers - No Printers Found.".
>>
>> My system has been like this since I converted back from mdev to udev.
>> Though I have just built Linux 3.3.8 in the hope that a new kernel build
>> would help. ;-(.
>>
>> Help would be most appreciated.
>>
>> TIA!
> I had to blacklist the usblp module for CUPS to work with my printer. FWIW. :)
>
>


I think I read something about this a while back. Maybe google can turn
up a reason why since my memory is like a screen door, only catches some
stuff but lets everything else flow right through. ;-)

Since I have not had any trouble with my printer, I bet it was on this
mailing list or KDE's mailing list. Those are the only two I subscribe
to.

Dale

:-) :-)

--
I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

Bill Kenworthy 07-25-2012 03:18 AM

Printer isn't working. Help, please!
 
On Tue, 2012-07-24 at 21:54 -0500, Dale wrote:
> Paul Hartman wrote:
> > On Sat, Jul 21, 2012 at 12:58 PM, Alan Mackenzie <acm@muc.de> wrote:
> >> Evening, Experts!
> >>
> >> My printer isn't printing.
> >>
> >> More precisely, when in CUPS 1.5.2 (localhost:631), CUPS fails to find
> >> the printer. When I click on "Find New Printers" it comes back with
> >> "Available Printers - No Printers Found.".
> >>
> >> My system has been like this since I converted back from mdev to udev.
> >> Though I have just built Linux 3.3.8 in the hope that a new kernel build
> >> would help. ;-(.
> >>
> >> Help would be most appreciated.
> >>
> >> TIA!
> > I had to blacklist the usblp module for CUPS to work with my printer. FWIW. :)
> >
> >
>
>
> I think I read something about this a while back. Maybe google can turn
> up a reason why since my memory is like a screen door, only catches some
> stuff but lets everything else flow right through. ;-)
>
> Since I have not had any trouble with my printer, I bet it was on this
> mailing list or KDE's mailing list. Those are the only two I subscribe
> to.
>
> Dale
>
> :-) :-)
>

This broke my printing as well - I went the route of taking the module
out of the kernel config. But what I didnt resolve to my satisfaction,
is what is the best solution? - there are two that work but which
*should* we use?

BillK


All times are GMT. The time now is 01:15 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.