Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Really confusing situation (http://www.linux-archive.org/gentoo-user/68235-really-confusing-situation.html)

Michael Sullivan 04-11-2008 04:05 PM

Really confusing situation
 
I do a daily emerge --sync and emerge -avuD world, but today when I did
it, this came up:

camille ~ # emerge -pvuD world

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

app-crypt/gnupg:0

('ebuild', '/', 'app-crypt/gnupg-1.4.7-r1', 'merge') pulled in by
('installed', '/', 'mail-client/squirrelmail-1.4.10a-r2', 'nomerge')

('ebuild', '/', 'app-crypt/gnupg-2.0.7-r1', 'merge') pulled in by
('installed', '/', 'app-crypt/gpgme-1.1.6', 'nomerge')
('installed', '/', 'kde-base/kdepim-3.5.8', 'nomerge')
('installed', '/', 'mail-filter/spamassassin-3.2.1-r1', 'nomerge')
(and 2 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

... done!
[ebuild N ] app-crypt/gnupg-1.4.7-r1 USE="bzip2 nls readline usb
zlib -bindist -curl -ecc -idea -ldap (-selinux) -smartcard -static"
LINGUAS="-ru" 0 kB
[ebuild N ] app-crypt/gnupg-2.0.7-r1 USE="bzip2 doc nls -ldap
-openct -pcsc-lite (-selinux) -smartcard" 0 kB

Total: 2 packages (2 new), Size of downloads: 0 kB
camille ~ # emerge -pvC app-crypt/gnupg

>>> These are the packages that would be unmerged:

--- Couldn't find 'app-crypt/gnupg' to unmerge.

>>> No packages selected for removal by unmerge

As you can see, gnupg is not installed, yet it is in the way, and emerge
wants to install it. Should I submit this as a bug?

--
gentoo-user@lists.gentoo.org mailing list

"Andrey Falko" 04-11-2008 04:24 PM

Really confusing situation
 
On Fri, Apr 11, 2008 at 12:05 PM, Michael Sullivan
<michael@espersunited.com> wrote:
> I do a daily emerge --sync and emerge -avuD world, but today when I did
> it, this came up:
>
> camille ~ # emerge -pvuD world
>
> These are the packages that would be merged, in order:
>
> Calculating world dependencies |
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> app-crypt/gnupg:0
>
> ('ebuild', '/', 'app-crypt/gnupg-1.4.7-r1', 'merge') pulled in by
> ('installed', '/', 'mail-client/squirrelmail-1.4.10a-r2', 'nomerge')
>
> ('ebuild', '/', 'app-crypt/gnupg-2.0.7-r1', 'merge') pulled in by
> ('installed', '/', 'app-crypt/gpgme-1.1.6', 'nomerge')
> ('installed', '/', 'kde-base/kdepim-3.5.8', 'nomerge')
> ('installed', '/', 'mail-filter/spamassassin-3.2.1-r1', 'nomerge')
> (and 2 more)
>
>
> It may be possible to solve this problem by using package.mask to
> prevent one of those packages from being selected. However, it is also
> possible that conflicting dependencies exist such that they are
> impossible to satisfy simultaneously. If such a conflict exists in the
> dependencies of two different packages, then those packages can not be
> installed simultaneously.
>
> For more information, see MASKED PACKAGES section in the emerge man page
> or refer to the Gentoo Handbook.
>
> ... done!
> [ebuild N ] app-crypt/gnupg-1.4.7-r1 USE="bzip2 nls readline usb
> zlib -bindist -curl -ecc -idea -ldap (-selinux) -smartcard -static"
> LINGUAS="-ru" 0 kB
> [ebuild N ] app-crypt/gnupg-2.0.7-r1 USE="bzip2 doc nls -ldap
> -openct -pcsc-lite (-selinux) -smartcard" 0 kB
>
> Total: 2 packages (2 new), Size of downloads: 0 kB
> camille ~ # emerge -pvC app-crypt/gnupg
>
> >>> These are the packages that would be unmerged:
>
> --- Couldn't find 'app-crypt/gnupg' to unmerge.
>
> >>> No packages selected for removal by unmerge
>
> As you can see, gnupg is not installed, yet it is in the way, and emerge
> wants to install it. Should I submit this as a bug?
>
> --
> gentoo-user@lists.gentoo.org mailing list
>
>

I had something like this before...do you have anything in you
package.keywords or package.mask ?
--
gentoo-user@lists.gentoo.org mailing list

Tim 04-12-2008 04:19 PM

Really confusing situation
 
Michael Sullivan wrote:
> I do a daily emerge --sync and emerge -avuD world, but today when I did
> it, this came up:
>
> camille ~ # emerge -pvuD world
>
> These are the packages that would be merged, in order:
>
> Calculating world dependencies |
> !!! Multiple versions within a single package slot have been
> !!! pulled into the dependency graph:
>
> app-crypt/gnupg:0
>
> ('ebuild', '/', 'app-crypt/gnupg-1.4.7-r1', 'merge') pulled in by
> ('installed', '/', 'mail-client/squirrelmail-1.4.10a-r2', 'nomerge')
>
> ('ebuild', '/', 'app-crypt/gnupg-2.0.7-r1', 'merge') pulled in by
> ('installed', '/', 'app-crypt/gpgme-1.1.6', 'nomerge')
> ('installed', '/', 'kde-base/kdepim-3.5.8', 'nomerge')
> ('installed', '/', 'mail-filter/spamassassin-3.2.1-r1', 'nomerge')
> (and 2 more)
>
>
> It may be possible to solve this problem by using package.mask to
> prevent one of those packages from being selected. However, it is also
> possible that conflicting dependencies exist such that they are
> impossible to satisfy simultaneously. If such a conflict exists in the
> dependencies of two different packages, then those packages can not be
> installed simultaneously.
>
> For more information, see MASKED PACKAGES section in the emerge man page
> or refer to the Gentoo Handbook.
>
> ... done!
> [ebuild N ] app-crypt/gnupg-1.4.7-r1 USE="bzip2 nls readline usb
> zlib -bindist -curl -ecc -idea -ldap (-selinux) -smartcard -static"
> LINGUAS="-ru" 0 kB
> [ebuild N ] app-crypt/gnupg-2.0.7-r1 USE="bzip2 doc nls -ldap
> -openct -pcsc-lite (-selinux) -smartcard" 0 kB
>
> Total: 2 packages (2 new), Size of downloads: 0 kB
> camille ~ # emerge -pvC app-crypt/gnupg
>
>>>> These are the packages that would be unmerged:
>
> --- Couldn't find 'app-crypt/gnupg' to unmerge.
>
>>>> No packages selected for removal by unmerge
>
> As you can see, gnupg is not installed, yet it is in the way, and emerge
> wants to install it. Should I submit this as a bug?
>


Looking at the ebuilds, both gnupg-1.4.7-r1 and gnupg-2.0.7-r1 occupy
SLOT 0, which is the cause of the initial error. However,
squirrelmail-1.4.10a-r2 depends explicitly on gnupg-1.4*, while
spamassassin only requires gnupg (any version). What you can try is to
emerge -1 =app-crypt/gnupg-1.4.7-r1, then retry your emerge -puvD world.
This should satisfy the dependency on both packages.

-Tim
--
gentoo-user@lists.gentoo.org mailing list

Jil Larner 04-12-2008 05:46 PM

Really confusing situation
 
Hi,

I had this and masked v2. Actually, this is IMO not a bug because you
can't slot two gnupg installations. You must chose between 1.x stable
lightweight and 2.x branch. Don't hesitate to take a look at the gnupg
website ;)


Sincerely,
Jil

Tim a écrit :

Michael Sullivan wrote:

I do a daily emerge --sync and emerge -avuD world, but today when I did
it, this came up:

camille ~ # emerge -pvuD world

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:


app-crypt/gnupg:0

('ebuild', '/', 'app-crypt/gnupg-1.4.7-r1', 'merge') pulled in by
('installed', '/', 'mail-client/squirrelmail-1.4.10a-r2', 'nomerge')

('ebuild', '/', 'app-crypt/gnupg-2.0.7-r1', 'merge') pulled in by
('installed', '/', 'app-crypt/gpgme-1.1.6', 'nomerge')
('installed', '/', 'kde-base/kdepim-3.5.8', 'nomerge')
('installed', '/', 'mail-filter/spamassassin-3.2.1-r1', 'nomerge')
(and 2 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

... done!
[ebuild N ] app-crypt/gnupg-1.4.7-r1 USE="bzip2 nls readline usb
zlib -bindist -curl -ecc -idea -ldap (-selinux) -smartcard -static"
LINGUAS="-ru" 0 kB
[ebuild N ] app-crypt/gnupg-2.0.7-r1 USE="bzip2 doc nls -ldap
-openct -pcsc-lite (-selinux) -smartcard" 0 kB


Total: 2 packages (2 new), Size of downloads: 0 kB
camille ~ # emerge -pvC app-crypt/gnupg


These are the packages that would be unmerged:

--- Couldn't find 'app-crypt/gnupg' to unmerge.


No packages selected for removal by unmerge

As you can see, gnupg is not installed, yet it is in the way, and emerge
wants to install it. Should I submit this as a bug?




Looking at the ebuilds, both gnupg-1.4.7-r1 and gnupg-2.0.7-r1 occupy
SLOT 0, which is the cause of the initial error. However,
squirrelmail-1.4.10a-r2 depends explicitly on gnupg-1.4*, while
spamassassin only requires gnupg (any version). What you can try is to
emerge -1 =app-crypt/gnupg-1.4.7-r1, then retry your emerge -puvD world.
This should satisfy the dependency on both packages.

-Tim

--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 09:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.