FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 07-04-2012, 11:47 AM
Yohan Pereira
 
Default Suspend, hibernate and mount stopped working as a regular user.

Hi,
This happened after a recent world upgrade. I am currently using kde 4.8.4.
I can however suspend, hibernate using the pm-utils as root. Google has
lead me to believe this has something to do with consolekit. I found this
thread [1] which is more or less what I am experiencing (I can't mount
too). Running that dbus command gives me the same output mentioned
there.

yohan@powerslave ~ $ dbus-send --system --print-reply
--dest="org.freedesktop.UPower" /org/freedesktop/UPower
org.freedesktop.UPower.Suspend
Error org.freedesktop.UPower.GeneralError: not authorized

However I am not sure how to solve this. I don't have an .xinitrc file in my
home folder. So I looked at /etc/X11/xinit/xinitrc.d/, I tried removing
the file called 90-consolekit, which didn't help.

Anybody has any idea how to proceed in debugging this problem? any use
full output I can post?I have this feeling that I missed some important
piece of information from my portage log. I skimmed over summary.log
nothing caught my attention.

[1]https://bbs.archlinux.org/viewtopic.php?id=141337

--

- Yohan Pereira

The difference between a Miracle and a Fact is exactly the difference
between a mermaid and a seal.
-- Mark Twain
 
Old 07-04-2012, 12:48 PM
Alex Schuster
 
Default Suspend, hibernate and mount stopped working as a regular user.

Yohan Pereira writes:

> This happened after a recent world upgrade. I am currently using kde
> 4.8.4. I can however suspend, hibernate using the pm-utils as root.
> Google has lead me to believe this has something to do with consolekit.

Or maybe sys-auth/polkit? There were issues lately with a nonexisting
home directory, the elog message tells us to fix this with:

usermod -d "/var/lib/polkit-1" "polkitd"

Wonko
 
Old 07-04-2012, 01:29 PM
Yohan Pereira
 
Default Suspend, hibernate and mount stopped working as a regular user.

On 07/04/12 at 02:48pm, Alex Schuster wrote:
> Or maybe sys-auth/polkit? There were issues lately with a nonexisting
> home directory, the elog message tells us to fix this with:
>
> usermod -d "/var/lib/polkit-1" "polkitd"
>
> Wonko
>

Hi,
Thanks for the reply. Oddly the only polkit related message in my
summary.log is something about the user group wheel being changed to adm.
I ran your command though it says "no changes". The path is already set
in /etc/passwd.

--

- Yohan Pereira

The difference between a Miracle and a Fact is exactly the difference
between a mermaid and a seal.
-- Mark Twain
 

Thread Tools




All times are GMT. The time now is 06:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org