Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   x11-base/xorg-server 1.12.2 fails after upgrade (http://www.linux-archive.org/gentoo-user/679523-x11-base-xorg-server-1-12-2-fails-after-upgrade.html)

Alan McKinnon 07-03-2012 01:25 AM

x11-base/xorg-server 1.12.2 fails after upgrade
 
On Mon, 2 Jul 2012 21:14:01 -0400
David Kuhl <dhkuhl1108@gmail.com> wrote:

> I just upgraged my gentoo box after three months and now when I run
> startx X fails. This has happened before, but all I had to do was
> update my x11 drivers and it would work. I use evdev and don't have
> a xorg.conf file. Below is the xorg-server installed, qlist of x11
> drivers, the lspci -k output, and the Xorg log. I see the error in
> the log. It looks like: (EE) AIGLX error: r600 does not export
> required DRI extension. How should I fix this? Thanks.


> [ 199.752] (II) [KMS] drm report modesetting isn't supported.


Enable KMS in the kernel and try again.

Google is full of reports of this exact problem going back to April,
with solutions.

--
Alan McKinnnon
alan.mckinnon@gmail.com

David Kuhl 07-03-2012 01:55 AM

x11-base/xorg-server 1.12.2 fails after upgrade
 
I have a problem building the kernel too. I use genkernel with source
3.2.1 but the latest --sync brought in 3.3.8 which builds the kernel
but fails on building the initramsfs. Something about now finding an
ext2 header; however, when I searched for it I found in in the source
tree. Do I need to fix the kernel problem first and get KMS in?

On 7/2/12, Alan McKinnon <alan.mckinnon@gmail.com> wrote:
> On Mon, 2 Jul 2012 21:14:01 -0400
> David Kuhl <dhkuhl1108@gmail.com> wrote:
>
>> I just upgraged my gentoo box after three months and now when I run
>> startx X fails. This has happened before, but all I had to do was
>> update my x11 drivers and it would work. I use evdev and don't have
>> a xorg.conf file. Below is the xorg-server installed, qlist of x11
>> drivers, the lspci -k output, and the Xorg log. I see the error in
>> the log. It looks like: (EE) AIGLX error: r600 does not export
>> required DRI extension. How should I fix this? Thanks.
>
>
>> [ 199.752] (II) [KMS] drm report modesetting isn't supported.
>
>
> Enable KMS in the kernel and try again.
>
> Google is full of reports of this exact problem going back to April,
> with solutions.
>
> --
> Alan McKinnnon
> alan.mckinnon@gmail.com
>
>


All times are GMT. The time now is 07:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.