FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-25-2012, 12:41 PM
1126
 
Default revdep-rebuild keeps repeating the same steps

Hello list!

When I run revdep-rebuild, it keeps repeating the same steps over and over
again.

Here is what I mean:

* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 36% ] * broken /usr/lib32/libavdevice.so.53.4.100 (requires
libpulse-simple.so.0
libpulse.so.0)
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* /usr/lib32/libavdevice.so.53.4.100 ->
app-emulation/emul-linux-x86-medialibs
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --complete-graph=y --oneshot app-emulation/emul-linux-x86-medialibs:0
..........
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
* emul-linux-x86-medialibs-20120520.tar.xz RMD160 SHA1 SHA256 size ;-) ...
[ ok ]
>>> Unpacking source...
>>> Unpacking emul-linux-x86-medialibs-20120520.tar.xz to
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>> Source unpacked in
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>> Preparing source in
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source prepared.
>>> Configuring source in
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source configured.
>>> Compiling source in
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/emul-linux-x86-medialibs-20120520

>>> Install emul-linux-x86-medialibs-20120520 into
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/ category
app-emulation
>>> Completed installing emul-linux-x86-medialibs-20120520 into
/var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/


* QA Notice: The following files contain runtime text relocations
* Text relocations force the dynamic linker to perform extra
* work at startup, waste system resources, and may pose a security
* risk. On some architectures, the code may not even function
* properly, if at all.
* For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
* Please include the following list of files in your report:
* TEXTREL usr/lib32/libx264.so.120


>>> Installing (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.
* Build finished correctly. Removing temporary files...
* You can re-run revdep-rebuild to verify that all libraries and binaries
* are fixed. Possible reasons for remaining inconsistencies include:
* orphaned files
* deep dependencies
* packages installed outside of portage's control
* specially-evaluated libraries


It keeps complaining about libavdevice.so and them re-emerges
app-emulation/emul-linux-x86-medialibs-20120520.


When I would re-run it right now, it would again complain about libavdevice and
would again re-emerge app-emulation/emul-linux-x86-medialibs..

Has anyone any idea how to fix this?

Thanks in advance,
Christian.
 
Old 05-25-2012, 12:47 PM
Markos Chandras
 
Default revdep-rebuild keeps repeating the same steps

On Fri, May 25, 2012 at 1:41 PM, 1126
<mailinglists@elfsechsundzwanzig.de> wrote:
> Hello list!
>
> When I run revdep-rebuild, it keeps repeating the same steps over and over
> again.
>
> Here is what I mean:
>
> ** Configuring search environment for revdep-rebuild
>
> ** Checking reverse dependencies
> ** Packages containing binaries and libraries broken by a package update
> ** will be emerged.
>
> ** Collecting system binaries and libraries
> ** Generated new 1_files.rr
> ** Collecting complete LD_LIBRARY_PATH
> ** Generated new 2_ldpath.rr
> ** Checking dynamic linking consistency
> [ 36% ] ** * broken /usr/lib32/libavdevice.so.53.4.100 (requires
> libpulse-simple.so.0
> libpulse.so.0)
> [ 100% ]
> ** Generated new 3_broken.rr
> ** Assigning files to packages
> ** * /usr/lib32/libavdevice.so.53.4.100 ->
> app-emulation/emul-linux-x86-medialibs
> ** Generated new 4_raw.rr and 4_owners.rr
> ** Cleaning list of packages to rebuild
> ** Generated new 4_pkgs.rr
> ** Assigning packages to ebuilds
> ** Generated new 4_ebuilds.rr
> ** Evaluating package order
> ** Generated new 5_order.rr
> ** All prepared. Starting rebuild
> emerge --complete-graph=y --oneshot * app-emulation/emul-linux-x86-medialibs:0
> ..........
> Calculating dependencies... done!
>
>>>> Verifying ebuild manifests
>
>>>> Emerging (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
> ** emul-linux-x86-medialibs-20120520.tar.xz RMD160 SHA1 SHA256 size ;-) ...
> [ ok ]
>>>> Unpacking source...
>>>> Unpacking emul-linux-x86-medialibs-20120520.tar.xz to
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>>> Source unpacked in
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>>> Preparing source in
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>>> Source prepared.
>>>> Configuring source in
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>>> Source configured.
>>>> Compiling source in
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>>> Source compiled.
>>>> Test phase [not enabled]: app-emulation/emul-linux-x86-medialibs-20120520
>
>>>> Install emul-linux-x86-medialibs-20120520 into
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/ category
> app-emulation
>>>> Completed installing emul-linux-x86-medialibs-20120520 into
> /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/
>
>
> ** QA Notice: The following files contain runtime text relocations
> ** *Text relocations force the dynamic linker to perform extra
> ** *work at startup, waste system resources, and may pose a security
> ** *risk. *On some architectures, the code may not even function
> ** *properly, if at all.
> ** *For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
> ** *Please include the following list of files in your report:
> ** TEXTREL usr/lib32/libx264.so.120
>
>
>>>> Installing (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
>>>> Auto-cleaning packages...
>
>>>> No outdated packages were found on your system.
>
> ** GNU info directory index is up-to-date.
> ** Build finished correctly. Removing temporary files...
> ** You can re-run revdep-rebuild to verify that all libraries and binaries
> ** are fixed. Possible reasons for remaining inconsistencies include:
> ** * orphaned files
> ** * deep dependencies
> ** * packages installed outside of portage's control
> ** * specially-evaluated libraries
>
>
> It keeps complaining about libavdevice.so and them re-emerges
> app-emulation/emul-linux-x86-medialibs-20120520.
>
>
> When I would re-run it right now, it would again complain about libavdevice and
> would again re-emerge app-emulation/emul-linux-x86-medialibs..
>
> Has anyone any idea how to fix this?
>
> Thanks in advance,
> Christian.
>
>

This is bug: https://bugs.gentoo.org/show_bug.cgi?id=416751

Bugzilla+search is your friend
 
Old 05-25-2012, 12:47 PM
Alan McKinnon
 
Default revdep-rebuild keeps repeating the same steps

On Fri, 25 May 2012 14:41:36 +0200
1126 <mailinglists@elfsechsundzwanzig.de> wrote:

> Hello list!
>
> When I run revdep-rebuild, it keeps repeating the same steps over and
> over again.
>
> Here is what I mean:
>
> * Configuring search environment for revdep-rebuild
>
> * Checking reverse dependencies
> * Packages containing binaries and libraries broken by a package
> update
> * will be emerged.
>
> * Collecting system binaries and libraries
> * Generated new 1_files.rr
> * Collecting complete LD_LIBRARY_PATH
> * Generated new 2_ldpath.rr
> * Checking dynamic linking consistency
> [ 36% ] * broken /usr/lib32/libavdevice.so.53.4.100 (requires
> libpulse-simple.so.0
> libpulse.so.0)
> [ 100% ]
> * Generated new 3_broken.rr
> * Assigning files to packages
> * /usr/lib32/libavdevice.so.53.4.100 ->
> app-emulation/emul-linux-x86-medialibs
> * Generated new 4_raw.rr and 4_owners.rr
> * Cleaning list of packages to rebuild
> * Generated new 4_pkgs.rr
> * Assigning packages to ebuilds
> * Generated new 4_ebuilds.rr
> * Evaluating package order
> * Generated new 5_order.rr
> * All prepared. Starting rebuild
> emerge --complete-graph=y --oneshot
> app-emulation/emul-linux-x86-medialibs:0 ..........
> Calculating dependencies... done!

[snip]

> When I would re-run it right now, it would again complain about
> libavdevice and would again re-emerge
> app-emulation/emul-linux-x86-medialibs..
>
> Has anyone any idea how to fix this?

You can't.

emul-linux-x86-medialibs is a prebuilt binary and wants pulse libs
which you don;t have. You can't change the emul packages easily, so
just tell revdep-rebuild to ignore them. Put this in
/etc/revdep-rebuild/99revdep-rebuild:


SEARCH_DIRS_MASK="/usr/lib32 /lib32"


--
Alan McKinnnon
alan.mckinnon@gmail.com
 
Old 05-25-2012, 01:32 PM
1126
 
Default revdep-rebuild keeps repeating the same steps

On Fri, 25. May 13:47, Markos Chandras wrote:
> On Fri, May 25, 2012 at 1:41 PM, 1126
> <mailinglists@elfsechsundzwanzig.de> wrote:
> > Hello list!
> >
> > When I run revdep-rebuild, it keeps repeating the same steps over and over
> > again.
> >
> > Here is what I mean:
> >
> > ** Configuring search environment for revdep-rebuild
> >
> > ** Checking reverse dependencies
> > ** Packages containing binaries and libraries broken by a package update
> > ** will be emerged.
> >
> > ** Collecting system binaries and libraries
> > ** Generated new 1_files.rr
> > ** Collecting complete LD_LIBRARY_PATH
> > ** Generated new 2_ldpath.rr
> > ** Checking dynamic linking consistency
> > [ 36% ] ** * broken /usr/lib32/libavdevice.so.53.4.100 (requires
> > libpulse-simple.so.0
> > libpulse.so.0)
> > [ 100% ]
> > ** Generated new 3_broken.rr
> > ** Assigning files to packages
> > ** * /usr/lib32/libavdevice.so.53.4.100 ->
> > app-emulation/emul-linux-x86-medialibs
> > ** Generated new 4_raw.rr and 4_owners.rr
> > ** Cleaning list of packages to rebuild
> > ** Generated new 4_pkgs.rr
> > ** Assigning packages to ebuilds
> > ** Generated new 4_ebuilds.rr
> > ** Evaluating package order
> > ** Generated new 5_order.rr
> > ** All prepared. Starting rebuild
> > emerge --complete-graph=y --oneshot * app-emulation/emul-linux-x86-medialibs:0
> > ..........
> > Calculating dependencies... done!
> >
> >>>> Verifying ebuild manifests
> >
> >>>> Emerging (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
> > ** emul-linux-x86-medialibs-20120520.tar.xz RMD160 SHA1 SHA256 size ;-) ...
> > [ ok ]
> >>>> Unpacking source...
> >>>> Unpacking emul-linux-x86-medialibs-20120520.tar.xz to
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
> >>>> Source unpacked in
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
> >>>> Preparing source in
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
> >>>> Source prepared.
> >>>> Configuring source in
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
> >>>> Source configured.
> >>>> Compiling source in
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
> >>>> Source compiled.
> >>>> Test phase [not enabled]: app-emulation/emul-linux-x86-medialibs-20120520
> >
> >>>> Install emul-linux-x86-medialibs-20120520 into
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/ category
> > app-emulation
> >>>> Completed installing emul-linux-x86-medialibs-20120520 into
> > /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/
> >
> >
> > ** QA Notice: The following files contain runtime text relocations
> > ** *Text relocations force the dynamic linker to perform extra
> > ** *work at startup, waste system resources, and may pose a security
> > ** *risk. *On some architectures, the code may not even function
> > ** *properly, if at all.
> > ** *For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
> > ** *Please include the following list of files in your report:
> > ** TEXTREL usr/lib32/libx264.so.120
> >
> >
> >>>> Installing (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
> >>>> Auto-cleaning packages...
> >
> >>>> No outdated packages were found on your system.
> >
> > ** GNU info directory index is up-to-date.
> > ** Build finished correctly. Removing temporary files...
> > ** You can re-run revdep-rebuild to verify that all libraries and binaries
> > ** are fixed. Possible reasons for remaining inconsistencies include:
> > ** * orphaned files
> > ** * deep dependencies
> > ** * packages installed outside of portage's control
> > ** * specially-evaluated libraries
> >
> >
> > It keeps complaining about libavdevice.so and them re-emerges
> > app-emulation/emul-linux-x86-medialibs-20120520.
> >
> >
> > When I would re-run it right now, it would again complain about libavdevice and
> > would again re-emerge app-emulation/emul-linux-x86-medialibs..
> >
> > Has anyone any idea how to fix this?
> >
> > Thanks in advance,
> > Christian.
> >
> >
>
> This is bug: https://bugs.gentoo.org/show_bug.cgi?id=416751
>
> Bugzilla+search is your friend
>

Thanks, a friend I somehow forgot to ask this time
 
Old 05-25-2012, 01:33 PM
1126
 
Default revdep-rebuild keeps repeating the same steps

On Fri, 25. May 14:47, Alan McKinnon wrote:
> On Fri, 25 May 2012 14:41:36 +0200
> 1126 <mailinglists@elfsechsundzwanzig.de> wrote:
>
> > Hello list!
> >
> > When I run revdep-rebuild, it keeps repeating the same steps over and
> > over again.
> >
> > Here is what I mean:
> >
> > * Configuring search environment for revdep-rebuild
> >
> > * Checking reverse dependencies
> > * Packages containing binaries and libraries broken by a package
> > update
> > * will be emerged.
> >
> > * Collecting system binaries and libraries
> > * Generated new 1_files.rr
> > * Collecting complete LD_LIBRARY_PATH
> > * Generated new 2_ldpath.rr
> > * Checking dynamic linking consistency
> > [ 36% ] * broken /usr/lib32/libavdevice.so.53.4.100 (requires
> > libpulse-simple.so.0
> > libpulse.so.0)
> > [ 100% ]
> > * Generated new 3_broken.rr
> > * Assigning files to packages
> > * /usr/lib32/libavdevice.so.53.4.100 ->
> > app-emulation/emul-linux-x86-medialibs
> > * Generated new 4_raw.rr and 4_owners.rr
> > * Cleaning list of packages to rebuild
> > * Generated new 4_pkgs.rr
> > * Assigning packages to ebuilds
> > * Generated new 4_ebuilds.rr
> > * Evaluating package order
> > * Generated new 5_order.rr
> > * All prepared. Starting rebuild
> > emerge --complete-graph=y --oneshot
> > app-emulation/emul-linux-x86-medialibs:0 ..........
> > Calculating dependencies... done!
>
> [snip]
>
> > When I would re-run it right now, it would again complain about
> > libavdevice and would again re-emerge
> > app-emulation/emul-linux-x86-medialibs..
> >
> > Has anyone any idea how to fix this?
>
> You can't.
>
> emul-linux-x86-medialibs is a prebuilt binary and wants pulse libs
> which you don;t have. You can't change the emul packages easily, so
> just tell revdep-rebuild to ignore them. Put this in
> /etc/revdep-rebuild/99revdep-rebuild:
>
>
> SEARCH_DIRS_MASK="/usr/lib32 /lib32"

Okay, thank you!

>
>
> --
> Alan McKinnnon
> alan.mckinnon@gmail.com
>
>
 

Thread Tools




All times are GMT. The time now is 12:11 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org