Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   media-tv/mythtv-0.24.1_p20110524 fails to emerge (http://www.linux-archive.org/gentoo-user/670579-media-tv-mythtv-0-24-1_p20110524-fails-emerge.html)

Michael Sullivan 05-24-2012 03:53 PM

media-tv/mythtv-0.24.1_p20110524 fails to emerge
 
I seriously screwed up my system this week, and broke myth. Now I'm
trying to emerge media-tv/mythtv-0.24.1_p20110524 since my old myth
version is no longer supported (the ebuilds aren't even still around).
The emerge goes along fine until it gets to this part:

mythrender_opengl.cpp: In function 'int __glCheck__(const QString&,
const char*, int)':
mythrender_opengl.cpp:38: error: 'gluErrorString' was not declared in
this scope
make[2]: *** [mythrender_opengl.o] Error 1
make[2]: Leaving directory
`/var/tmp/portage/media-tv/mythtv-0.24.1_p20110524/work/MythTV-mythtv-347cd24/mythtv/libs/libmythui'
make[1]: *** [sub-libmythui-make_default] Error 2
make[1]: Leaving directory
`/var/tmp/portage/media-tv/mythtv-0.24.1_p20110524/work/MythTV-mythtv-347cd24/mythtv/libs'
make: *** [libs] Error 2

Most of our TV watching is off Myth. We only have one show that we
follow that's currently in season and that's on Monday, so I'd really
like to have this working by then. Can anyone help me?
-Michael Sullivan-

Alan McKinnon 05-24-2012 08:34 PM

media-tv/mythtv-0.24.1_p20110524 fails to emerge
 
On Thu, 24 May 2012 10:53:04 -0500
Michael Sullivan <msulli1355@gmail.com> wrote:

> I seriously screwed up my system this week, and broke myth. Now I'm
> trying to emerge media-tv/mythtv-0.24.1_p20110524 since my old myth
> version is no longer supported (the ebuilds aren't even still around).
> The emerge goes along fine until it gets to this part:
>
> mythrender_opengl.cpp: In function 'int __glCheck__(const QString&,
> const char*, int)':
> mythrender_opengl.cpp:38: error: 'gluErrorString' was not declared in
> this scope
> make[2]: *** [mythrender_opengl.o] Error 1
> make[2]: Leaving directory
> `/var/tmp/portage/media-tv/mythtv-0.24.1_p20110524/work/MythTV-mythtv-347cd24/mythtv/libs/libmythui'
> make[1]: *** [sub-libmythui-make_default] Error 2
> make[1]: Leaving directory
> `/var/tmp/portage/media-tv/mythtv-0.24.1_p20110524/work/MythTV-mythtv-347cd24/mythtv/libs'
> make: *** [libs] Error 2
>
> Most of our TV watching is off Myth. We only have one show that we
> follow that's currently in season and that's on Monday, so I'd really
> like to have this working by then. Can anyone help me?
> -Michael Sullivan-
>

I can't help you fix that error, but I have something just as good :-)

myth is still installed, just broken right? You didn;t uninstall it?

In /var/db/pkg/<cat>/<package-version>/ you will find the ebuild that
is currently installed (despite it not being in the tree anymore). Copy
it to your personal overlay and continue to use it till you get the
error sorted out.



--
Alan McKinnnon
alan.mckinnon@gmail.com

Kerwin Hui 05-25-2012 04:41 AM

media-tv/mythtv-0.24.1_p20110524 fails to emerge
 
On Thu, 24 May 2012 10:53:04 -0500
Michael Sullivan <msulli1355@gmail.com> wrote:

> I seriously screwed up my system this week, and broke myth. Now I'm
> trying to emerge media-tv/mythtv-0.24.1_p20110524 since my old myth
> version is no longer supported (the ebuilds aren't even still around).
> The emerge goes along fine until it gets to this part:
>
> mythrender_opengl.cpp: In function 'int __glCheck__(const QString&,
> const char*, int)':
> mythrender_opengl.cpp:38: error: 'gluErrorString' was not declared in
> this scope

See bug #407845 and the workaround.

I believe mythtv-0.25 has a fix (the fix was committed to git 7 months
ago) but gentoo hasn't packaged that yet, see bug #411547.

Kerwin.


All times are GMT. The time now is 03:34 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.