FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-14-2012, 10:49 AM
Space Cake
 
Default solving curl dependency issues

Hi,

For several weeks I'm trying to solve dependency issues with curl, but
I'm lost.. any idea?


emerge --keep-going -upND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy
"net-misc/curl[ssl,curl_ssl_nss]".

!!! One of the following packages is required to complete your request:
- net-misc/curl-7.25.0-r1::gentoo (Change USE: +curl_ssl_nss, this
change violates use flag constraints defined by net-misc/curl-7.25.0-r1:
'threads? ( !ares ) ssl? ( exactly-one-of ( curl_ssl_axtls
curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss
curl_ssl_polarssl ) )')

(dependency required by "net-libs/liboauth-0.9.6[curl,nss]" [installed])
(dependency required by
"gnome-extra/evolution-data-server-3.2.3-r1[gnome-online-accounts]"
[installed])

(dependency required by "gnome-extra/gnome-contacts-3.2.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

----

[i] net-misc/curl
Available versions: 7.21.4 (~)7.21.6 (~)7.21.7 (~)7.21.7-r2
(~)7.22.0 (~)7.23.1 7.24.0 (~)7.25.0 (~)7.25.0-r1 {ares curl_ssl_axtls
curl_ssl_cyassl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl
curl_ssl_polarssl gnutls idn ipv6 kerberos ldap nss ssh ssl static-libs
test threads}
Installed versions: 7.25.0-r1(12.34.47
2012-05-14)(curl_ssl_openssl idn ipv6 ldap ssh ssl threads -ares
-curl_ssl_axtls -curl_ssl_cyassl -curl_ssl_gnutls -curl_ssl_nss
-curl_ssl_polarssl -kerberos -static-libs -test)

Homepage: http://curl.haxx.se/
Description: A Client that groks URLs

-------

Thank you
L:
 
Old 05-14-2012, 11:35 AM
Neil Bothwick
 
Default solving curl dependency issues

On Mon, 14 May 2012 12:49:59 +0200, Space Cake wrote:

> emerge: there are no ebuilds built with USE flags to satisfy
> "net-misc/curl[ssl,curl_ssl_nss]".
> !!! One of the following packages is required to complete your request:
> - net-misc/curl-7.25.0-r1::gentoo (Change USE: +curl_ssl_nss, this
> change violates use flag constraints defined by
> net-misc/curl-7.25.0-r1: 'threads? ( !ares ) ssl? ( exactly-one-of
> ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl
> curl_ssl_nss curl_ssl_polarssl ) )')

You need to set curl_ssl_nss but you cannot have this set at the same
time as any other curl_ssl* flags, the error message says you must have
exactly one of them. So you also need to set -curl_ssl_openssl as that
one is enabled by default.


--
Neil Bothwick

Why is there an expiration date on sour cream?
 
Old 05-14-2012, 01:08 PM
walt
 
Default solving curl dependency issues

On 05/14/2012 03:49 AM, Space Cake wrote:
> Hi,
>
> For several weeks I'm trying to solve dependency issues with curl, but I'm lost.. any idea?

That problem drove me nuts for months. I finally discovered by desperate
trial and error that un-setting the 'curl' useflag fixes it. Finally!
 
Old 05-14-2012, 02:02 PM
Space Cake
 
Default solving curl dependency issues

Removing keywords from curl produces this

brutal keywords # emerge --keep-going -upND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy
"net-misc/curl[ssl,curl_ssl_nss]".

!!! One of the following packages is required to complete your request:
- net-misc/curl-7.25.0-r1::gentoo (Change USE: +curl_ssl_nss, this
change violates use flag constraints defined by
net-misc/curl-7.25.0-r1: 'threads? ( !ares ) ssl? ( exactly-one-of (
curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl
curl_ssl_nss curl_ssl_polarssl ) )')

(dependency required by "net-libs/liboauth-0.9.6[curl,nss]" [installed])
(dependency required by
"gnome-extra/evolution-data-server-3.2.3-r1[gnome-online-accounts]"
[installed])

(dependency required by "gnome-extra/gnome-contacts-3.2.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


eix output:[i] net-misc/curl
Available versions: 7.21.4 (~)7.21.6 (~)7.21.7 (~)7.21.7-r2
(~)7.22.0 (~)7.23.1 7.24.0 (~)7.25.0 (~)7.25.0-r1 {ares curl_ssl_axtls
curl_ssl_cyassl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl
curl_ssl_polarssl gnutls idn ipv6 kerberos ldap nss ssh ssl static-libs
test threads}
Installed versions: 7.25.0-r1(12.34.47
2012-05-14)(curl_ssl_openssl idn ipv6 ldap ssh ssl threads -ares
-curl_ssl_axtls -curl_ssl_cyassl -curl_ssl_gnutls -curl_ssl_nss
-curl_ssl_polarssl -kerberos -static-libs -test)

Homepage: http://curl.haxx.se/
Description: A Client that groks URLs


So, this is asking for curl_ssl_nss,

But after I set this I'm getting this

brutal ~ # emerge --keep-going -upND world

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for net-misc/curl from @selected
... done!

!!! The ebuild selected to satisfy "net-misc/curl" has unmet
requirements.
- net-misc/curl-7.25.0-r1::gentoo USE="idn ipv6 ldap ssl threads -ares
-kerberos -ssh -static-libs -test" CURL_SSL="nss openssl -axtls -cyassl
-gnutls -polarssl"


The following REQUIRED_USE flag constraints are unsatisfied:
ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl
curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )


The above constraints are a subset of the following complete
expression:
threads? ( !ares ) ssl? ( exactly-one-of ( curl_ssl_axtls
curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss
curl_ssl_polarssl ) )


(dependency required by "@selected" [set])
(dependency required by "@world" [argument])




On 2012. máj. 14., hétfő, 15.08.17 CEST, walt wrote:

On 05/14/2012 03:49 AM, Space Cake wrote:

Hi,

For several weeks I'm trying to solve dependency issues with curl, but I'm lost.. any idea?


That problem drove me nuts for months. I finally discovered by desperate
trial and error that un-setting the 'curl' useflag fixes it. Finally!
 
Old 05-14-2012, 03:06 PM
walt
 
Default solving curl dependency issues

On 05/14/2012 06:08 AM, walt wrote:
> On 05/14/2012 03:49 AM, Space Cake wrote:
>> Hi,
>>
>> For several weeks I'm trying to solve dependency issues with curl, but I'm lost.. any idea?
>
> That problem drove me nuts for months. I finally discovered by desperate
> trial and error that un-setting the 'curl' useflag fixes it. Finally!

Sorry, I forgot that I also un-set the 'nss' and 'openssl' useflags.
Now I have only the gnutls useflag set. (I kept that one because the
gnutls is GPL, not because I think one is better that the others.)

The only thing I insist on being encrypted are ssl connections in firefox,
so my encryption needs are minimal, maybe less than yours.
 
Old 05-14-2012, 03:34 PM
Alan McKinnon
 
Default solving curl dependency issues

On Mon, 14 May 2012 16:02:15 +0200
Space Cake <spacecakex@gmail.com> wrote:

> Removing keywords from curl produces this
>
> brutal keywords # emerge --keep-going -upND world
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> emerge: there are no ebuilds built with USE flags to satisfy
> "net-misc/curl[ssl,curl_ssl_nss]".
> !!! One of the following packages is required to complete your
> request:
> - net-misc/curl-7.25.0-r1::gentoo (Change USE: +curl_ssl_nss, this
> change violates use flag constraints defined by
> net-misc/curl-7.25.0-r1: 'threads? ( !ares ) ssl? ( exactly-one-of (
> curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl
> curl_ssl_nss curl_ssl_polarssl ) )')
> (dependency required by
> "net-libs/liboauth-0.9.6[curl,nss]" [installed]) (dependency required
> by
> "gnome-extra/evolution-data-server-3.2.3-r1[gnome-online-accounts]" [installed])
> (dependency required by
> "gnome-extra/gnome-contacts-3.2.2" [installed]) (dependency required
> by "@selected" [set]) (dependency required by "@world" [argument])
>
>
> eix output:[i] net-misc/curl
> Available versions: 7.21.4 (~)7.21.6 (~)7.21.7 (~)7.21.7-r2
> (~)7.22.0 (~)7.23.1 7.24.0 (~)7.25.0 (~)7.25.0-r1 {ares
> curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_nss
> +curl_ssl_openssl curl_ssl_polarssl gnutls idn ipv6 kerberos ldap nss
> ssh ssl static-libs test threads}
> Installed versions: 7.25.0-r1(12.34.47
> 2012-05-14)(curl_ssl_openssl idn ipv6 ldap ssh ssl threads -ares
> -curl_ssl_axtls -curl_ssl_cyassl -curl_ssl_gnutls -curl_ssl_nss
> -curl_ssl_polarssl -kerberos -static-libs -test)
> Homepage: http://curl.haxx.se/
> Description: A Client that groks URLs
>
>
> So, this is asking for curl_ssl_nss,
>
> But after I set this I'm getting this
>
> brutal ~ # emerge --keep-going -upND world
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies /
>
> !!! Problem resolving dependencies for net-misc/curl from @selected
> ... done!
>
> !!! The ebuild selected to satisfy "net-misc/curl" has unmet
> requirements.
> - net-misc/curl-7.25.0-r1::gentoo USE="idn ipv6 ldap ssl threads
> -ares -kerberos -ssh -static-libs -test" CURL_SSL="nss openssl -axtls
> -cyassl -gnutls -polarssl"
>
> The following REQUIRED_USE flag constraints are unsatisfied:
> ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl
> curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )
>
> The above constraints are a subset of the following complete
> expression:
> threads? ( !ares ) ssl? ( exactly-one-of ( curl_ssl_axtls
> curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss
> curl_ssl_polarssl ) )
>
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
>
>
>
>
> On 2012. máj. 14., hétfő, 15.08.17 CEST, walt wrote:
> > On 05/14/2012 03:49 AM, Space Cake wrote:
> >> Hi,
> >>
> >> For several weeks I'm trying to solve dependency issues with curl,
> >> but I'm lost.. any idea?
> >
> > That problem drove me nuts for months. I finally discovered by
> > desperate trial and error that un-setting the 'curl' useflag fixes
> > it. Finally!
> >
> >
> >
>

The requirements are (from the error message):

If USE=ssl then use exactly one of the following:
curl_ssl_axtls
curl_ssl_cyassl
curl_ssl_gnutls
curl_ssl_openssl
curl_ssl_nss
curl_ssl_polarssl

You have the following set for curl (per eix):

curl_ssl_openssl

But the error message also says that this is required:
net-misc/curl[ssl,curl_ssl_nss] by liboauth

You cannot have curl_ssl_nss and curl_ssl_openssl both set for curl as
liboauth complains

So, what you need to do is set

USE="-curl_ssl_openssl curl_ssl_nss" for curl

If you read my post carefully and see how all the bits fit the output
you supplied, it all makes sense. Portage output is not exactly
intuitive but it can be understood.

Or you could unset USE="curl" for liboauth.

I don't know if you'll be willing to switch from curl_ssl just to make
liboauth happy. That's your call.

--
Alan McKinnnon
alan.mckinnon@gmail.com
 
Old 05-15-2012, 10:04 AM
Space Cake
 
Default solving curl dependency issues

Thank you. It seems to be ok now

[ebuild R ~] net-misc/curl-7.25.0-r1 CURL_SSL="gnutls* -openssl*"
[ebuild R ~] net-libs/liboauth-0.9.6 USE="-curl*"

>=net-misc/curl-7.24.0 -curl_ssl_nss -curl_ssl_openssl curl_ssl_gnutls
ssl -nss ssh



Laszlo


On 2012. máj. 14., hétfő, 17.34.19 CEST, Alan McKinnon wrote:


On Mon, 14 May 2012 16:02:15 +0200
Space Cake<spacecakex@gmail.com> wrote:



Removing keywords from curl produces this

brutal keywords # emerge --keep-going -upND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy
"net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your
request:
- net-misc/curl-7.25.0-r1::gentoo (Change USE: +curl_ssl_nss, this
change violates use flag constraints defined by
net-misc/curl-7.25.0-r1: 'threads? ( !ares ) ssl? ( exactly-one-of (
curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl
curl_ssl_nss curl_ssl_polarssl ) )')
(dependency required by
"net-libs/liboauth-0.9.6[curl,nss]" [installed]) (dependency required
by
"gnome-extra/evolution-data-server-3.2.3-r1[gnome-online-accounts]"
[installed])

(dependency required by
"gnome-extra/gnome-contacts-3.2.2" [installed]) (dependency required
by "@selected" [set]) (dependency required by "@world" [argument])


eix output:[i] net-misc/curl
Available versions: 7.21.4 (~)7.21.6 (~)7.21.7 (~)7.21.7-r2
(~)7.22.0 (~)7.23.1 7.24.0 (~)7.25.0 (~)7.25.0-r1 {ares
curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_nss
+curl_ssl_openssl curl_ssl_polarssl gnutls idn ipv6 kerberos ldap nss
ssh ssl static-libs test threads}
Installed versions: 7.25.0-r1(12.34.47
2012-05-14)(curl_ssl_openssl idn ipv6 ldap ssh ssl threads -ares
-curl_ssl_axtls -curl_ssl_cyassl -curl_ssl_gnutls -curl_ssl_nss
-curl_ssl_polarssl -kerberos -static-libs -test)
Homepage: http://curl.haxx.se/
Description: A Client that groks URLs


So, this is asking for curl_ssl_nss,

But after I set this I'm getting this

brutal ~ # emerge --keep-going -upND world

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for net-misc/curl from @selected
... done!

!!! The ebuild selected to satisfy "net-misc/curl" has unmet
requirements.
- net-misc/curl-7.25.0-r1::gentoo USE="idn ipv6 ldap ssl threads
-ares -kerberos -ssh -static-libs -test" CURL_SSL="nss openssl -axtls
-cyassl -gnutls -polarssl"

The following REQUIRED_USE flag constraints are unsatisfied:
ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl
curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )

The above constraints are a subset of the following complete
expression:
threads? ( !ares ) ssl? ( exactly-one-of ( curl_ssl_axtls
curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss
curl_ssl_polarssl ) )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])




On 2012. máj. 14., hétfő, 15.08.17 CEST, walt wrote:


On 05/14/2012 03:49 AM, Space Cake wrote:


Hi,

For several weeks I'm trying to solve dependency issues with curl,
but I'm lost.. any idea?



That problem drove me nuts for months. I finally discovered by
desperate trial and error that un-setting the 'curl' useflag fixes
it. Finally!









The requirements are (from the error message):

If USE=ssl then use exactly one of the following:
curl_ssl_axtls
curl_ssl_cyassl
curl_ssl_gnutls
curl_ssl_openssl
curl_ssl_nss
curl_ssl_polarssl

You have the following set for curl (per eix):

curl_ssl_openssl

But the error message also says that this is required:
net-misc/curl[ssl,curl_ssl_nss] by liboauth

You cannot have curl_ssl_nss and curl_ssl_openssl both set for curl as
liboauth complains

So, what you need to do is set

USE="-curl_ssl_openssl curl_ssl_nss" for curl

If you read my post carefully and see how all the bits fit the output
you supplied, it all makes sense. Portage output is not exactly
intuitive but it can be understood.

Or you could unset USE="curl" for liboauth.

I don't know if you'll be willing to switch from curl_ssl just to make
liboauth happy. That's your call.
 

Thread Tools




All times are GMT. The time now is 02:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org