FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 05-02-2012, 09:58 PM
Hilco Wijbenga
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

Hi all,

I ran equery depends on both but it gives me identical results:

centaur ~ # equery depends net-libs/webkit-gtk
* These packages depend on net-libs/webkit-gtk:
dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r200
* These packages depend on net-libs/webkit-gtk-1.8.1-r200:
dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r300
* These packages depend on net-libs/webkit-gtk-1.8.1-r300:
dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)

I unmerged the *-r200 version but it got reinstalled so apparently
"something" needs it. Can anyone explain this?

Cheers,
Hilco
 
Old 05-02-2012, 10:08 PM
Canek Peláez Valdés
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On Wed, May 2, 2012 at 4:58 PM, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
> Hi all,
>
> I ran equery depends on both but it gives me identical results:
>
> centaur ~ # equery depends net-libs/webkit-gtk
> ** These packages depend on net-libs/webkit-gtk:
> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r200
> ** These packages depend on net-libs/webkit-gtk-1.8.1-r200:
> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r300
> ** These packages depend on net-libs/webkit-gtk-1.8.1-r300:
> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>
> I unmerged the *-r200 version but it got reinstalled so apparently
> "something" needs it. Can anyone explain this?

One uses gtk+-2, the other one gtk+-3. If you use something with
gtk+-3 (e.g., GNOME), it is needed and will be pulled.

Regards.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México
 
Old 05-02-2012, 10:20 PM
Canek Peláez Valdés
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On Wed, May 2, 2012 at 5:08 PM, Canek Peláez Valdés <caneko@gmail.com> wrote:
> On Wed, May 2, 2012 at 4:58 PM, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
>> Hi all,
>>
>> I ran equery depends on both but it gives me identical results:
>>
>> centaur ~ # equery depends net-libs/webkit-gtk
>> ** These packages depend on net-libs/webkit-gtk:
>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r200
>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r200:
>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r300
>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r300:
>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>
>> I unmerged the *-r200 version but it got reinstalled so apparently
>> "something" needs it. Can anyone explain this?
>
> One uses gtk+-2, the other one gtk+-3. If you use something with
> gtk+-3 (e.g., GNOME), it is needed and will be pulled.

I meant GNOME 3.

Regards.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México
 
Old 05-03-2012, 06:58 PM
Hilco Wijbenga
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On 2 May 2012 15:20, Canek Peláez Valdés <caneko@gmail.com> wrote:
> On Wed, May 2, 2012 at 5:08 PM, Canek Peláez Valdés <caneko@gmail.com> wrote:
>> On Wed, May 2, 2012 at 4:58 PM, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
>>> Hi all,
>>>
>>> I ran equery depends on both but it gives me identical results:
>>>
>>> centaur ~ # equery depends net-libs/webkit-gtk
>>> ** These packages depend on net-libs/webkit-gtk:
>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r200
>>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r200:
>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r300
>>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r300:
>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>>
>>> I unmerged the *-r200 version but it got reinstalled so apparently
>>> "something" needs it. Can anyone explain this?
>>
>> One uses gtk+-2, the other one gtk+-3. If you use something with
>> gtk+-3 (e.g., GNOME), it is needed and will be pulled.
>
> I meant GNOME 3.

I'm not running Gnome but I do have various Gnome dependent packages
installed. So both gtk+-2 and gtk+-3 are installed.

Unfortunately, I'm finding it hard to determine why I need gtk+-2 (and
consequently net-libs/webkit-gtk-1.8.1-r200). Running equery depends
... gives me identical results and thus does not help. Using emerge
-vtp or emerge -vetp does not yield useful information either. Any
ideas?
 
Old 05-03-2012, 07:08 PM
Canek Peláez Valdés
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On Thu, May 3, 2012 at 1:58 PM, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
> On 2 May 2012 15:20, Canek Peláez Valdés <caneko@gmail.com> wrote:
>> On Wed, May 2, 2012 at 5:08 PM, Canek Peláez Valdés <caneko@gmail.com> wrote:
>>> On Wed, May 2, 2012 at 4:58 PM, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
>>>> Hi all,
>>>>
>>>> I ran equery depends on both but it gives me identical results:
>>>>
>>>> centaur ~ # equery depends net-libs/webkit-gtk
>>>> ** These packages depend on net-libs/webkit-gtk:
>>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r200
>>>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r200:
>>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>>> centaur ~ # equery depends =net-libs/webkit-gtk-1.8.1-r300
>>>> ** These packages depend on net-libs/webkit-gtk-1.8.1-r300:
>>>> dev-java/swt-3.7.2 (webkit ? >=net-libs/webkit-gtk-1.2:2)
>>>> gnome-extra/sushi-0.2.1 (net-libs/webkit-gtk:3[introspection])
>>>> gnome-extra/zenity-3.2.0 (webkit ? >=net-libs/webkit-gtk-1.4.0:3)
>>>> media-gfx/gimp-2.6.12 (webkit ? net-libs/webkit-gtk:2)
>>>>
>>>> I unmerged the *-r200 version but it got reinstalled so apparently
>>>> "something" needs it. Can anyone explain this?
>>>
>>> One uses gtk+-2, the other one gtk+-3. If you use something with
>>> gtk+-3 (e.g., GNOME), it is needed and will be pulled.
>>
>> I meant GNOME 3.
>
> I'm not running Gnome but I do have various Gnome dependent packages
> installed. So both gtk+-2 and gtk+-3 are installed.
>
> Unfortunately, I'm finding it hard to determine why I need gtk+-2 (and
> consequently net-libs/webkit-gtk-1.8.1-r200). Running equery depends
> ... gives me identical results and thus does not help. Using emerge
> -vtp or emerge -vetp does not yield useful information either. Any
> ideas?

Use the slot for equery:

equery depends x11-libs/gtk+:2
equery depends x11-libs/gtk+:3

Saludos.
--
Canek Peláez Valdés
Posgrado en Ciencia e Ingeniería de la Computación
Universidad Nacional Autónoma de México
 
Old 05-03-2012, 07:14 PM
Nikos Chantziaras
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On 03/05/12 00:58, Hilco Wijbenga wrote:

Hi all,

I ran equery depends on both


If you want accurate results, use emerge, not equery:

emerge -pv --depclean net-libs/webkit-gtk

It will tell you what's pulling it in.
 
Old 05-03-2012, 07:19 PM
Michael Mol
 
Default Why do I have both net-libs/webkit-gtk-1.8.1-r200 and net-libs/webkit-gtk-1.8.1-r300?

On Thu, May 3, 2012 at 3:14 PM, Nikos Chantziaras <realnc@gmail.com> wrote:
> On 03/05/12 00:58, Hilco Wijbenga wrote:
>>
>> Hi all,
>>
>> I ran equery depends on both
>
>
> If you want accurate results, use emerge, not equery:
>
> *emerge -pv --depclean net-libs/webkit-gtk
>
> It will tell you what's pulling it in.

I have --tree in EMERGE_DEFAULT_OPTS for additional clarity.

--
:wq
 

Thread Tools




All times are GMT. The time now is 03:04 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org