Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer (http://www.linux-archive.org/gentoo-user/660483-gentoo-segfaults-virtualbox-4-1-14-when-running-amd-bulldozer.html)

Markos Chandras 04-27-2012 07:35 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
Hi all

This is a copy of the thread I recently opened on Gentoo forums[1].

I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
noticed that all of my Gentoo virtual machines throw (compiler)
segmentation faults when building or running any application. This
happens on a Gentoo testing VM, on a Gentoo stable VM and on a brand new
Gentoo installation. I have no idea where to look for that problem.

System:

Motherboard: Asus M5A78L-M/USB3
CPU: AMD FX(tm)-6100 Six-Core Processor
Host: Gentoo x86_64 testing (has not problem at all, so I presume HW
problem is eliminated)

Any ideas?

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Markos Chandras 04-27-2012 10:30 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/27/2012 08:35 PM, Markos Chandras wrote:
> Hi all
>
> This is a copy of the thread I recently opened on Gentoo forums[1].
>
> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
> noticed that all of my Gentoo virtual machines throw (compiler)
> segmentation faults when building or running any application. This
> happens on a Gentoo testing VM, on a Gentoo stable VM and on a brand new
> Gentoo installation. I have no idea where to look for that problem.
>
> System:
>
> Motherboard: Asus M5A78L-M/USB3
> CPU: AMD FX(tm)-6100 Six-Core Processor
> Host: Gentoo x86_64 testing (has not problem at all, so I presume HW
> problem is eliminated)
>
> Any ideas?
>
On the other hand, these virtual machines work fine on a Windows 7
64-bit host

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Nikos Chantziaras 04-27-2012 10:45 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 27/04/12 22:35, Markos Chandras wrote:

I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
noticed that all of my Gentoo virtual machines throw (compiler)
segmentation faults when building or running any application.


How do you get it to boot? How do you manage to log in? Are the
binaries from the stage tarball not affected?

Markos Chandras 04-27-2012 10:54 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/27/2012 11:45 PM, Nikos Chantziaras wrote:
> On 27/04/12 22:35, Markos Chandras wrote:
>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
>> noticed that all of my Gentoo virtual machines throw (compiler)
>> segmentation faults when building or running any application.
>
> How do you get it to boot? How do you manage to log in? Are the
> binaries from the stage tarball not affected?
>
>
What do you mean? I was using these VMs before I replace my CPU and I
was kinda expecting to keep working on my new CPU as well. The same VMs
work on the same host when using Windows 7 64-bit as host OS and not
Gentoo. I also tried to install Gentoo on a fresh new VM and I got a gcc
segmentation fault right in the middle of the kernel compilation. So,
yes stage binaries are affected as well. Is that what you were asking?

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Matthew Marlowe 04-28-2012 12:24 AM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On Fri, Apr 27, 2012 at 3:54 PM, Markos Chandras <hwoarang@gentoo.org> wrote:
> On 04/27/2012 11:45 PM, Nikos Chantziaras wrote:
>> On 27/04/12 22:35, Markos Chandras wrote:
>>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
>>> noticed that all of my Gentoo virtual machines throw (compiler)
>>> segmentation faults when building or running any application.
>>

I'm not familiar with virtualbox, but I've seen similar issues occur
with vmware and the solution was to at least temporarily mask whatever
new cpu flags the new hypervisor was passing to the guest. In vmware,
one could limit the cpu flags to maintain compatibility with various
cpu releases which was especially helpful in clusters.... Yes, your
gentoo vms should have been fine ..but at least until you track down
the issue, see if virtualbox has a similar feature?

--
Matthew Marlowe
matt@professionalsysadmin.com
https://www.twitter.com/deploylinux
1-805-857-9144

walt 04-28-2012 12:36 AM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/27/2012 12:35 PM, Markos Chandras wrote:
> Hi all
>
> This is a copy of the thread I recently opened on Gentoo forums[1].
>
> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
> noticed that all of my Gentoo virtual machines throw (compiler)
> segmentation faults when building or running any application. This
> happens on a Gentoo testing VM, on a Gentoo stable VM and on a brand new
> Gentoo installation. I have no idea where to look for that problem.

VirtualBox 4.1.14 just landed on ~amd64 today and I haven't had time to
test it yet. How long ago did you upgrade VirtualBox?

Markos Chandras 04-28-2012 08:25 AM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/28/2012 01:24 AM, Matthew Marlowe wrote:
> On Fri, Apr 27, 2012 at 3:54 PM, Markos Chandras
> <hwoarang@gentoo.org> wrote:
>> On 04/27/2012 11:45 PM, Nikos Chantziaras wrote:
>>> On 27/04/12 22:35, Markos Chandras wrote:
>>>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer.
>>>> However, I noticed that all of my Gentoo virtual machines
>>>> throw (compiler) segmentation faults when building or running
>>>> any application.
>>>
>
> I'm not familiar with virtualbox, but I've seen similar issues
> occur with vmware and the solution was to at least temporarily mask
> whatever new cpu flags the new hypervisor was passing to the guest.
> In vmware, one could limit the cpu flags to maintain compatibility
> with various cpu releases which was especially helpful in
> clusters.... Yes, your gentoo vms should have been fine ..but at
> least until you track down the issue, see if virtualbox has a
> similar feature?
>
I don't see an obvious way to manipulate the cpu flags in virtualbox

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Markos Chandras 04-28-2012 08:26 AM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/28/2012 01:36 AM, walt wrote:
> On 04/27/2012 12:35 PM, Markos Chandras wrote:
>> Hi all
>>
>> This is a copy of the thread I recently opened on Gentoo forums[1].
>>
>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
>> noticed that all of my Gentoo virtual machines throw (compiler)
>> segmentation faults when building or running any application. This
>> happens on a Gentoo testing VM, on a Gentoo stable VM and on a brand new
>> Gentoo installation. I have no idea where to look for that problem.
>
> VirtualBox 4.1.14 just landed on ~amd64 today and I haven't had time to
> test it yet. How long ago did you upgrade VirtualBox?
>
>
>
I updated yesterday but the same thing happened in 4.1.12 as well

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Markos Chandras 04-29-2012 07:23 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
On 04/28/2012 01:24 AM, Matthew Marlowe wrote:
> On Fri, Apr 27, 2012 at 3:54 PM, Markos Chandras <hwoarang@gentoo.org> wrote:
>> On 04/27/2012 11:45 PM, Nikos Chantziaras wrote:
>>> On 27/04/12 22:35, Markos Chandras wrote:
>>>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I
>>>> noticed that all of my Gentoo virtual machines throw (compiler)
>>>> segmentation faults when building or running any application.
>>>
>
> I'm not familiar with virtualbox, but I've seen similar issues occur
> with vmware and the solution was to at least temporarily mask whatever
> new cpu flags the new hypervisor was passing to the guest. In vmware,
> one could limit the cpu flags to maintain compatibility with various
> cpu releases which was especially helpful in clusters.... Yes, your
> gentoo vms should have been fine ..but at least until you track down
> the issue, see if virtualbox has a similar feature?
>
Interestingly this seems to be caused when using my wireless card to
bridge the virtualbox interfaces onto. I can't reproduce (yet) any
segfaults when I use the onboard ethernet card. I have the following
wireless card (supported by the rtl8180 kernel module)

04:06.0 Ethernet controller: Belkin F5D7000 v7000 Wireless G Desktop
Card [Realtek RTL8185] (rev 20)

--
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2

Michael Mol 04-30-2012 01:33 PM

Gentoo segfaults on virtualbox-4.1.14 when running on AMD bulldozer
 
Neat. Random guess, but it could be a bug in Bulldozer's memory controller or IOMMU. Try disabling IOMMU support in your kernel?

On Apr 29, 2012 3:29 PM, "Markos Chandras" <hwoarang@gentoo.org> wrote:
On 04/28/2012 01:24 AM, Matthew Marlowe wrote:

> On Fri, Apr 27, 2012 at 3:54 PM, Markos Chandras <hwoarang@gentoo.org> wrote:

>> On 04/27/2012 11:45 PM, Nikos Chantziaras wrote:

>>> On 27/04/12 22:35, Markos Chandras wrote:

>>>> I replaced my Phenom II cpu with a new 6-core AMD bulldozer. However, I

>>>> noticed that all of my Gentoo virtual machines throw (compiler)

>>>> segmentation faults when building or running any application.

>>>

>

> I'm not familiar with virtualbox, but I've seen similar issues occur

> with vmware and the solution was to at least temporarily mask whatever

> new cpu flags the new hypervisor was passing to the guest. *In vmware,

> one could limit the cpu flags to maintain compatibility with various

> cpu releases which was especially helpful in clusters.... Yes, your

> gentoo vms should have been fine ..but at least until you track down

> the issue, see if virtualbox has a similar feature?

>

Interestingly this seems to be caused when using my wireless card to

bridge the virtualbox interfaces onto. I can't reproduce (yet) any

segfaults when I use the onboard ethernet card. I have the following

wireless card (supported by the rtl8180 kernel module)



04:06.0 Ethernet controller: Belkin F5D7000 v7000 Wireless G Desktop

Card [Realtek RTL8185] (rev 20)



--

Regards,

Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2


All times are GMT. The time now is 02:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.