FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-03-2012, 01:06 PM
Josť Romildo Malaquias
 
Default web browsers crash at sourceforge.net project pages

Hello.

On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
0.4.3, Opera 11.61 Build 1250) just crash when loading any
sourceforge.net project page. Konquerer does not crash, though.

I have already run revdep-rebuild, but the problem persists.

Has anybody seen this? Any clues?

Romildo
 
Old 03-03-2012, 01:24 PM
Nikos Chantziaras
 
Default web browsers crash at sourceforge.net project pages

On 03/03/12 16:06, Josť Romildo Malaquias wrote:

Hello.

On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
0.4.3, Opera 11.61 Build 1250) just crash when loading any
sourceforge.net project page. Konquerer does not crash, though.

I have already run revdep-rebuild, but the problem persists.

Has anybody seen this? Any clues?


Uninstall adobe-flash and try again. If it works then, then you know
that Flash is causing this.
 
Old 03-03-2012, 02:09 PM
Josť Romildo Malaquias
 
Default web browsers crash at sourceforge.net project pages

On Sat, Mar 03, 2012 at 04:24:33PM +0200, Nikos Chantziaras wrote:
> On 03/03/12 16:06, Josť Romildo Malaquias wrote:
> > Hello.
> >
> > On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
> > 0.4.3, Opera 11.61 Build 1250) just crash when loading any
> > sourceforge.net project page. Konquerer does not crash, though.
> >
> > I have already run revdep-rebuild, but the problem persists.
> >
> > Has anybody seen this? Any clues?
>
> Uninstall adobe-flash and try again. If it works then, then you know
> that Flash is causing this.

The web browsers still crash after uninstalling adobe-flash.

Romildo
 
Old 03-03-2012, 02:18 PM
Nikos Chantziaras
 
Default web browsers crash at sourceforge.net project pages

On 03/03/12 17:09, Josť Romildo Malaquias wrote:

On Sat, Mar 03, 2012 at 04:24:33PM +0200, Nikos Chantziaras wrote:

On 03/03/12 16:06, Josť Romildo Malaquias wrote:

Hello.

On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
0.4.3, Opera 11.61 Build 1250) just crash when loading any
sourceforge.net project page. Konquerer does not crash, though.

I have already run revdep-rebuild, but the problem persists.

Has anybody seen this? Any clues?


Uninstall adobe-flash and try again. If it works then, then you know
that Flash is causing this.


The web browsers still crash after uninstalling adobe-flash.


Can you verify that some local flash installation is not left behind?
Does for example YouTube still work? Try playing a video and see what
the output of:


lsof | grep libflash

is. It should be empty.

Also, when you start the browser from the command-line, what does it
print when it crashes?
 
Old 03-03-2012, 03:38 PM
Paul Hartman
 
Default web browsers crash at sourceforge.net project pages

On Sat, Mar 3, 2012 at 8:06 AM, Josť Romildo Malaquias
<j.romildo@gmail.com> wrote:
> Hello.
>
> On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
> 0.4.3, Opera 11.61 Build 1250) just crash when loading any
> sourceforge.net project page. Konquerer does not crash, though.
>
> I have already run revdep-rebuild, but the problem persists.
>
> Has anybody seen this? Any clues?

They work for me, but in the olden days I had a similar problem that
was due to a corrupt font. Every time a site would use that font (or
specific glyph?) it would die.
 
Old 03-03-2012, 05:55 PM
Josť Romildo Malaquias
 
Default web browsers crash at sourceforge.net project pages

On Sat, Mar 03, 2012 at 10:38:29AM -0600, Paul Hartman wrote:
> On Sat, Mar 3, 2012 at 8:06 AM, Josť Romildo Malaquias
> <j.romildo@gmail.com> wrote:
> > Hello.
> >
> > On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
> > 0.4.3, Opera 11.61 Build 1250) just crash when loading any
> > sourceforge.net project page. Konquerer does not crash, though.
> >
> > I have already run revdep-rebuild, but the problem persists.
> >
> > Has anybody seen this? Any clues?
>
> They work for me, but in the olden days I had a similar problem that
> was due to a corrupt font. Every time a site would use that font (or
> specific glyph?) it would die.

After uninstalling almost media-fonts/* packages, the problem still
happens.

# eix -IAc media-fonts
[i] media-fonts/encodings (1.0.4{tbz2}@07/26/2011): X.Org font encodings
[i] media-fonts/font-alias (1.0.3{tbz2}@07/27/2011): X.Org font aliases
[i] media-fonts/font-misc-misc (1.1.2{tbz2}@07/27/2011): X.Org miscellaneous fonts
[i] media-fonts/font-util (1.2.0{tbz2}@07/26/2011): X.Org font utilities
Found 4 matches.

$ fc-list
Fixed:style=Bold
Fixed:style=Bold SemiCondensed
Fixed:style=SemiCondensed
Fixed:style=Oblique SemiCondensed
Fixed:style=Oblique
Fixed:style=ko
Fixed:style=ja
Fixed:style=Regular

Firefox, midori and opera crashes for both normal users I have on my
system, as well as for the root user.


Romildo.
 
Old 03-03-2012, 06:09 PM
Josť Romildo Malaquias
 
Default web browsers crash at sourceforge.net project pages

On Sat, Mar 03, 2012 at 05:18:15PM +0200, Nikos Chantziaras wrote:
> On 03/03/12 17:09, Josť Romildo Malaquias wrote:
> > On Sat, Mar 03, 2012 at 04:24:33PM +0200, Nikos Chantziaras wrote:
> >> On 03/03/12 16:06, Josť Romildo Malaquias wrote:
> >>> Hello.
> >>>
> >>> On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
> >>> 0.4.3, Opera 11.61 Build 1250) just crash when loading any
> >>> sourceforge.net project page. Konquerer does not crash, though.
> >>>
> >>> I have already run revdep-rebuild, but the problem persists.
> >>>
> >>> Has anybody seen this? Any clues?
> >>
> >> Uninstall adobe-flash and try again. If it works then, then you know
> >> that Flash is causing this.
> >
> > The web browsers still crash after uninstalling adobe-flash.
>
> Can you verify that some local flash installation is not left behind?
> Does for example YouTube still work? Try playing a video and see what
> the output of:
>
> lsof | grep libflash
>
> is. It should be empty.

"lsof | grep libflash" output is empty.

I belive no local flash installation has been left behind:

$ locate libflash | grep -v ^/usr/portage
/usr/lib64/libreoffice/basis3.4/program/libflashlx.so.bak


To test the flash player plugin I visisted the page at
http://www.ultrasounds.com/, which tells me the plugin is missing.


> Also, when you start the browser from the command-line, what does it
> print when it crashes?

$ firefox http://sourceforge.net/projects/pgf/
Segmentation fault

$ opera http://sourceforge.net/projects/pgf/
opera: no fonts found among preferred font formats, trying pcf fonts
Unrecognized system call failure [fnmatch]: Invalid or incomplete multibyte or wide character
opera [crash logging]: CRASH!!
/usr/lib64/opera/opera got signal SIGSEGV at address 7F73ED1D17D5

Log was created here:
/var/tmp/crash20120303155333.txt
Killed

$ midori http://sourceforge.net/projects/pgf/
(midori:6011): GnomeShellBrowserPlugin-DEBUG: plugin loaded
(midori:6011): GnomeShellBrowserPlugin-DEBUG: plugin loaded
(midori:6011): GnomeShellBrowserPlugin-DEBUG: plugin loaded
Segmentation fault


Romildo
 
Old 03-03-2012, 08:12 PM
walt
 
Default web browsers crash at sourceforge.net project pages

On 03/03/2012 11:09 AM, Josť Romildo Malaquias wrote:
> $ opera http://sourceforge.net/projects/pgf/
> opera: no fonts found among preferred font formats, trying pcf fonts
> Unrecognized system call failure [fnmatch]: Invalid or incomplete multibyte or wide character
> opera [crash logging]: CRASH!!
> /usr/lib64/opera/opera got signal SIGSEGV at address 7F73ED1D17D5
>
> Log was created here:
> /var/tmp/crash20120303155333.txt

Is there anything interesting in that log file? If not, firefox-bin
has a 'crashreporter' function that might create a useful log.
 
Old 03-03-2012, 10:15 PM
Josť Romildo Malaquias
 
Default web browsers crash at sourceforge.net project pages

On Sat, Mar 03, 2012 at 03:55:26PM -0300, Josť Romildo Malaquias wrote:
> On Sat, Mar 03, 2012 at 10:38:29AM -0600, Paul Hartman wrote:
> > On Sat, Mar 3, 2012 at 8:06 AM, Josť Romildo Malaquias
> > <j.romildo@gmail.com> wrote:
> > > Hello.
> > >
> > > On my ~amd64 systems some web browsers (Mozilla Firefox 10.0.1, Midori
> > > 0.4.3, Opera 11.61 Build 1250) just crash when loading any
> > > sourceforge.net project page. Konquerer does not crash, though.
> > >
> > > I have already run revdep-rebuild, but the problem persists.
> > >
> > > Has anybody seen this? Any clues?
> >
> > They work for me, but in the olden days I had a similar problem that
> > was due to a corrupt font. Every time a site would use that font (or
> > specific glyph?) it would die.
>
> After uninstalling almost media-fonts/* packages, the problem still
> happens.
>
> # eix -IAc media-fonts
> [i] media-fonts/encodings (1.0.4{tbz2}@07/26/2011): X.Org font encodings
> [i] media-fonts/font-alias (1.0.3{tbz2}@07/27/2011): X.Org font aliases
> [i] media-fonts/font-misc-misc (1.1.2{tbz2}@07/27/2011): X.Org miscellaneous fonts
> [i] media-fonts/font-util (1.2.0{tbz2}@07/26/2011): X.Org font utilities
> Found 4 matches.
>
> $ fc-list
> Fixed:style=Bold
> Fixed:style=Bold SemiCondensed
> Fixed:style=SemiCondensed
> Fixed:style=Oblique SemiCondensed
> Fixed:style=Oblique
> Fixed:style=ko
> Fixed:style=ja
> Fixed:style=Regular
>
> Firefox, midori and opera crashes for both normal users I have on my
> system, as well as for the root user.


The problem was with some packages installed from the lcd-filtering
overlay. After removing the overlay and reinstalled them, the web
browsers do not crash anymore.

# emerge -avt1 corefonts media-fonts/dejavu liberation-fonts fontconfig freetype x11-libs/cairo libXf


Romildo
 

Thread Tools




All times are GMT. The time now is 08:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org