FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-22-2012, 06:47 PM
 
Default downgrading gcc, stage 2

Hi,

while trying to get a "clean" system after downgrading gcc to
gcc-4.4.5. I encountered a field of black magick...more black
than magic at all:

To find broken libs I did these two commands:
sudo find /usr/lib/. /lib/. /usr/bin/. -type f -name 'lib*[^a]' -exec ldd {} ; >! /tmp/librebuild.txt 2>&1
cat /tmp/librebuild.txt | grep GLIB

and got a list like this one:
/usr/lib/./firefox/libxpcom.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./firefox/components/libdbusservice.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./firefox/components/libbrowsercomps.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./firefox/components/libmozgnome.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./libwpd-stream-0.9.so.9.0.4: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./libwpd-stream-0.9.so.9.0.4)
/usr/lib/./xulrunner-devel-2.0/sdk/lib/libxpcom.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./xulrunner-devel-2.0/sdk/lib/libxul.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./xulrunner-devel-2.0/sdk/lib/libxul.so)
/usr/lib/./ardour2/libpbd.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/libpbd.so)
/usr/lib/./ardour2/libgtkmm2ext.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/libgtkmm2ext.so)
/usr/lib/./ardour2/surfaces/libardour_powermate.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/surfaces/libardour_powermate.so)
/usr/lib/./ardour2/surfaces/libardour_genericmidi.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/surfaces/libardour_genericmidi.so)
/usr/lib/./ardour2/surfaces/libardour_tranzport.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/surfaces/libardour_tranzport.so)
/usr/lib/./ardour2/surfaces/libardour_mackie.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/surfaces/libardour_mackie.so)
/usr/lib/./ardour2/libardour.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/libardour.so)
/usr/lib/./ardour2/libmidi++.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/libmidi++.so)
/usr/lib/./ardour2/libardour_cp.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./ardour2/libardour_cp.so)
/usr/lib/./xulrunner-2.0/libxpcom.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./xulrunner-2.0/components/libdbusservice.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./xulrunner-2.0/components/libmozgnome.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by //usr/lib64/xulrunner-2.0/libxul.so)
/usr/lib/./xulrunner-2.0/libxul.so: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./xulrunner-2.0/libxul.so)
/usr/lib/./libwpd-0.9.so.9.0.4: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./libwpd-0.9.so.9.0.4)
/usr/lib/./libdigikamdatabase.so.2.0.0: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./libdigikamdatabase.so.2.0.0)
/usr/lib/./libwpg-0.2.so.2.0.1: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib64/libwpd-0.9.so.9)
/usr/lib/./libwpg-0.2.so.2.0.1: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib64/libwpd-stream-0.9.so.9)
/usr/lib/./libMagick++.so.5.0.0: /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/./libMagick++.so.5.0.0)

(a emerge gcc:4.4 has already been completed at that point)

For me it looks like -- for example /usr/lib/./libMagick++.so.5.0.0
-- still awaits the API introduced with gcc:4.5

I rebuild a lot of applications and library-containing package, but
there are some which seems to resistant against my attempts to solve
their problems via recompiling them with gcc-4.4.5

In general I did for example

sudo emerge /usr/lib/./libMagick++.so.5.0.0

but the next find/grep-combo still reports it as broken.

The settings are:
solfire:/home/user>gcc-config -l
[1] x86_64-pc-linux-gnu-4.4.5 *
[2] x86_64-pc-linux-gnu-4.5.3

Either I misunderstood the context complete or.... I misunderstand
completly.

Any ideas, whats going on here?

Best regards,
mcc
 
Old 02-22-2012, 06:58 PM
Alan McKinnon
 
Default downgrading gcc, stage 2

On Wed, 22 Feb 2012 20:47:24 +0100
meino.cramer@gmx.de wrote:

> Hi,
>
> while trying to get a "clean" system after downgrading gcc to
> gcc-4.4.5. I encountered a field of black magick...more black
> than magic at all:
>
> To find broken libs I did these two commands:
> sudo find /usr/lib/. /lib/. /usr/bin/. -type f -name 'lib*[^a]'
> -exec ldd {} ; >! /tmp/librebuild.txt 2>&1 cat /tmp/librebuild.txt |
> grep
> GLIB

Why don't you just use revdep-rebuild?

That tool automates precisely what you are trying to do manually.


--
Alan McKinnnon
alan.mckinnon@gmail.com
 
Old 02-22-2012, 07:19 PM
Mark Knecht
 
Default downgrading gcc, stage 2

On Wed, Feb 22, 2012 at 11:58 AM, Alan McKinnon <alan.mckinnon@gmail.com> wrote:
> On Wed, 22 Feb 2012 20:47:24 +0100
> meino.cramer@gmx.de wrote:
>
>> Hi,
>>
>> while trying to get a "clean" system after downgrading gcc to
>> gcc-4.4.5. I encountered a field of black magick...more black
>> than magic at all:
>>
>> To find broken libs I did these two commands:
>> * * sudo find /usr/lib/. /lib/. /usr/bin/. -type f -name 'lib*[^a]'
>> -exec ldd {} ; >! /tmp/librebuild.txt 2>&1 cat /tmp/librebuild.txt |
>> grep
>> GLIB
>
> Why don't you just use revdep-rebuild?
>
> That tool automates precisely what you are trying to do manually.
>
>
> --
> Alan McKinnnon
> alan.mckinnon@gmail.com
>
>

I tend to agree with Alan. revdep-rebuild should help.

Additionally, if I were really intent on downgrading gcc, then I would
probably remove EVERY application unneeded to keep the machine running
down to and including X11, do the downgrade, rebuild the kernel and
reboot, do an emerge -e @world, make sure all that is working, and
only then start building apps. But that's just me...

Not exactly related, but I'm personally wondering what's driving the
need to downgrade. For kicks yesterday I rebuilt my laptop which
currently has audio apps as well as Blender on it with the latest
stable gcc. Everything rebuilt fine and everything I've tried seems to
run.

Good luck,
Mark
 

Thread Tools




All times are GMT. The time now is 01:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org