FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 04-01-2008, 04:44 AM
Ted Ozolins
 
Default gstreamer

I have both gstreamer-0.8 and -0.10 on my system. -0.8 is no longer in
portage. Revdep-rebuild complains about several packages as broken and
require gstreamer-0.8. I tried following:

http://gentoo-wiki.com/TIP_Troubleshooting_Gstreamer


Can I emerge -C =media-libs/gstreamer-0.8 without borking my system?
--
Ted Ozolins (VE7TVO)
Cranbrook, B.C.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-01-2008, 05:47 AM
Stroller
 
Default gstreamer

On 1 Apr 2008, at 05:44, Ted Ozolins wrote:

I have both gstreamer-0.8 and -0.10 on my system. -0.8 is no longer
in portage. Revdep-rebuild complains about several packages as
broken and require gstreamer-0.8. I tried following:

http://gentoo-wiki.com/TIP_Troubleshooting_Gstreamer


Can I emerge -C =media-libs/gstreamer-0.8 without borking my system?


I would _imagine_ so.
I'd expect that if you were to remove 0.8 then revdep-rebuild would
then allow the packages to be rebuilt linked against the late version.


However, to be sure that these packages don't have a depends that
specifies < 0.9 it might be worth telling use which packages are broken?

I take it you can't emerge -1 each of these packages separately?

Stroller.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-01-2008, 07:55 AM
Alan McKinnon
 
Default gstreamer

On Tuesday 01 April 2008, Ted Ozolins wrote:
> I have both gstreamer-0.8 and -0.10 on my system. -0.8 is no longer
> in portage. Revdep-rebuild complains about several packages as broken
> and
>
> require gstreamer-0.8. I tried following:
> > http://gentoo-wiki.com/TIP_Troubleshooting_Gstreamer
>
> Can I emerge -C =media-libs/gstreamer-0.8 without borking my system?

Please post the output of revdep-rebuild -p -i

Do these various packages require specifically gstreamer-0.8? If so,
that is a bug and should be rpeorted at b.g.o. In general, unmerging
gstreamer-0.8 will cause other things linked to it to now not work, so
I reckon you will suffer some fallout if you just unmerge it.

A good safety net will be to look into the portage cache in /var/db/pkg,
you will find a copy of the current gstreamer-0.8 ebuild you are using
there. Copy it to your local overlay so you can remerge it if
necessary. Do the same with any plugins that are also not in portage
anymore

--
Alan McKinnon
alan dot mckinnon at gmail dot com

--
gentoo-user@lists.gentoo.org mailing list
 
Old 04-01-2008, 07:56 AM
Neil Bothwick
 
Default gstreamer

On Mon, 31 Mar 2008 22:44:15 -0600, Ted Ozolins wrote:

> I have both gstreamer-0.8 and -0.10 on my system. -0.8 is no longer in
> portage. Revdep-rebuild complains about several packages as broken and
> require gstreamer-0.8. I tried following:
> > http://gentoo-wiki.com/TIP_Troubleshooting_Gstreamer
>
> Can I emerge -C =media-libs/gstreamer-0.8 without borking my system?

As it is no longer in portage, copy the ebuild from /var/db/pkg to your
overlay, then quickpkg it before you unmerge anything.

It will only have been removed for portage if nothing else in there
depends on it, so unmerge it (after doing the above) then run
revdep-rebuild followed by emerge -uavD world.


--
Neil Bothwick

MS-DOS: if you believe in a flat Earth, this is the OS for you.
 

Thread Tools




All times are GMT. The time now is 05:10 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org