FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-19-2011, 06:54 PM
Allan Gottlieb
 
Default (Solved) please explain this contradictory(?) emerge dependency

On Sun, Dec 18 2011, Allan Gottlieb wrote:

> On Sun, Dec 18 2011, Joshua Murphy wrote:
>
>> On Sun, Dec 18, 2011 at 8:34 PM, Allan Gottlieb <gottlieb@nyu.edu> wrote:
>>> I get dependency problems in my normal update world that I can't
>>> understand. *The entire output is below.
>>>
>>> As far as I can tell gnome-2.32.1-r1 (which is installed) is requiring
>>> packages from gnome-3, which must be wrong. *I don't see any such
>>> dependencies in the ebuild for gnome-2.32.1-r1 and there is an "official
>>> mask list" (which I am using) for those of us who want to
>>> delay installing gnome-3 for a while.
>>>
>>> My conclusion that gnome-2... is requiring gnome-3 packages (which I
>>> know is wrong) comes from two points in the output below.
>>>
>>> 1. *The indenting of the --tree --verbose output seems to say this
>>> * *(e.g., the first two lines say gnome-2... depends on nautilus-3)
>>>
>>> 2. *The comments related to mask changes at the bottom say
>>> * *evince-3... is required by gnome-2...
>>>
>>> Please help.
>>> thanks,
>>> allan
>>
>>
>> Without doing any digging (I'm 100mi away from my Gentoo boxes and
>> sitting on satellite internet, so SSH is painful), I would presume the
>> packages pulling in those dependencies aren't specifying a maximum
>> version, so it's not that they're "requiring" gnome 3 packages,
>> they're requiring gnome packages and are choosing to use the newest,
>> which happens to be part of 3, meaning the gnome 2 ebuilds would need
>> updated to require version < 3.0 to avoid it automatically, and
>> possibly block on mixing 2 and 3 if the mixing really does give
>> issues.
>
> All the gnome-3 packages are masked (package.mask).
>
> Indeed, at the end of my output (see prev msg) you see recommendations
> from emerge for me to remove some masks.
>
> allan

It was more subtle than I thought. A big tip from Alexandre Rostovtsev
suggested that the problem might be that some package other than
gnome-base/gnome might be requiring nautilus-3 *OR introspection*.

Sure enough the new evince was the culprit. I put in a workaround for
today but everything should be fine tomorrow due to ...

From: Allan Gottlieb <gottlieb@nyu.edu>
Subject: Re: [Bug 395173] gnome-light-2.32 shouldn't depend on >=x11-themes/gnome-themes-standard-3.0.2
To: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Mon, 19 Dec 2011 14:47:08 -0500

On Mon, Dec 19 2011, Alexandre Rostovtsev wrote:

> On Mon, 2011-12-19 at 10:59 -0500, Allan Gottlieb wrote:
>> The equery d command (with depth=2 or depth=30) shows no mention of
>> gnome-3, but *does* show introspection. Specifically
>>
>> app-text/evince-2.32.0-r3 (nautilus ? >=gnome-base/nautilus-2.10[introspection?])
>>
> Ah, that explains it.
>
> When we unmasked gobject-introspection in August, the introspection
> USE flag was masked on versions of gnome-2 packages that were already
> stable, including on <app-text/evince-2.32.0-r4 and
> <gnome-base/nautilus-2.32.2.1-r2.
>
> Two days ago, evince was bumped to 2.32.0-r4 to fix a crash.
> Therefore, evince-2.32.0-r4 became the first gnome-2 version of evince
> that had introspection unmasked, and it wanted to pull in
> nautilus[introspection]. But the latest gnome-2 version of nautilus in
> portage was nautilus-2.32.2.1-r1, which had introspection masked.
> Therefore, evince-2.32.0-r4 effectively depended on nautilus-3. And
> since nautilus-3 and evince-2.32.0-r4 are both in ~arch, repoman (the
> automatic script that gentoo developers use to check their ebuilds
> before committing) did not catch the problem
>
> I have now fixed it by bumping nautilus to 2.32.2.1-r2, and have
> alerted the other gnome team members to be aware of this issue.
>
> Thank you very much for reporting this as soon as you did!
>
> -Alexandre.

Great. So tomorrow, my resync will find nautilus...-r2 and I will be
able to remove
app-text/evince -introspection
from package.use.
(That is the workaround I put in today to permit an update world to
proceed without gnome-3).

Case closed!
allan
 
Old 12-20-2011, 02:10 AM
Pandu Poluan
 
Default (Solved) please explain this contradictory(?) emerge dependency

On Dec 20, 2011 2:58 AM, "Allan Gottlieb" <gottlieb@nyu.edu> wrote:

>

> On Sun, Dec 18 2011, Allan Gottlieb wrote:

>

> > On Sun, Dec 18 2011, Joshua Murphy wrote:

> >

> >> On Sun, Dec 18, 2011 at 8:34 PM, Allan Gottlieb <gottlieb@nyu.edu> wrote:

> >>> I get dependency problems in my normal update world that I can't

> >>> understand. *The entire output is below.

> >>>

> >>> As far as I can tell gnome-2.32.1-r1 (which is installed) is requiring

> >>> packages from gnome-3, which must be wrong. *I don't see any such

> >>> dependencies in the ebuild for gnome-2.32.1-r1 and there is an "official

> >>> mask list" (which I am using) for those of us who want to

> >>> delay installing gnome-3 for a while.

> >>>

> >>> My conclusion that gnome-2... is requiring gnome-3 packages (which I

> >>> know is wrong) comes from two points in the output below.

> >>>

> >>> 1. *The indenting of the --tree --verbose output seems to say this

> >>> * *(e.g., the first two lines say gnome-2... depends on nautilus-3)

> >>>

> >>> 2. *The comments related to mask changes at the bottom say

> >>> * *evince-3... is required by gnome-2...

> >>>

> >>> Please help.

> >>> thanks,

> >>> allan

> >>

> >>

> >> Without doing any digging (I'm 100mi away from my Gentoo boxes and

> >> sitting on satellite internet, so SSH is painful), I would presume the

> >> packages pulling in those dependencies aren't specifying a maximum

> >> version, so it's not that they're "requiring" gnome 3 packages,

> >> they're requiring gnome packages and are choosing to use the newest,

> >> which happens to be part of 3, meaning the gnome 2 ebuilds would need

> >> updated to require version < 3.0 to avoid it automatically, and

> >> possibly block on mixing 2 and 3 if the mixing really does give

> >> issues.

> >

> > All the gnome-3 packages are masked (package.mask).

> >

> > Indeed, at the end of my output (see prev msg) you see recommendations

> > from emerge for me to remove some masks.

> >

> > allan

>

> It was more subtle than I thought. *A big tip from Alexandre Rostovtsev

> suggested that the problem might be that some package other than

> gnome-base/gnome might be requiring nautilus-3 *OR introspection*.

>

> Sure enough the new evince was the culprit. *I put in a workaround for

> today but everything should be fine tomorrow due to ...

>

> * *From: Allan Gottlieb <gottlieb@nyu.edu>

> * *Subject: Re: [Bug 395173] gnome-light-2.32 shouldn't depend on >=x11-themes/gnome-themes-standard-3.0.2

> * *To: Alexandre Rostovtsev <tetromino@gentoo.org>

> * *Date: Mon, 19 Dec 2011 14:47:08 -0500

>

> * *On Mon, Dec 19 2011, Alexandre Rostovtsev wrote:

>

> * *> On Mon, 2011-12-19 at 10:59 -0500, Allan Gottlieb wrote:

> * *>> The equery d *command (with depth=2 or depth=30) shows no mention of

> * *>> gnome-3, but *does* show introspection. *Specifically

> * *>>

> * *>> app-text/evince-2.32.0-r3 (nautilus ? >=gnome-base/nautilus-2.10[introspection?])

> * *>>

> * *> Ah, that explains it.

> * *>

> * *> When we unmasked gobject-introspection in August, the introspection

> * *> USE flag was masked on versions of gnome-2 packages that were already

> * *> stable, including on <app-text/evince-2.32.0-r4 and

> * *> <gnome-base/nautilus-2.32.2.1-r2.

> * *>

> * *> Two days ago, evince was bumped to 2.32.0-r4 to fix a crash.

> * *> Therefore, evince-2.32.0-r4 became the first gnome-2 version of evince

> * *> that had introspection unmasked, and it wanted to pull in

> * *> nautilus[introspection]. But the latest gnome-2 version of nautilus in

> * *> portage was nautilus-2.32.2.1-r1, which had introspection masked.

> * *> Therefore, evince-2.32.0-r4 effectively depended on nautilus-3. And

> * *> since nautilus-3 and evince-2.32.0-r4 are both in ~arch, repoman (the

> * *> automatic script that gentoo developers use to check their ebuilds

> * *> before committing) did not catch the problem

> * *>

> * *> I have now fixed it by bumping nautilus to 2.32.2.1-r2, and have

> * *> alerted the other gnome team members to be aware of this issue.

> * *>

> * *> Thank you very much for reporting this as soon as you did!

> * *>

> * *> -Alexandre.

>

> * *Great. *So tomorrow, my resync will find nautilus...-r2 and I will be

> * *able to remove

> * * * *app-text/evince -introspection

> * *from package.use.

> * *(That is the workaround I put in today to permit an update world to

> * *proceed without gnome-3).

>


Cool!


A perfect example why we ought to report on bugs. It might save someone else from a teeth-gritting hardship, even when handling a totally unrelated package.


Well done, Gentoo-ers :-)


Rgds,
 

Thread Tools




All times are GMT. The time now is 09:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org