FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-19-2011, 02:54 AM
Allan Gottlieb
 
Default please explain this contradictory(?) emerge dependency

On Sun, Dec 18 2011, Joshua Murphy wrote:

> On Sun, Dec 18, 2011 at 8:34 PM, Allan Gottlieb <gottlieb@nyu.edu> wrote:
>> I get dependency problems in my normal update world that I can't
>> understand. *The entire output is below.
>>
>> As far as I can tell gnome-2.32.1-r1 (which is installed) is requiring
>> packages from gnome-3, which must be wrong. *I don't see any such
>> dependencies in the ebuild for gnome-2.32.1-r1 and there is an "official
>> mask list" (which I am using) for those of us who want to
>> delay installing gnome-3 for a while.
>>
>> My conclusion that gnome-2... is requiring gnome-3 packages (which I
>> know is wrong) comes from two points in the output below.
>>
>> 1. *The indenting of the --tree --verbose output seems to say this
>> * *(e.g., the first two lines say gnome-2... depends on nautilus-3)
>>
>> 2. *The comments related to mask changes at the bottom say
>> * *evince-3... is required by gnome-2...
>>
>> Please help.
>> thanks,
>> allan
>
>
> Without doing any digging (I'm 100mi away from my Gentoo boxes and
> sitting on satellite internet, so SSH is painful), I would presume the
> packages pulling in those dependencies aren't specifying a maximum
> version, so it's not that they're "requiring" gnome 3 packages,
> they're requiring gnome packages and are choosing to use the newest,
> which happens to be part of 3, meaning the gnome 2 ebuilds would need
> updated to require version < 3.0 to avoid it automatically, and
> possibly block on mixing 2 and 3 if the mixing really does give
> issues.

All the gnome-3 packages are masked (package.mask).

Indeed, at the end of my output (see prev msg) you see recommendations
from emerge for me to remove some masks.

allan
 
Old 12-19-2011, 11:56 AM
walt
 
Default please explain this contradictory(?) emerge dependency

On 12/18/2011 05:34 PM, Allan Gottlieb wrote:

# /etc/portage/package.mask:
# GNOME 3.2 stuff
=gnome-extra/sushi-0.2.1


Just working from memory here. Try removing the version number:

gnome-extra/sushi
 

Thread Tools




All times are GMT. The time now is 05:50 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org