Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   please explain this contradictory(?) emerge dependency (http://www.linux-archive.org/gentoo-user/611596-please-explain-contradictory-emerge-dependency.html)

Allan Gottlieb 12-19-2011 12:34 AM

please explain this contradictory(?) emerge dependency
 
I get dependency problems in my normal update world that I can't
understand. The entire output is below.

As far as I can tell gnome-2.32.1-r1 (which is installed) is requiring
packages from gnome-3, which must be wrong. I don't see any such
dependencies in the ebuild for gnome-2.32.1-r1 and there is an "official
mask list" (which I am using) for those of us who want to
delay installing gnome-3 for a while.

My conclusion that gnome-2... is requiring gnome-3 packages (which I
know is wrong) comes from two points in the output below.

1. The indenting of the --tree --verbose output seems to say this
(e.g., the first two lines say gnome-2... depends on nautilus-3)

2. The comments related to mask changes at the bottom say
evince-3... is required by gnome-2...

Please help.
thanks,
allan

================================================== ==============

ajglap gottlieb # emerge --keep-going --update --newuse --with-bdeps=y world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge ] gnome-base/gnome-2.32.1-r1 USE="cdr cups dvdr ldap policykit -accessibility -mono"
[nomerge ] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp"
[ebuild N #] gnome-extra/sushi-0.2.1 290 kB
[ebuild U #] app-text/evince-3.2.1-r1 [2.32.0-r3] USE="dbus gnome-keyring introspection* nautilus tiff -debug -djvu -doc -dvi -t1lib -xps% (-gnome%*)" 3,706 kB
[ebuild U #] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp" 4,594 kB
[ebuild NS ] net-libs/webkit-gtk-1.6.1-r301 [1.6.1-r201] USE="gstreamer introspection jit spell (-aqua) -coverage -debug -doc -test -webgl" 0 kB
[ebuild N ] dev-libs/gjs-1.30.0 USE="-examples -test" 445 kB
[ebuild N ] dev-lang/spidermonkey-1.8.5-r1 USE="-debug -static-libs -test" 6,021 kB
[ebuild N ] media-libs/clutter-gtk-1.0.4 USE="introspection -debug -doc -examples" 299 kB
[ebuild N ] media-libs/clutter-gst-1.4.4 USE="introspection -debug -doc -examples" 330 kB
[ebuild N ] media-libs/clutter-1.6.20 USE="introspection -debug -doc" 4,414 kB
[ebuild N ] dev-libs/json-glib-0.14.2 USE="introspection -debug -doc" 435 kB
[ebuild NS ] x11-libs/gtksourceview-3.2.3 [2.10.5-r2] USE="introspection -doc -glade -test" 1,188 kB
[ebuild N ] x11-themes/gnome-icon-theme-symbolic-3.2.1 144 kB
[ebuild N ] dev-util/gdbus-codegen-2.30.2 5,683 kB
[ebuild NS ] gnome-base/gnome-desktop-3.2.1 [2.32.1-r1] USE="introspection -debug -doc" 903 kB

Total: 14 packages (2 upgrades, 9 new, 3 in new slots), Size of downloads: 28,444 kB

The following mask changes are necessary to proceed:
#required by gnome-base/nautilus-3.2.1-r1[previewer], required by app-text/evince-3.2.1-r1[nautilus], required by gnome-base/gnome-2.32.1-r1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# GNOME 3.2 stuff
=gnome-extra/sushi-0.2.1
#required by gnome-extra/sushi-0.2.1, required by gnome-base/nautilus-3.2.1-r1[previewer], required by gnome-base/gnome-control-center-2.32.1-r1, required by gnome-base/gnome-2.32.1-r1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# GNOME 3.2 stuff
# GNOME 3 core libs
# Core Applications
# Extra Applications
=app-text/evince-3.2.1-r1
#required by gnome-extra/sushi-0.2.1
# /etc/portage/package.mask:
# GNOME 3.2 stuff
# GNOME 3 core libs
# Core Applications
=gnome-base/nautilus-3.2.1-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
ajglap gottlieb #

Allan Gottlieb 12-19-2011 12:58 AM

please explain this contradictory(?) emerge dependency
 
On Sun, Dec 18 2011, Allan Gottlieb wrote:

> I get dependency problems in my normal update world that I can't
> understand. The entire output is below.
>
> As far as I can tell gnome-2.32.1-r1 (which is installed) is requiring
> packages from gnome-3, which must be wrong. I don't see any such
> dependencies in the ebuild for gnome-2.32.1-r1 and there is an "official
> mask list" (which I am using) for those of us who want to
> delay installing gnome-3 for a while.
>
> My conclusion that gnome-2... is requiring gnome-3 packages (which I
> know is wrong) comes from two points in the output below.
>
> 1. The indenting of the --tree --verbose output seems to say this
> (e.g., the first two lines say gnome-2... depends on nautilus-3)
>
> 2. The comments related to mask changes at the bottom say
> evince-3... is required by gnome-2...
>
> Please help.
> thanks,
> allan

A new bug just appeared on bugs.gnome.org that may be related
#395173

allan


All times are GMT. The time now is 10:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.