FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-17-2011, 01:22 PM
Allan Gottlieb
 
Default Why is gnome-2.32.1-r1 requiring the gnome-3 nautilus and evince?

I run gnome3 on a test laptop, but want to wait until intersession to
install it on my real laptop. I will probably like gnome3, but had a
bad experience a few months ago when gnome-shell repeatedly crashed so
want to wait for a "quiet time" to do the upgrade.

Anyway, weeks ago I installed the package.mask list and all was well
until this morning. Here is the beginning of the output from emerge
--tree --verbose [the full output is below]

Calculating dependencies... done!
[ebuild U ] sys-block/gparted-0.11.0 [0.10.0] USE="gtk -btrfs -dmraid -fat -hfs -jfs -kde -mdadm -ntfs -reiser4 -reiserfs -xfs" 1,623 kB
[nomerge ] gnome-base/gnome-2.32.1-r1 USE="cdr cups dvdr ldap policykit -accessibility -mono"
[nomerge ] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp"

If I am reading this correctly gpartd is requiring gnome-2.32.1-r1
(which is installed), and the latter is requiring nautilus-3.2.1-r1.

The end of the emerge output says that gnome-2.32.1-r1 requires
evince-3.2.1-r1[nautilus].

I looked at the gnome ebuild and don't see why it wants nautilus from
gnome-3 or evince from gnome-3.

Can someone explain this.

thanks,
allan


================ full emerge output ========================

ajglap gottlieb # emerge --keep-going --update --newuse --with-bdeps=y world
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild U ] sys-block/gparted-0.11.0 [0.10.0] USE="gtk -btrfs -dmraid -fat -hfs -jfs -kde -mdadm -ntfs -reiser4 -reiserfs -xfs" 1,623 kB
[nomerge ] gnome-base/gnome-2.32.1-r1 USE="cdr cups dvdr ldap policykit -accessibility -mono"
[nomerge ] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp"
[ebuild N #] gnome-extra/sushi-0.2.1 290 kB
[ebuild U #] app-text/evince-3.2.1-r1 [2.32.0-r3] USE="dbus gnome-keyring introspection* nautilus tiff -debug -djvu -doc -dvi -t1lib -xps% (-gnome%*)" 3,706 kB
[ebuild U #] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp" 4,594 kB
[ebuild N ] media-libs/clutter-gtk-1.0.4 USE="introspection -debug -doc -examples" 299 kB
[ebuild NS ] net-libs/webkit-gtk-1.6.1-r301 [1.6.1-r201] USE="gstreamer introspection jit spell (-aqua) -coverage -debug -doc -test -webgl" 0 kB
[ebuild NS ] x11-libs/gtksourceview-3.2.3 [2.10.5-r1] USE="introspection -doc -glade -test" 1,188 kB
[ebuild NS ] gnome-base/gnome-desktop-3.2.1 [2.32.1-r1] USE="introspection -debug -doc" 903 kB
[ebuild U ] x11-libs/gtksourceview-2.10.5-r2 [2.10.5-r1] USE="-doc -glade -test" 1,224 kB
[nomerge ] gnome-extra/sushi-0.2.1
[ebuild N ] media-libs/clutter-gst-1.4.4 USE="introspection -debug -doc -examples" 330 kB
[ebuild N ] dev-libs/gjs-1.30.0 USE="-examples -test" 445 kB
[ebuild N ] media-libs/clutter-1.6.20 USE="introspection -debug -doc" 4,414 kB
[nomerge ] dev-libs/gjs-1.30.0 USE="-examples -test"
[ebuild N ] dev-lang/spidermonkey-1.8.5-r1 USE="-debug -static-libs -test" 6,021 kB
[nomerge ] media-libs/clutter-gst-1.4.4 USE="introspection -debug -doc -examples"
[nomerge ] media-libs/clutter-1.6.20 USE="introspection -debug -doc"
[ebuild N ] dev-libs/json-glib-0.14.2 USE="introspection -debug -doc" 435 kB
[nomerge ] media-gfx/gimp-2.6.11-r6 USE="alsa dbus exif gnome jpeg lcms mmx mng pdf png sse svg tiff -aalib (-altivec) -curl -debug -doc -python -smp -webkit -wmf"
[nomerge ] gnome-base/gvfs-1.10.1 USE="bluetooth cdda gdu gnome-keyring http udev -afp -archive -avahi -bluray -doc -fuse -gphoto2 -ios -samba"
[nomerge ] sys-apps/gnome-disk-utility-3.0.2-r200 USE="gnome-keyring nautilus -avahi -doc -fat -remote-access"
[nomerge ] gnome-base/nautilus-3.2.1-r1 [2.32.2.1-r1] USE="exif%* gnome introspection* previewer%* -doc -packagekit% -sendto% -test -tracker% -xmp"
[ebuild N ] x11-themes/gnome-icon-theme-symbolic-3.2.1 144 kB
[ebuild N ] dev-util/gdbus-codegen-2.30.2 5,683 kB
[nomerge ] media-video/gnome-mplayer-1.0.5_beta1 USE="alsa dbus dconf gnome libnotify pulseaudio -ipod -musicbrainz"
[nomerge ] media-libs/gmtk-1.0.5_beta1 USE="alsa dconf pulseaudio"
[nomerge ] x11-libs/gtk+-3.2.2-r2 USE="colord cups introspection (-aqua) -debug -doc -examples -packagekit -test -vim-syntax -xinerama"
[nomerge ] x11-misc/colord-0.1.15 USE="introspection scanner udev -doc -examples -gusb -vala"
[ebuild U ] media-libs/lcms-2.3 [2.2-r1] USE="jpeg tiff zlib -doc -static-libs -test" 4,358 kB

Total: 17 packages (5 upgrades, 9 new, 3 in new slots), Size of downloads: 35,647 kB

The following mask changes are necessary to proceed:
#required by gnome-base/nautilus-3.2.1-r1[previewer], required by app-text/evince-3.2.1-r1[nautilus], required by gnome-base/gnome-2.32.1-r1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# GNOME 3.2 stuff
=gnome-extra/sushi-0.2.1
#required by gnome-extra/sushi-0.2.1, required by gnome-base/nautilus-3.2.1-r1[previewer], required by gnome-base/gnome-control-center-2.32.1-r1, required by gnome-base/gnome-2.32.1-r1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# GNOME 3.2 stuff
# GNOME 3 core libs
# Core Applications
# Extra Applications
=app-text/evince-3.2.1-r1
#required by gnome-extra/sushi-0.2.1
# /etc/portage/package.mask:
# GNOME 3.2 stuff
# GNOME 3 core libs
# Core Applications
=gnome-base/nautilus-3.2.1-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
ajglap gottlieb #
 
Old 12-17-2011, 02:12 PM
walt
 
Default Why is gnome-2.32.1-r1 requiring the gnome-3 nautilus and evince?

On 12/17/2011 06:22 AM, Allan Gottlieb wrote:

The following mask changes are necessary to proceed:
#required by gnome-base/nautilus-3.2.1-r1[previewer]


Do you have the 'previewer' useflag set? I'm guessing that
the older nautilus doesn't have that functionality, so the
new version gets pulled in to supply it. Maybe?
 
Old 12-17-2011, 02:41 PM
Allan Gottlieb
 
Default Why is gnome-2.32.1-r1 requiring the gnome-3 nautilus and evince?

On Sat, Dec 17 2011, walt wrote:

> On 12/17/2011 06:22 AM, Allan Gottlieb wrote:
>> The following mask changes are necessary to proceed:
>> #required by gnome-base/nautilus-3.2.1-r1[previewer]
>
> Do you have the 'previewer' useflag set? I'm guessing that
> the older nautilus doesn't have that functionality, so the
> new version gets pulled in to supply it. Maybe?

I think not. emerge --info seems to agree


USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline scanner sdl session socialweb spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

allan
 

Thread Tools




All times are GMT. The time now is 07:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org