FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-10-2011, 07:37 PM
Michael Sullivan
 
Default Two video problems: Mythtv and xscreensaver

I'm having a problem on my personal workstation where mythfrontend will
not display video when Watch TV is requested. The sound works just
fine. When I issue a

michael@camille ~ $ mplayer /dev/video0
MPlayer SVN-r33094-4.4.5 (C) 2000-2011 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing /dev/video0.
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
MPEG-PS file format detected.
VIDEO: MPEG2 480x480 (aspect 2) 29.970 fps 6000.0 kbps (750.0 kbyte/s)
Load subtitles in /dev/
[VO_TDFXFB] This driver only supports the 3Dfx Banshee, Voodoo3 and
Voodoo 5.
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
================================================== ========================
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 480x480 => 640x480 Planar YV12
[mpeg2video @ 0x87a1ce0]warning: first frame is no keyframe
[VD_FFMPEG] DRI failure.
A: 0.7 V: 1.3 A-V: -0.591 ct: 0.000 2/ 2 ??% ??% ??,?% 1 0
[mpeg2video @ 0x87a1ce0]warning: first frame is no keyframe
A: 9.3 V: 9.3 A-V: -0.015 ct: -0.788 241/241 9% 0% 1.4% 4 0

Exiting... (Quit)

there is still no picture, but sound is present. My xscreesaver is set
to glslideshow displaying pictures and it doesn't display pictures.
When I run it, I get these errors: (from ~/.xsession-errors)

X error in glslideshow:
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 136 (DRI2)
Minor opcode of failed request: 8 (DRI2SwapBuffers )
Resource id in failed request: 0x3200070
Serial number of failed request: 1999
Current serial number in output stream: 1999
xscreensaver-getimage: target pixmap 0x340010a unexpectedly deleted


When I look at the Xorg logs, I find this:

camille ~ # grep EE /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[621028.083] (II) Loading extension MIT-SCREEN-SAVER
[621029.135] (EE) intel(0): Detected a hung GPU, disabling acceleration.
[621029.135] (EE) intel(0): When reporting this, please include
i915_error_state from debugfs and the full dmesg.
[621215.105] (EE) intel(0): [DRI2] DRI2SwapBuffers: drawable has no back
or front?
[621217.191] (EE) intel(0): [DRI2] DRI2SwapBuffers: drawable has no back
or front?

Just before I got this listing I restarted X after doing a qlist -I -C
x11-drivers/ and re-merging all of them (there were like 10).
Mythfrontend Watch TV works fine from every other computer on my
network, and the recordings are fine, so I'm pretty sure it's this
DRI2SwapBuffers thing. What should I do to resolve this?
 

Thread Tools




All times are GMT. The time now is 01:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org