FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 12-03-2011, 01:49 PM
Michael Mol
 
Default Gnupg 2 and BZIP2 preference

On Sat, Dec 3, 2011 at 9:32 AM, Claudio Roberto França Pereira
<spideybr@gmail.com> wrote:
> Try emerge -pv gnupg.
> Maybe the devs had masked the bzip2 use flag for some reason.
>
> Sorry, I'm not in Gentoo right now to assist you more.

Doesn't look like it, at least to my limited ability to follow .ebuild
files. bzip2 is there. Also, no mention of bzip2 in Changelog. (We're
talking about app-crypt/gnupg, not app-vim/gnupg, right? emerge
complained about ambiguity while I was searching.)

fwiw:

shortcircuit@kaylee /usr/portage/app-crypt/gnupg $ equery m app-crypt/gnupg
* app-crypt/gnupg [gentoo]
Herd: crypto (crypto@gentoo.org)
Maintainer: crypto@gentoo.org (Crypto Herd)
Upstream: None specified
Homepage: http://www.gnupg.org/
Location: /usr/portage/app-crypt/gnupg
Keywords: 1.4.11:0:
Keywords: 2.0.17:0: alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86
Keywords: 2.0.17-r2:0:
Keywords: 2.0.17-r3:0:
Keywords: 2.0.18:0: ~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~mips ~ppc
~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-solaris
~sparc64-solaris ~x64-freebsd ~x64-macos ~x64-solaris
~x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~x86-macos
~x86-solaris

shortcircuit@kaylee /usr/portage/app-crypt/gnupg $ equery y app-crypt/gnupg
Keywords for app-crypt/gnupg:
| | u |
| a a p s | n |
| l m h i m m p s p | u s | r
| p d a p a 6 i p c 3 a x | s l | e
| h 6 r p 6 8 p p 6 9 s r 8 | e o | p
| a 4 m a 4 k s c 4 0 h c 6 | d t | o
----------+---------------------------+-----+-------
1.4.11 | + + + + + o ~ + + + + + + | # 0 | gentoo
2.0.17 | + + + + + o ~ + + + + + + | o | gentoo
2.0.17-r2 | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | # | gentoo
2.0.17-r3 | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | # | gentoo
2.0.18 | ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ ~ | o | gentoo

--
:wq
 
Old 12-03-2011, 05:17 PM
Samuraiii
 
Default Gnupg 2 and BZIP2 preference

That's the Problem

no bzip2 masked



emerge -pv gnupg

[ebuild** R*** ] app-crypt/gnupg-2.0.17* USE="adns bzip2 ldap nls
static -caps -doc -openct -pcsc-lite (-selinux) -smartcard" 0 kB








On 2011-12-03 15:32, Claudio Roberto França Pereira wrote:
Try emerge -pv gnupg.

Maybe the devs had masked the bzip2 use flag for some reason.



Sorry, I'm not in Gentoo right now to assist you more.




--


Samuraiii

e-mail: samuraiii@volny.cz

GnuPG key ID: 0x80C752EA
(obtainable on http://pgp.mit.edu)

Full copy
of public timestamp block
signatures id- (from ) is included in header of html.
 
Old 12-05-2011, 11:51 PM
Claudio Roberto França Pereira
 
Default Gnupg 2 and BZIP2 preference

Are you sure you've re-emerged the package after adding the bzip2 use
flag? Run eix app-crypt/gnupg to confirm.
 
Old 12-06-2011, 09:18 AM
Samuraiii
 
Default Gnupg 2 and BZIP2 preference

few times my bzip2 flag is set from installation of systemabd
since then I needed gpg 1.4 one time so I needed emrege it*
(downgrading gpg 2) and then again upgrading it back and then I
even tried (few times) to emrege gpg (for rebuilding) because of
this problem

If you want to see emerge --info gnupg follow my bug



https://bugs.gentoo.org/show_bug.cgi?id=390163



S






On 2011-12-06 01:51, Claudio Roberto França Pereira wrote:

Are you sure you've re-emerged the package after adding the bzip2 use
flag? Run eix app-crypt/gnupg to confirm.







--


Samuraiii

e-mail: samuraiii@volny.cz

GnuPG key ID: 0x80C752EA
(obtainable on http://pgp.mit.edu)

Full copy
of public timestamp block
signatures id- (from ) is included in header of html.
 
Old 12-06-2011, 10:49 AM
Florian Philipp
 
Default Gnupg 2 and BZIP2 preference

Am 06.12.2011 11:18, schrieb Samuraiii:
> few times my bzip2 flag is set from installation of systemabd since then
> I needed gpg 1.4 one time so I needed emrege it (downgrading gpg 2) and
> then again upgrading it back and then I even tried (few times) to emrege
> gpg (for rebuilding) because of this problem
> If you want to see emerge --info gnupg follow my bug
>
> https://bugs.gentoo.org/show_bug.cgi?id=390163
>
> S
>

There is also a GnuPG mailing list with some highly competent
participants. Maybe you should ask there. Maybe something about your gpg
config or key file is off.

Regards,
Florian Philipp
 

Thread Tools




All times are GMT. The time now is 09:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org