Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Vim stops installing when it runs installman.sh (http://www.linux-archive.org/gentoo-user/600172-vim-stops-installing-when-runs-installman-sh.html)

1990 dqgcs 11-19-2011 01:44 AM

Vim stops installing when it runs installman.sh
 
Hi Everyone*I *am very sad i failed to install vim in gentoo ,without vim i could not do anything :(*I download*vim-7.3.tar.bz2*not emerge because i can modify Makefile to find out where is wrong.Compiling seems well,but when it begin to install man ,it stops,just like:

/bin/sh ./installman.sh install /usr/local/share/man/it/man1 "-it" /usr/local/share/vim /usr/local/share/vim/vim73 /usr/local/share/vim ../runtime/doc 644 vim vimdiff evim
installing /usr/local/share/man/it/man1/vim.1and never go on..... sool cruel
Yes ,the script is installman.sh and it stop here below,what should i do?it runs very well in my ubuntu! what is wrong???
# vim.1* *echo installing $destdir/$exename.1* *sed -e s+/usr/local/lib/vim+$vimloc+ * -e s+$vimloc/doc+$helpsubloc+
* -e s+$vimloc/print+$printsubloc+ * -e s+$vimloc/syntax+$synsubloc+
* -e s+$vimloc/tutor+$tutorsubloc+ * -e s+$vimloc/vimrc+$vimrcloc/vimrc+
* -e s+$vimloc/gvimrc+$vimrcloc/gvimrc+ * -e s+$vimloc/menu.vim+$scriptloc/menu.vim+
* -e s+$vimloc/bugreport.vim+$scriptloc/bugreport.vim+ * -e s+$vimloc/filetype.vim+$scriptloc/filetype.vim+
* -e s+$vimloc/scripts.vim+$scriptloc/scripts.vim+ * -e s+$vimloc/optwin.vim+$scriptloc/optwin.vim+
* -e 's+$vimloc/*.ps+$scriptloc/*.ps+' * $helpsource/vim$langadd.1 > $destdir/$exename.1
* *chmod $manmod $destdir/$exename.1
ANY suggest is OK,Thanks!!!Best RgdsEleree Nicola

James Broadhead 11-19-2011 01:01 PM

Vim stops installing when it runs installman.sh
 
On 19 November 2011 02:44, 1990 dqgcs <dqgcs1990@gmail.com> wrote:
> Hi Everyone
> I *am very sad i failed to install vim in gentoo ,without vim i could not do
> anything :(
> I download*vim-7.3.tar.bz2*not emerge because i can modify Makefile to find
> out where is wrong.Compiling seems well,but when it begin to install man ,it
> stops,just like:
> /bin/sh ./installman.sh install /usr/local/share/man/it/man1 "-it"
> /usr/local/share/vim /usr/local/share/vim/vim73 /usr/local/share/vim
> ../runtime/doc 644 vim vimdiff evim
> installing /usr/local/share/man/it/man1/vim.1
> and never go on..... sool cruel
> Yes ,the script is installman.sh and it stop here below,what should i do?it
> runs very well in my ubuntu! what is wrong???
> # vim.1
> * *echo installing $destdir/$exename.1
> * *sed -e s+/usr/local/lib/vim+$vimloc+
> * -e s+$vimloc/doc+$helpsubloc+
> * -e s+$vimloc/print+$printsubloc+
> * -e s+$vimloc/syntax+$synsubloc+
> * -e s+$vimloc/tutor+$tutorsubloc+
> * -e s+$vimloc/vimrc+$vimrcloc/vimrc+
> * -e s+$vimloc/gvimrc+$vimrcloc/gvimrc+
> * -e s+$vimloc/menu.vim+$scriptloc/menu.vim+
> * -e s+$vimloc/bugreport.vim+$scriptloc/bugreport.vim+
> * -e s+$vimloc/filetype.vim+$scriptloc/filetype.vim+
> * -e s+$vimloc/scripts.vim+$scriptloc/scripts.vim+
> * -e s+$vimloc/optwin.vim+$scriptloc/optwin.vim+
> * -e 's+$vimloc/*.ps+$scriptloc/*.ps+'
> * $helpsource/vim$langadd.1 > $destdir/$exename.1
> * *chmod $manmod $destdir/$exename.1
> ANY suggest is OK,Thanks!!!
> Best Rgds
> Eleree Nicola

$ eix app-editors/vim
[i] app-editors/vim
Available versions: 7.2.442 7.3.135 7.3.189 ~7.3.219 ~7.3.244
7.3.266 ~7.3.322 {X acl bash-completion cscope debug gpm minimal nls
perl python ruby vim-pager}
Installed versions: 7.3.266(23:14:32 09/10/11)(X acl
bash-completion gpm nls python -cscope -debug -minimal -perl -ruby
-vim-pager)
Homepage: http://www.vim.org/
Description: Vim, an improved vi-style text editor

So: to get the latest well-tested version of vim in gentoo, just run
"emerge vim" as root, which will get you vim-7.3.266. This will build
it with your configured settings/optimisations.

If you want to build it manually, you're on your own -- we can
probably help you if you supply more info, but unless you have a good
reason not to use portage/emerge, then you're not using your time
effectively.

Note: eix isn't installed by default, and it's super-useful. Run
"emerge eix ; eix-update" to get the output above.

Mick 11-19-2011 11:08 PM

Vim stops installing when it runs installman.sh
 
On Saturday 19 Nov 2011 14:01:56 James Broadhead wrote:
> On 19 November 2011 02:44, 1990 dqgcs <dqgcs1990@gmail.com> wrote:
> > Hi Everyone
> > I am very sad i failed to install vim in gentoo ,without vim i could not
> > do anything :(
> > I download vim-7.3.tar.bz2 not emerge because i can modify Makefile to
> > find out where is wrong.Compiling seems well,but when it begin to
> > install man ,it stops,just like:
> > /bin/sh ./installman.sh install /usr/local/share/man/it/man1 "-it"
> > /usr/local/share/vim /usr/local/share/vim/vim73 /usr/local/share/vim
> > ../runtime/doc 644 vim vimdiff evim
> > installing /usr/local/share/man/it/man1/vim.1
> > and never go on..... sool cruel
> > Yes ,the script is installman.sh and it stop here below,what should i
> > do?it runs very well in my ubuntu! what is wrong???
> > # vim.1
> > echo installing $destdir/$exename.1
> > sed -e s+/usr/local/lib/vim+$vimloc+
> > -e s+$vimloc/doc+$helpsubloc+
> > -e s+$vimloc/print+$printsubloc+
> > -e s+$vimloc/syntax+$synsubloc+
> > -e s+$vimloc/tutor+$tutorsubloc+
> > -e s+$vimloc/vimrc+$vimrcloc/vimrc+
> > -e s+$vimloc/gvimrc+$vimrcloc/gvimrc+
> > -e s+$vimloc/menu.vim+$scriptloc/menu.vim+
> > -e s+$vimloc/bugreport.vim+$scriptloc/bugreport.vim+
> > -e s+$vimloc/filetype.vim+$scriptloc/filetype.vim+
> > -e s+$vimloc/scripts.vim+$scriptloc/scripts.vim+
> > -e s+$vimloc/optwin.vim+$scriptloc/optwin.vim+
> > -e 's+$vimloc/*.ps+$scriptloc/*.ps+'
> > $helpsource/vim$langadd.1 > $destdir/$exename.1
> > chmod $manmod $destdir/$exename.1
> > ANY suggest is OK,Thanks!!!
> > Best Rgds
> > Eleree Nicola
>
> $ eix app-editors/vim
> [i] app-editors/vim
> Available versions: 7.2.442 7.3.135 7.3.189 ~7.3.219 ~7.3.244
> 7.3.266 ~7.3.322 {X acl bash-completion cscope debug gpm minimal nls
> perl python ruby vim-pager}
> Installed versions: 7.3.266(23:14:32 09/10/11)(X acl
> bash-completion gpm nls python -cscope -debug -minimal -perl -ruby
> -vim-pager)
> Homepage: http://www.vim.org/
> Description: Vim, an improved vi-style text editor
>
> So: to get the latest well-tested version of vim in gentoo, just run
> "emerge vim" as root, which will get you vim-7.3.266. This will build
> it with your configured settings/optimisations.
>
> If you want to build it manually, you're on your own -- we can
> probably help you if you supply more info, but unless you have a good
> reason not to use portage/emerge, then you're not using your time
> effectively.
>
> Note: eix isn't installed by default, and it's super-useful. Run
> "emerge eix ; eix-update" to get the output above.

It doesn't make sense not to use the distro's recommended package manager
(portage or even paludis). If you really like the script then compare what
the portage ebuild does agains the script you are using and then ... use the
ebuild!

Otherwise you are bound to come across dependency conflicts sooner or later and
end up with such a spaghetti in your hands that you will have to reinstall.
--
Regards,
Mick

1990 dqgcs 11-20-2011 12:41 AM

Vim stops installing when it runs installman.sh
 
I am sorry i have not made it clear,I meet the situation when i use "sudo emerge vim" after "sudo emerge --sync && sudo emerge -auvDN",So,i try to install my own vim for DEBUG,what should i do now,could i not to install man page?


2011/11/19 James Broadhead <jamesbroadhead@gmail.com>

On 19 November 2011 02:44, 1990 dqgcs <dqgcs1990@gmail.com> wrote:

> Hi Everyone

> I *am very sad i failed to install vim in gentoo ,without vim i could not do

> anything :(

> I download*vim-7.3.tar.bz2*not emerge because i can modify Makefile to find

> out where is wrong.Compiling seems well,but when it begin to install man ,it

> stops,just like:

> /bin/sh ./installman.sh install /usr/local/share/man/it/man1 "-it"

> /usr/local/share/vim /usr/local/share/vim/vim73 /usr/local/share/vim

> ../runtime/doc 644 vim vimdiff evim

> installing /usr/local/share/man/it/man1/vim.1

> and never go on..... sool cruel

> Yes ,the script is installman.sh and it stop here below,what should i do?it

> runs very well in my ubuntu! what is wrong???

> # vim.1

> * *echo installing $destdir/$exename.1

> * *sed -e s+/usr/local/lib/vim+$vimloc+

> * -e s+$vimloc/doc+$helpsubloc+

> * -e s+$vimloc/print+$printsubloc+

> * -e s+$vimloc/syntax+$synsubloc+

> * -e s+$vimloc/tutor+$tutorsubloc+

> * -e s+$vimloc/vimrc+$vimrcloc/vimrc+

> * -e s+$vimloc/gvimrc+$vimrcloc/gvimrc+

> * -e s+$vimloc/menu.vim+$scriptloc/menu.vim+

> * -e s+$vimloc/bugreport.vim+$scriptloc/bugreport.vim+

> * -e s+$vimloc/filetype.vim+$scriptloc/filetype.vim+

> * -e s+$vimloc/scripts.vim+$scriptloc/scripts.vim+

> * -e s+$vimloc/optwin.vim+$scriptloc/optwin.vim+

> * -e 's+$vimloc/*.ps+$scriptloc/*.ps+'

> * $helpsource/vim$langadd.1 > $destdir/$exename.1

> * *chmod $manmod $destdir/$exename.1

> ANY suggest is OK,Thanks!!!

> Best Rgds

> Eleree Nicola



$ eix app-editors/vim

[i] app-editors/vim

* * Available versions: *7.2.442 7.3.135 7.3.189 ~7.3.219 ~7.3.244

7.3.266 ~7.3.322 {X acl bash-completion cscope debug gpm minimal nls

perl python ruby vim-pager}

* * Installed versions: *7.3.266(23:14:32 09/10/11)(X acl

bash-completion gpm nls python -cscope -debug -minimal -perl -ruby

-vim-pager)

* * Homepage: * * * * * *http://www.vim.org/

* * Description: * * * * Vim, an improved vi-style text editor



So: to get the latest well-tested version of vim in gentoo, just run

"emerge vim" as root, which will get you vim-7.3.266. This will build

it with your configured settings/optimisations.



If you want to build it manually, you're on your own -- we can

probably help you if you supply more info, but unless you have a good

reason not to use portage/emerge, then you're not using your time

effectively.



Note: eix isn't installed by default, and it's super-useful. Run

"emerge eix ; eix-update" to get the output above.

1990 dqgcs 11-20-2011 12:43 AM

Vim stops installing when it runs installman.sh
 
Thanks for reply! I am sorry to tell you i have installed vim by emerge ,but i failed ,so i try to use vim7.3.266'source code for debug :( .Now what could i do?i am almost crazy now!!!

2011/11/20 Mick <michaelkintzios@gmail.com>

On Saturday 19 Nov 2011 14:01:56 James Broadhead wrote:

> On 19 November 2011 02:44, 1990 dqgcs <dqgcs1990@gmail.com> wrote:

> > Hi Everyone

> > I *am very sad i failed to install vim in gentoo ,without vim i could not

> > do anything :(

> > I download vim-7.3.tar.bz2 not emerge because i can modify Makefile to

> > find out where is wrong.Compiling seems well,but when it begin to

> > install man ,it stops,just like:

> > /bin/sh ./installman.sh install /usr/local/share/man/it/man1 "-it"

> > /usr/local/share/vim /usr/local/share/vim/vim73 /usr/local/share/vim

> > ../runtime/doc 644 vim vimdiff evim

> > installing /usr/local/share/man/it/man1/vim.1

> > and never go on..... sool cruel

> > Yes ,the script is installman.sh and it stop here below,what should i

> > do?it runs very well in my ubuntu! what is wrong???

> > # vim.1

> > * *echo installing $destdir/$exename.1

> > * *sed -e s+/usr/local/lib/vim+$vimloc+

> > * -e s+$vimloc/doc+$helpsubloc+

> > * -e s+$vimloc/print+$printsubloc+

> > * -e s+$vimloc/syntax+$synsubloc+

> > * -e s+$vimloc/tutor+$tutorsubloc+

> > * -e s+$vimloc/vimrc+$vimrcloc/vimrc+

> > * -e s+$vimloc/gvimrc+$vimrcloc/gvimrc+

> > * -e s+$vimloc/menu.vim+$scriptloc/menu.vim+

> > * -e s+$vimloc/bugreport.vim+$scriptloc/bugreport.vim+

> > * -e s+$vimloc/filetype.vim+$scriptloc/filetype.vim+

> > * -e s+$vimloc/scripts.vim+$scriptloc/scripts.vim+

> > * -e s+$vimloc/optwin.vim+$scriptloc/optwin.vim+

> > * -e 's+$vimloc/*.ps+$scriptloc/*.ps+'

> > * $helpsource/vim$langadd.1 > $destdir/$exename.1

> > * *chmod $manmod $destdir/$exename.1

> > ANY suggest is OK,Thanks!!!

> > Best Rgds

> > Eleree Nicola

>

> $ eix app-editors/vim

> [i] app-editors/vim

> * * *Available versions: *7.2.442 7.3.135 7.3.189 ~7.3.219 ~7.3.244

> 7.3.266 ~7.3.322 {X acl bash-completion cscope debug gpm minimal nls

> perl python ruby vim-pager}

> * * *Installed versions: *7.3.266(23:14:32 09/10/11)(X acl

> bash-completion gpm nls python -cscope -debug -minimal -perl -ruby

> -vim-pager)

> * * *Homepage: * * * * * *http://www.vim.org/

> * * *Description: * * * * Vim, an improved vi-style text editor

>

> So: to get the latest well-tested version of vim in gentoo, just run

> "emerge vim" as root, which will get you vim-7.3.266. This will build

> it with your configured settings/optimisations.

>

> If you want to build it manually, you're on your own -- we can

> probably help you if you supply more info, but unless you have a good

> reason not to use portage/emerge, then you're not using your time

> effectively.

>

> Note: eix isn't installed by default, and it's super-useful. Run

> "emerge eix ; eix-update" to get the output above.



It doesn't make sense not to use the distro's recommended package manager

(portage or even paludis). *If you really like the script then compare what

the portage ebuild does agains the script you are using and then ... use the

ebuild!



Otherwise you are bound to come across dependency conflicts sooner or later and

end up with such a spaghetti in your hands that you will have to reinstall.

--

Regards,

Mick

Mick 11-20-2011 08:54 AM

Vim stops installing when it runs installman.sh
 
On Sunday 20 Nov 2011 01:43:47 1990 dqgcs wrote:
> Thanks for reply! I am sorry to tell you i have installed vim by emerge
> ,but i failed ,so i try to use vim7.3.266'source code for debug :( .Now
> what could i do?i am almost crazy now!!!

No need to go crazy! :-)

Run

MAKEOPTS="-j1" emerge -uaDv app-editors/vim

and post here the error. This may be shown a few pages above where the emerge
fails - so you will need to scroll up a bit. Hopefully someone on this list
would know what to suggest.


PS. Also check https://bugs.gentoo.org/ in case someone has already reported
this problem.
--
Regards,
Mick

1990 dqgcs 11-21-2011 02:00 PM

Vim stops installing when it runs installman.sh
 
Hi MickHere is my output ,Thanks for help!!!******************************************* ************************************************** **********.-(~)-------------------------------------------------------------(ayu@Freedom)-
`--> * MAKEOPTS="-j1" emerge -uaDv app-editors/vimThis action requires superuser access...Would you like to add --pretend to options? [Yes/No] yes
These are the packages that would be merged, in order:

Calculating dependencies... done![ebuild * * U *] app-arch/bzip2-1.0.6-r3 [1.0.6-r2] USE="static-libs%* -static" 0 kB[ebuild * * U *] dev-libs/icu-4.8.1-r2 [4.8] USE="static-libs -debug -doc -examples" 18,241 kB
[ebuild * * U *] dev-libs/libffi-3.0.10 [3.0.9-r2] USE="static-libs -debug -test" 736 kB[ebuild * * U *] sys-libs/timezone-data-2011l [2011h] USE="nls" 331 kB[ebuild * * U *] sys-devel/automake-wrapper-5 [4] 0 kB
[ebuild * * U *] sys-apps/sandbox-2.5 [2.4] USE="(-multilib)" 348 kB[ebuild * * U *] sys-apps/less-444 [441] USE="unicode" 301 kB[ebuild * * U *] sys-kernel/linux-headers-2.6.39 [2.6.36.1] 4,583 kB
[ebuild * * U *] dev-perl/IO-Socket-SSL-1.440.0 [1.35] USE="-idn" 68 kB[ebuild * * U *] dev-util/gtk-doc-am-1.18 [1.17] 623 kB[ebuild * * U *] media-libs/freetype-2.4.7 [2.4.6] USE="X bzip2 static-libs -auto-hinter -bindist -debug -doc -fontforge -utils" 1,456 kB
[ebuild * * U *] dev-lang/python-2.7.2-r3 [2.7.1-r1] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite* -tk -wininst" 11,494 kB[ebuild * * U *] dev-libs/libxml2-2.7.8-r3 [2.7.8-r1] USE="icu ipv6 python readline static-libs%* -debug -doc -examples -test" 0 kB
[ebuild * * U *] dev-libs/libxslt-1.1.26-r2 [1.1.26-r1] USE="crypt python static-libs%* -debug" 0 kB[ebuild * * U *] dev-lang/python-3.1.4-r3 [3.1.3-r1] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst" 8,005 kB
[ebuild * * U *] sys-apps/util-linux-2.19.1-r1 [2.19.1] USE="cramfs crypt ncurses nls unicode -loop-aes -old-linux -perl (-selinux) -slang (-uclibc)" 0 kB[ebuild * * U *] sys-devel/binutils-2.21.1-r1 [2.20.1-r1] USE="nls static-libs -multislot -multitarget -test -vanilla" 18,572 kB
[ebuild * * U *] sys-devel/llvm-2.9-r2 [2.8-r2] USE="libffi -debug -llvm-gcc -multitarget -ocaml -test -udis86 -vim-syntax%" 9,351 kB[ebuild * * U *] app-text/docbook-xsl-stylesheets-1.76.1 [1.75.2] 3,597 kB
[ebuild * * U *] sys-apps/dbus-1.4.16 [1.4.12] USE="X static-libs -debug -doc (-selinux) -test" 1,846 kB[ebuild * * U *] dev-util/ctags-5.8 [5.7] USE="-ada" 469 kB[ebuild * * U *] dev-libs/dbus-glib-0.98 [0.92] USE="static-libs -debug -doc -test (-bash-completion%)" 707 kB
[ebuild * * U *] x11-misc/xdg-utils-1.1.0_rc1_p20111003 [1.1.0_rc1_p20110519] USE="-doc" 1,141 kB[ebuild * * U *] sys-libs/pam-1.1.5 [1.1.4] USE="berkdb cracklib nls -audit -debug -nis (-selinux) -test -vim-syntax" 1,584 kB
[ebuild * * U *] sys-auth/polkit-0.102 [0.101-r1] USE="gtk introspection nls pam -debug -doc -examples -kde" 860 kB[ebuild *N * * ] app-editors/vim-core-7.3.266 *USE="acl nls -bash-completion -livecd" 0 kB
[ebuild *N * * ] app-editors/vim-7.3.266 *USE="X acl gpm nls python -bash-completion -cscope -debug -minimal -perl -ruby -vim-pager" 0 kB[ebuild * * U *] x11-libs/gtk+-2.24.5-r1 [2.24.4] USE="cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama" 12,942 kB
[ebuild * * U *] media-libs/libpng-1.5.5 [1.4.8-r1] USE="static-libs -apng" 670 kB[ebuild * * U *] x11-libs/gdk-pixbuf-2.24.0-r1 [2.22.1-r2] USE="X introspection jpeg -debug -doc -jpeg2k -test -tiff (-svg%*)" 1,149 kB
[ebuild * * U *] app-text/ghostscript-gpl-9.04-r4 [9.04-r3] USE="X cups dbus gtk static-libs -bindist -djvu -idn -jpeg2k" LINGUAS="zh_CN -ja -ko -zh_TW" 0 kB[blocks B * * *] <x11-libs/libsexy-0.1.11-r3 ("<x11-libs/libsexy-0.1.11-r3" is blocking media-libs/libpng-1.5.5)
[blocks B * * *] <x11-libs/gdk-pixbuf-2.24.0-r1 ("<x11-libs/gdk-pixbuf-2.24.0-r1" is blocking media-libs/libpng-1.5.5)
Total: 31 packages (29 upgrades, 2 new), Size of downloads: 99,064 kB
Conflict: 2 blocks (2 unsatisfied)
** Error: The above package list contains packages which cannot be** installed at the same time on the same system.
* (media-libs/libpng-1.5.5::gentoo, ebuild scheduled for merge) pulled in by
* * media-libs/libpng:0 required by (app-text/ghostscript-gpl-9.04-r4::gentoo, ebuild scheduled for merge)* * >=media-libs/libpng-1.4.3:0 required by (net-print/cups-1.4.8-r1::gentoo, installed)
* * >=media-libs/libpng-1.4:0 required by (app-text/poppler-0.16.7::gentoo, installed)* * >=media-libs/libpng-1.4:0 required by (x11-libs/gdk-pixbuf-2.24.0-r1::gentoo, ebuild scheduled for merge)
* * media-libs/libpng:0 required by (x11-libs/cairo-1.10.2-r1::gentoo, installed)

For more information about Blocked Packages, please refer to the followingsection of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

** IMPORTANT: 1 news items need reading for repository 'gentoo'.
** Use eselect news to read news items.
.-(~)-------------------------------------------------------------(ayu@Freedom)-

2011/11/20 Mick <michaelkintzios@gmail.com>

On Sunday 20 Nov 2011 01:43:47 1990 dqgcs wrote:

> Thanks for reply! I am sorry to tell you i have installed vim by emerge

> ,but i failed ,so i try to use vim7.3.266'source code for debug :( .Now

> what could i do?i am almost crazy now!!!



No need to go crazy! *:-)



Run



* MAKEOPTS="-j1" emerge -uaDv app-editors/vim



and post here the error. *This may be shown a few pages above where the emerge

fails - so you will need to scroll up a bit. *Hopefully someone on this list

would know what to suggest.





PS. *Also check https://bugs.gentoo.org/ in case someone has already reported

this problem.

--

Regards,

Mick

James Broadhead 11-21-2011 02:16 PM

Vim stops installing when it runs installman.sh
 
On 21 November 2011 15:00, 1990 dqgcs <dqgcs1990@gmail.com> wrote:


Hi MickHere is my output ,Thanks for help!!!******************************************* ************************************************** **********.-(~)-------------------------------------------------------------(ayu@Freedom)-


`--> * MAKEOPTS="-j1" emerge -uaDv app-editors/vimThis action requires superuser access...Would you like to add --pretend to options? [Yes/No] yes
These are the packages that would be merged, in order:



Calculating dependencies... done![ebuild * * U *] app-arch/bzip2-1.0.6-r3 [1.0.6-r2] USE="static-libs%* -static" 0 kB[ebuild * * U *] dev-libs/icu-4.8.1-r2 [4.8] USE="static-libs -debug -doc -examples" 18,241 kB


[ebuild * * U *] dev-libs/libffi-3.0.10 [3.0.9-r2] USE="static-libs -debug -test" 736 kB[ebuild * * U *] sys-libs/timezone-data-2011l [2011h] USE="nls" 331 kB[ebuild * * U *] sys-devel/automake-wrapper-5 [4] 0 kB


[ebuild * * U *] sys-apps/sandbox-2.5 [2.4] USE="(-multilib)" 348 kB[ebuild * * U *] sys-apps/less-444 [441] USE="unicode" 301 kB[ebuild * * U *] sys-kernel/linux-headers-2.6.39 [2.6.36.1] 4,583 kB


[ebuild * * U *] dev-perl/IO-Socket-SSL-1.440.0 [1.35] USE="-idn" 68 kB[ebuild * * U *] dev-util/gtk-doc-am-1.18 [1.17] 623 kB[ebuild * * U *] media-libs/freetype-2.4.7 [2.4.6] USE="X bzip2 static-libs -auto-hinter -bindist -debug -doc -fontforge -utils" 1,456 kB


[ebuild * * U *] dev-lang/python-2.7.2-r3 [2.7.1-r1] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite* -tk -wininst" 11,494 kB[ebuild * * U *] dev-libs/libxml2-2.7.8-r3 [2.7.8-r1] USE="icu ipv6 python readline static-libs%* -debug -doc -examples -test" 0 kB


[ebuild * * U *] dev-libs/libxslt-1.1.26-r2 [1.1.26-r1] USE="crypt python static-libs%* -debug" 0 kB[ebuild * * U *] dev-lang/python-3.1.4-r3 [3.1.3-r1] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -build -doc -examples -sqlite -tk -wininst" 8,005 kB


[ebuild * * U *] sys-apps/util-linux-2.19.1-r1 [2.19.1] USE="cramfs crypt ncurses nls unicode -loop-aes -old-linux -perl (-selinux) -slang (-uclibc)" 0 kB[ebuild * * U *] sys-devel/binutils-2.21.1-r1 [2.20.1-r1] USE="nls static-libs -multislot -multitarget -test -vanilla" 18,572 kB


[ebuild * * U *] sys-devel/llvm-2.9-r2 [2.8-r2] USE="libffi -debug -llvm-gcc -multitarget -ocaml -test -udis86 -vim-syntax%" 9,351 kB[ebuild * * U *] app-text/docbook-xsl-stylesheets-1.76.1 [1.75.2] 3,597 kB


[ebuild * * U *] sys-apps/dbus-1.4.16 [1.4.12] USE="X static-libs -debug -doc (-selinux) -test" 1,846 kB[ebuild * * U *] dev-util/ctags-5.8 [5.7] USE="-ada" 469 kB[ebuild * * U *] dev-libs/dbus-glib-0.98 [0.92] USE="static-libs -debug -doc -test (-bash-completion%)" 707 kB


[ebuild * * U *] x11-misc/xdg-utils-1.1.0_rc1_p20111003 [1.1.0_rc1_p20110519] USE="-doc" 1,141 kB[ebuild * * U *] sys-libs/pam-1.1.5 [1.1.4] USE="berkdb cracklib nls -audit -debug -nis (-selinux) -test -vim-syntax" 1,584 kB


[ebuild * * U *] sys-auth/polkit-0.102 [0.101-r1] USE="gtk introspection nls pam -debug -doc -examples -kde" 860 kB[ebuild *N * * ] app-editors/vim-core-7.3.266 *USE="acl nls -bash-completion -livecd" 0 kB


[ebuild *N * * ] app-editors/vim-7.3.266 *USE="X acl gpm nls python -bash-completion -cscope -debug -minimal -perl -ruby -vim-pager" 0 kB[ebuild * * U *] x11-libs/gtk+-2.24.5-r1 [2.24.4] USE="cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama" 12,942 kB


[ebuild * * U *] media-libs/libpng-1.5.5 [1.4.8-r1] USE="static-libs -apng" 670 kB[ebuild * * U *] x11-libs/gdk-pixbuf-2.24.0-r1 [2.22.1-r2] USE="X introspection jpeg -debug -doc -jpeg2k -test -tiff (-svg%*)" 1,149 kB


[ebuild * * U *] app-text/ghostscript-gpl-9.04-r4 [9.04-r3] USE="X cups dbus gtk static-libs -bindist -djvu -idn -jpeg2k" LINGUAS="zh_CN -ja -ko -zh_TW" 0 kB[blocks B * * *] <x11-libs/libsexy-0.1.11-r3 ("<x11-libs/libsexy-0.1.11-r3" is blocking media-libs/libpng-1.5.5)


[blocks B * * *] <x11-libs/gdk-pixbuf-2.24.0-r1 ("<x11-libs/gdk-pixbuf-2.24.0-r1" is blocking media-libs/libpng-1.5.5)
Total: 31 packages (29 upgrades, 2 new), Size of downloads: 99,064 kB


Conflict: 2 blocks (2 unsatisfied)
** Error: The above package list contains packages which cannot be** installed at the same time on the same system.
* (media-libs/libpng-1.5.5::gentoo, ebuild scheduled for merge) pulled in by


* * media-libs/libpng:0 required by (app-text/ghostscript-gpl-9.04-r4::gentoo, ebuild scheduled for merge)* * >=media-libs/libpng-1.4.3:0 required by (net-print/cups-1.4.8-r1::gentoo, installed)


* * >=media-libs/libpng-1.4:0 required by (app-text/poppler-0.16.7::gentoo, installed)* * >=media-libs/libpng-1.4:0 required by (x11-libs/gdk-pixbuf-2.24.0-r1::gentoo, ebuild scheduled for merge)


* * media-libs/libpng:0 required by (x11-libs/cairo-1.10.2-r1::gentoo, installed)

For more information about Blocked Packages, please refer to the followingsection of the Gentoo Linux x86 Handbook (architecture is irrelevant):



http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



** IMPORTANT: 1 news items need reading for repository 'gentoo'.
** Use eselect news to read news items.
.-(~)-------------------------------------------------------------(ayu@Freedom)-
Hi 1990, * * * (wow, feels so retro!)*


You seem to have a couple of problems with your current setup -- perhaps you should take another look through the portage handbook on how to maintain a gentoo system.*
First off, read the news update (`eselect news read`), which will explain how to fix ....

*Second, fix your libpng problem. The news article will help, but mainly it involves running revdep-rebuild*(`emerge --sync ;*emerge gentoolkit ; revdep-rebuild`)
Third, use emerge as the superuser (I assume that you usually do)


Fourth, don't upgrade that many packages with a command-line-specific setting (the MAKEOPTS line).*Run (`emerge --sync ; emerge -uDvN world), and THEN re-build vim with the MAKEOPTS setting. In general don't use environment variables set on the command-line; it leads to messy system updates.*


Finally: You probably don't need the MAKEOPTS flag at all - try updating vim without it. ( `emerge -u vim` )
That about covers it ;)
*

Dale 11-21-2011 05:51 PM

Vim stops installing when it runs installman.sh
 
James Broadhead wrote:


Finally: You probably don't need the MAKEOPTS flag at all - try
updating vim without it. ( `emerge -u vim` )


That about covers it ;)



And don't forget the -1 or --oneshot option either.

Dale

:-) :-)

--
I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

James Broadhead 11-22-2011 11:22 AM

Vim stops installing when it runs installman.sh
 
On 21 November 2011 18:51, Dale <rdalek1967@gmail.com> wrote:


James Broadhead wrote:




Finally: You probably don't need the MAKEOPTS flag at all - try updating vim without it. ( `emerge -u vim` )



That about covers it ;)






And don't forget the -1 or --oneshot option either.
You are incorrect, vim definitely belongs in world.*
:wq*
:P


All times are GMT. The time now is 11:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.