Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   sdhc card on eeepc701 running gentoo (http://www.linux-archive.org/gentoo-user/599344-sdhc-card-eeepc701-running-gentoo.html)

Érico Porto 11-16-2011 05:32 PM

sdhc card on eeepc701 running gentoo
 
Hello,

I'm having lots of hardware error current when trying to use a sdhc card (transcend 16GB) on my eeepc701. I have never used any card on gentoo before, but I have used with success previously in Ubuntu.



Is there some know bug?

Also, only sometimes I get a device at /dev/sdb and couldn't get any /dev/sdb1 to show, but I do see it using fdisk /dev/sdb and them pressing p.

Érico V. Porto

Michael Mol 11-16-2011 06:06 PM

sdhc card on eeepc701 running gentoo
 
On Wed, Nov 16, 2011 at 1:32 PM, Érico Porto <ericoporto2008@gmail.com> wrote:
> Hello,
>
> I'm having lots of hardware error current when trying to use a sdhc card
> (transcend 16GB) on my eeepc701. I have never used any card on gentoo
> before, but I have used with success previously in Ubuntu.
>
> Is there some know bug?
>
> Also, only sometimes I get a device at /dev/sdb and couldn't get any
> /dev/sdb1 to show, but I do see it using fdisk /dev/sdb and them pressing p.
>
> Érico V. Porto
>

Could be a dying card. Try imaging it on another machine?


--
:wq

Paul Hartman 11-16-2011 07:03 PM

sdhc card on eeepc701 running gentoo
 
On Wed, Nov 16, 2011 at 12:32 PM, Érico Porto <ericoporto2008@gmail.com> wrote:
> Hello,
>
> I'm having lots of hardware error current when trying to use a sdhc card
> (transcend 16GB) on my eeepc701. I have never used any card on gentoo
> before, but I have used with success previously in Ubuntu.
>
> Is there some know bug?
>
> Also, only sometimes I get a device at /dev/sdb and couldn't get any
> /dev/sdb1 to show, but I do see it using fdisk /dev/sdb and them pressing p.

I have a USB card reader that only worked if I issued "hdparm -z
/dev/sdX", for some reason the device only worked after the second
time it was initialized. I don't know if you're using USB or MMC
interface for your card reader but maybe you can try it.

I have another device that used the MMC driver, it didn't work
properly with fast cards (above class 4) -- massive corruption every
time -- the "fix" was to hardcode the DTO value of 0xA in the mmc
driver (instead of dynamic calculation), after that it worked fine...

Érico Porto 11-16-2011 09:20 PM

sdhc card on eeepc701 running gentoo
 
it is a 16GB class 10 Transcend, but the eeepc uses a usb card reader inside of it - no mmc I think.
Actually, the first thing I tried to do with it was to format to ext2, and then the formating proccess frozed in the middle of it.. I've tried to load it in a windows pc after but couldn't read, and when I tried to format, everything frozed - but it was a public computer, so I don't know if it ever had a working card reader.


I've booted ubuntu in the eeepc now, and the card is shown in /dev/sdc1, but I can't edit it using disk utility - it gives me error calling fsync(2), on:/dev/sdc: input/output error. But on ubuntu I don't see no dmesg error msgs like the ones I see on gentoo just by plugin it on the port.


Is there any disk error checking utility in gentoo or ubuntu?
Érico V. Porto



On Wed, Nov 16, 2011 at 6:03 PM, Paul Hartman <paul.hartman+gentoo@gmail.com> wrote:



On Wed, Nov 16, 2011 at 12:32 PM, Érico Porto <ericoporto2008@gmail.com> wrote:

> Hello,

>

> I'm having lots of hardware error current when trying to use a sdhc card

> (transcend 16GB) on my eeepc701. I have never used any card on gentoo

> before, but I have used with success previously in Ubuntu.

>

> Is there some know bug?

>

> Also, only sometimes I get a device at /dev/sdb and couldn't get any

> /dev/sdb1 to show, but I do see it using fdisk /dev/sdb and them pressing p.



I have a USB card reader that only worked if I issued "hdparm -z

/dev/sdX", for some reason the device only worked after the second

time it was initialized. I don't know if you're using USB or MMC

interface for your card reader but maybe you can try it.



I have another device that used the MMC driver, it didn't work

properly with fast cards (above class 4) -- massive corruption every

time -- the "fix" was to hardcode the DTO value of 0xA in the mmc

driver (instead of dynamic calculation), after that it worked fine...

Dale 11-16-2011 09:28 PM

sdhc card on eeepc701 running gentoo
 
Érico Porto wrote:
it is a 16GB class 10 Transcend, but the eeepc uses a usb card reader
inside of it - no mmc I think.


Actually, the first thing I tried to do with it was to format to ext2,
and then the formating proccess frozed in the middle of it.. I've
tried to load it in a windows pc after but couldn't read, and when I
tried to format, everything frozed - but it was a public computer, so
I don't know if it ever had a working card reader.


I've booted ubuntu in the eeepc now, and the card is shown in
/dev/sdc1, but I can't edit it using disk utility - it gives me error
calling fsync(2), on:/dev/sdc: input/output error. But on ubuntu I
don't see no dmesg error msgs like the ones I see on gentoo just by
plugin it on the port.


Is there any disk error checking utility in gentoo or ubuntu?


Érico V. Porto




This may help. smartmontools I'm not sure what sort of testing can be
done on those if any.


Dale

:-) :-)


--
I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

Érico Porto 11-16-2011 11:09 PM

sdhc card on eeepc701 running gentoo
 
hdparm -i /dev/sdb gives meSG_IO: bad/missing sense data sb[]: 70 00 05 00 00 00 00 10 00 00 00 00 24 00 (00..HDIO_GET_IDENDITY failed: Invalid argument
I think I will try to use my warranty...

Érico V. Porto



On Wed, Nov 16, 2011 at 8:28 PM, Dale <rdalek1967@gmail.com> wrote:


Érico Porto wrote:


it is a 16GB class 10 Transcend, but the eeepc uses a usb card reader inside of it - no mmc I think.



Actually, the first thing I tried to do with it was to format to ext2, and then the formating proccess frozed in the middle of it.. I've tried to load it in a windows pc after but couldn't read, and when I tried to format, everything frozed - but it was a public computer, so I don't know if it ever had a working card reader.





I've booted ubuntu in the eeepc now, and the card is shown in /dev/sdc1, but I can't edit it using disk utility - it gives me error calling fsync(2), on:/dev/sdc: input/output error. But on ubuntu I don't see no dmesg error msgs like the ones I see on gentoo just by plugin it on the port.





Is there any disk error checking utility in gentoo or ubuntu?





Érico V. Porto








This may help. *smartmontools *I'm not sure what sort of testing can be done on those if any.



Dale



:-) *:-)





--

I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

Érico Porto 11-16-2011 11:40 PM

sdhc card on eeepc701 running gentoo
 
one thing I don't get is why I can see /dev/sdb1 when I type fdisk and press p, but that isn't listed when I type ls /dev/sd*Érico V. Porto



On Wed, Nov 16, 2011 at 10:09 PM, Érico Porto <ericoporto2008@gmail.com> wrote:


hdparm -i /dev/sdb gives meSG_IO: bad/missing sense data sb[]: 70 00 05 00 00 00 00 10 00 00 00 00 24 00 (00..HDIO_GET_IDENDITY failed: Invalid argument
I think I will try to use my warranty...


Érico V. Porto



On Wed, Nov 16, 2011 at 8:28 PM, Dale <rdalek1967@gmail.com> wrote:



Érico Porto wrote:


it is a 16GB class 10 Transcend, but the eeepc uses a usb card reader inside of it - no mmc I think.



Actually, the first thing I tried to do with it was to format to ext2, and then the formating proccess frozed in the middle of it.. I've tried to load it in a windows pc after but couldn't read, and when I tried to format, everything frozed - but it was a public computer, so I don't know if it ever had a working card reader.






I've booted ubuntu in the eeepc now, and the card is shown in /dev/sdc1, but I can't edit it using disk utility - it gives me error calling fsync(2), on:/dev/sdc: input/output error. But on ubuntu I don't see no dmesg error msgs like the ones I see on gentoo just by plugin it on the port.






Is there any disk error checking utility in gentoo or ubuntu?





Érico V. Porto








This may help. *smartmontools *I'm not sure what sort of testing can be done on those if any.



Dale



:-) *:-)





--

I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

Érico Porto 11-16-2011 11:44 PM

sdhc card on eeepc701 running gentoo
 
one thing I noted, is that I'm having buffer i/o error on logical block 3939582. Is it possible to at least use the position before this?Érico V. Porto



On Wed, Nov 16, 2011 at 10:40 PM, Érico Porto <ericoporto2008@gmail.com> wrote:


one thing I don't get is why I can see /dev/sdb1 when I type fdisk and press p, but that isn't listed when I type ls /dev/sd*Érico V. Porto



On Wed, Nov 16, 2011 at 10:09 PM, Érico Porto <ericoporto2008@gmail.com> wrote:



hdparm -i /dev/sdb gives meSG_IO: bad/missing sense data sb[]: 70 00 05 00 00 00 00 10 00 00 00 00 24 00 (00..HDIO_GET_IDENDITY failed: Invalid argument
I think I will try to use my warranty...



Érico V. Porto



On Wed, Nov 16, 2011 at 8:28 PM, Dale <rdalek1967@gmail.com> wrote:




Érico Porto wrote:


it is a 16GB class 10 Transcend, but the eeepc uses a usb card reader inside of it - no mmc I think.



Actually, the first thing I tried to do with it was to format to ext2, and then the formating proccess frozed in the middle of it.. I've tried to load it in a windows pc after but couldn't read, and when I tried to format, everything frozed - but it was a public computer, so I don't know if it ever had a working card reader.







I've booted ubuntu in the eeepc now, and the card is shown in /dev/sdc1, but I can't edit it using disk utility - it gives me error calling fsync(2), on:/dev/sdc: input/output error. But on ubuntu I don't see no dmesg error msgs like the ones I see on gentoo just by plugin it on the port.







Is there any disk error checking utility in gentoo or ubuntu?





Érico V. Porto








This may help. *smartmontools *I'm not sure what sort of testing can be done on those if any.



Dale



:-) *:-)





--

I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

Dale 11-16-2011 11:54 PM

sdhc card on eeepc701 running gentoo
 
Érico Porto wrote:
one thing I noted, is that I'm having buffer i/o error on logical
block 3939582. Is it possible to at least use the position before this?


Érico V. Porto



I had sort of the same problem with a hard drive a few weeks ago. I got
the data off and a day or so later, it died. If it was me, I wouldn't
trust it with any data where there is no copies somewhere else. It has
problems, I would replace it. Since it is under warranty, just get them
to replace it. Maybe the new one will be better.


Dale

:-) :-)

--
I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

11-17-2011 05:08 AM

sdhc card on eeepc701 running gentoo
 
Hello,

I would guess the internal reader don't work properly for such modern cards.
Especially for the 701 there exist some reports about similar problems.
You may try on another (external) sd-card-reader which is specified for class 10 cards.

Steffen.


Am 16.11.2011 19:32, schrieb Érico Porto:
> Hello,
>
> I'm having lots of hardware error current when trying to use a sdhc card
> (transcend 16GB) on my eeepc701. I have never used any card on gentoo
> before, but I have used with success previously in Ubuntu.
>
> Is there some know bug?
>
> Also, only sometimes I get a device at /dev/sdb and couldn't get any
> /dev/sdb1 to show, but I do see it using fdisk /dev/sdb and them pressing p.
>
> Érico V. Porto
>


All times are GMT. The time now is 02:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.