FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-21-2008, 12:55 PM
CJoeB
 
Default DVD Playback Problem

Hi Guys,

First, let me say that I did search this problem on Google. I found a
somewhat relevant solution, but before I try it, I thought I would post
here.


The problem is jerky playback of the dvd when I try to play it using
kaffeine. The laptop on which I am trying to play the DVD is a Dell
Inspiron M1710. It is less than a year old (purchased late April 2006).


One of the things the post said was to check that dma was enabled by
running hdparm -I /dev/hdc. I did that and this is the output:


/dev/hdc:

ATAPI CD-ROM, with removable media
Model Number: TSSTcorp DVD+/-RW TS-L632D
Serial Number:
Firmware Revision: DE04
Standards:

Likely used CD-ROM ATAPI-1
Configuration:
DRQ response: 50us.
Packet size: 12 bytes
Capabilities:
LBA, IORDY(can be disabled)
DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=227ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
HW reset results:
CBLID- below Vih
Device num = 0


Another thing this post said was that the person switched from the
scsi/sata system for the drive to the deprecated ide/sata model.


Admittedly, I haven't rebuild the kernel in a while. I'm running
2.6.21-gentoo-r4. This was because when I tried to upgrade to the next
stable version of the kernel after 2.6.21-gentoo-r4, it wouldn't
recognize my hard drive as a sata, so I went back to a kernel version
that I knew worked. Do you think a kernel upgrade would help solve the
problem.


BTW I have 2 gig of memory on this laptop, so the issue shouldn't be
memory related.


Any ideas? Thanks in advance for the assistance! :-)

Regards,

Colleen

--

Registered Linux User #411143 with the Linux Counter, http://counter.li.org

--
gentoo-user@lists.gentoo.org mailing list
 
Old 03-21-2008, 03:06 PM
Florian Philipp
 
Default DVD Playback Problem

On Fri, 2008-03-21 at 08:55 -0500, CJoeB wrote:
> Hi Guys,
>
> First, let me say that I did search this problem on Google. I found a
> somewhat relevant solution, but before I try it, I thought I would post
> here.
>
> The problem is jerky playback of the dvd when I try to play it using
> kaffeine. The laptop on which I am trying to play the DVD is a Dell
> Inspiron M1710. It is less than a year old (purchased late April 2006).
>
> One of the things the post said was to check that dma was enabled by
> running hdparm -I /dev/hdc. I did that and this is the output:
>
> /dev/hdc:
>
> ATAPI CD-ROM, with removable media
> Model Number: TSSTcorp DVD+/-RW TS-L632D
> Serial Number:
> Firmware Revision: DE04
> Standards:
> Likely used CD-ROM ATAPI-1
> Configuration:
> DRQ response: 50us.
> Packet size: 12 bytes
> Capabilities:
> LBA, IORDY(can be disabled)
> DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2
> Cycle time: min=120ns recommended=120ns
> PIO: pio0 pio1 pio2 pio3 pio4
> Cycle time: no flow control=227ns IORDY flow control=120ns
> Commands/features:
> Enabled Supported:
> HW reset results:
> CBLID- below Vih
> Device num = 0
>
>
> Another thing this post said was that the person switched from the
> scsi/sata system for the drive to the deprecated ide/sata model.
>
> Admittedly, I haven't rebuild the kernel in a while. I'm running
> 2.6.21-gentoo-r4. This was because when I tried to upgrade to the next
> stable version of the kernel after 2.6.21-gentoo-r4, it wouldn't
> recognize my hard drive as a sata, so I went back to a kernel version
> that I knew worked. Do you think a kernel upgrade would help solve the
> problem.
>
> BTW I have 2 gig of memory on this laptop, so the issue shouldn't be
> memory related.
>
> Any ideas? Thanks in advance for the assistance! :-)
>
> Regards,
>
> Colleen
>
> --

That a kernel recognizes a sata-drive as pata usually happens if there
are generic drivers present in the kernel. Deselect everything "generic"
and you should be fine.

Then you should try mplayer instead of kaffeine to be sure it's not
software related.
 

Thread Tools




All times are GMT. The time now is 07:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org