FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-19-2008, 09:26 PM
"Danis Petkakis"
 
Default Fusion-icon

"root@ ~ > equery l python
[ Searching for package 'python' in all categories among: ]
** installed packages
[I--] [* ] app-admin/python-updater-0.2 (0)
[I--] [* ] dev-lang/python-2.4.4-r9 (2.4)

[I--] [ ~] dev-python/compizconfig-python-0.6.0.1 (0)
[I--] [* ] dev-python/dbus-python-0.80.2 (0)
[I--] [* ] dev-python/python-docs-2.4.4 (2.4)
[I--] [* ] dev-python/python-fchksum-1.7.1 (0)
[I--] [* ] dev-python/qscintilla-python-2.1 (0)

[I--] [* ] dev-python/wxpython-2.6.4.0-r1 (2.6)"

should i emerge all of this again?? how can i tell if i have other python modules
installed??

On 19/03/2008, birbilis <birbilis@gmail.com> wrote:
Re-emerge dev-python/sip and probably all the python modules you have
installed (?). There must be a script for this though i don't recall it :|

Στις Τετ 19 Μαρ 2008, ο/η Danis Petkakis *γραψε:

> hello there...yesterday i did a major stupidity of mine...i accidentaly

> unmerged python
> and borked my system...i managed to get my system back to work but since
> then
> "fusion-icon" doesn't work...here is what i get when running it from
> konsole

>
> "jrn23@ ~ > fusion-icon
>*** Detected Session: kde
>*** Searching for installed applications...
>*** NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
>*** Using the GTK Interface

>*** /usr/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so: undefined
> symbol: PyUnicodeUCS4_FromObject
>**... Trying another interface
>*** Using the Qt4 Interface
>*** /usr/lib/python2.5/site-packages/sip.so: undefined symbol:

> PyUnicodeUCS4_AsWideChar
>**... Trying another interface
>*** Using the Qt3 Interface
>*** Interface not installed
>***** Error: All interfaces failed, aborting!"
>
>

> could someone tell me how to solve this?? after the crash and after i
> recovered python in order to get 'emerge' to
> work i did 'emerge -vNuD world' and then 'revdep-rebuild' and re-emerged

> "fusion-icon"...what else should i do??



--
gentoo-user@lists.gentoo.org mailing list
 
Old 03-20-2008, 06:41 AM
birbilis
 
Default Fusion-icon

I think this is the package you need: app-admin/python-updater.

http://gentoo-portage.com/app-admin/python-updater

Hope it helps,

Στις *εμ 20 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> "root@ ~ > equery l python
> [ Searching for package 'python' in all categories among: ]
> * installed packages
> [I--] [ ] app-admin/python-updater-0.2 (0)
> [I--] [ ] dev-lang/python-2.4.4-r9 (2.4)
> [I--] [ ~] dev-python/compizconfig-python-0.6.0.1 (0)
> [I--] [ ] dev-python/dbus-python-0.80.2 (0)
> [I--] [ ] dev-python/python-docs-2.4.4 (2.4)
> [I--] [ ] dev-python/python-fchksum-1.7.1 (0)
> [I--] [ ] dev-python/qscintilla-python-2.1 (0)
> [I--] [ ] dev-python/wxpython-2.6.4.0-r1 (2.6)"
>
> should i emerge all of this again?? how can i tell if i have other python
> modules
> installed??
>
> On 19/03/2008, birbilis <birbilis@gmail.com> wrote:
> > Re-emerge dev-python/sip and probably all the python modules you have
> > installed (?). There must be a script for this though i don't recall it
> > :|
> >
> > Στις Τετ 19 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> > > hello there...yesterday i did a major stupidity of mine...i accidentaly
> > > unmerged python
> > > and borked my system...i managed to get my system back to work but
> > > since then
> > > "fusion-icon" doesn't work...here is what i get when running it from
> > > konsole
> > >
> > > "jrn23@ ~ > fusion-icon
> > > * Detected Session: kde
> > > * Searching for installed applications...
> > > * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
> > > * Using the GTK Interface
> > > * /usr/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so:
> >
> > undefined
> >
> > > symbol: PyUnicodeUCS4_FromObject
> > > ... Trying another interface
> > > * Using the Qt4 Interface
> > > * /usr/lib/python2.5/site-packages/sip.so: undefined symbol:
> > > PyUnicodeUCS4_AsWideChar
> > > ... Trying another interface
> > > * Using the Qt3 Interface
> > > * Interface not installed
> > > *** Error: All interfaces failed, aborting!"
> > >
> > >
> > > could someone tell me how to solve this?? after the crash and after i
> > > recovered python in order to get 'emerge' to
> > > work i did 'emerge -vNuD world' and then 'revdep-rebuild' and
> > > re-emerged "fusion-icon"...what else should i do??
> >
> > --
> > gentoo-user@lists.gentoo.org mailing list


--
gentoo-user@lists.gentoo.org mailing list
 
Old 03-20-2008, 08:25 PM
"Danis Petkakis"
 
Default Fusion-icon

well i seem to have without to my knowledge symlinked 'usr/bin/python & /usr/bin/python2'
to python-2.5...i corrected the symlink to point to python-2.4 and run 'python-updater' again
and there were a lot of packages that were built again and now my problem is solved...thanks

for your help...but could you tell me why it was a mistake to have symlinked the above to
python-2.5??

On 20/03/2008, birbilis <birbilis@gmail.com> wrote:

I think this is the package you need: app-admin/python-updater.

http://gentoo-portage.com/app-admin/python-updater


Hope it helps,


Στις *εμ 20 Μαρ 2008, ο/η Danis Petkakis *γραψε:

> "root@ ~ > equery l python
> [ Searching for package 'python' in all categories among: ]
>*** installed packages
> [I--] [**] app-admin/python-updater-0.2 (0)


> [I--] [**] dev-lang/python-2.4.4-r9 (2.4)
> [I--] [ ~] dev-python/compizconfig-python-0.6.0.1 (0)
> [I--] [**] dev-python/dbus-python-0.80.2 (0)
> [I--] [**] dev-python/python-docs-2.4.4 (2.4)


> [I--] [**] dev-python/python-fchksum-1.7.1 (0)
> [I--] [**] dev-python/qscintilla-python-2.1 (0)
> [I--] [**] dev-python/wxpython-2.6.4.0-r1 (2.6)"
>
> should i emerge all of this again?? how can i tell if i have other python


> modules
> installed??
>
> On 19/03/2008, birbilis <birbilis@gmail.com> wrote:

> > Re-emerge dev-python/sip and probably all the python modules you have

> > installed (?). There must be a script for this though i don't recall it
> > :|
> >
> > Στις Τετ 19 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> > > hello there...yesterday i did a major stupidity of mine...i accidentaly


> > > unmerged python
> > > and borked my system...i managed to get my system back to work but
> > > since then
> > > "fusion-icon" doesn't work...here is what i get when running it from


> > > konsole
> > >
> > > "jrn23@ ~ > fusion-icon
> > >*** Detected Session: kde
> > >*** Searching for installed applications...
> > >*** NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING


> > >*** Using the GTK Interface
> > >*** /usr/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so:
> >
> > undefined
> >
> > > symbol: PyUnicodeUCS4_FromObject


> > >**... Trying another interface
> > >*** Using the Qt4 Interface
> > >*** /usr/lib/python2.5/site-packages/sip.so: undefined symbol:
> > > PyUnicodeUCS4_AsWideChar

> > >**... Trying another interface

> > >*** Using the Qt3 Interface
> > >*** Interface not installed
> > >***** Error: All interfaces failed, aborting!"
> > >
> > >
> > > could someone tell me how to solve this?? after the crash and after i


> > > recovered python in order to get 'emerge' to
> > > work i did 'emerge -vNuD world' and then 'revdep-rebuild' and
> > > re-emerged "fusion-icon"...what else should i do??


> >
> > --
> > gentoo-user@lists.gentoo.org mailing list




--

gentoo-user@lists.gentoo.org mailing list
 
Old 03-21-2008, 07:23 AM
birbilis
 
Default Fusion-icon

/usr/bin/python is symlinked to python2.5 to my system too and nothing seems
to be wrong... so this is done by the ebuild. AFAIK python versions are
multi-slotted, e.g. I have versions 2.4.4-r8 and 2.5.1-r5 currently
installed. Obviously, there must be some packages that rely on previous
versions of python...


Στις *εμ 20 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> well i seem to have without to my knowledge symlinked 'usr/bin/python &
> /usr/bin/python2'
> to python-2.5...i corrected the symlink to point to python-2.4 and run
> 'python-updater' again
> and there were a lot of packages that were built again and now my problem
> is solved...thanks
> for your help...but could you tell me why it was a mistake to have
> symlinked the above to
> python-2.5??
>
> On 20/03/2008, birbilis <birbilis@gmail.com> wrote:
> > I think this is the package you need: app-admin/python-updater.
> >
> > http://gentoo-portage.com/app-admin/python-updater
> >
> > Hope it helps,
> >
> > Στις *εμ 20 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> > > "root@ ~ > equery l python
> > > [ Searching for package 'python' in all categories among: ]
> > > * installed packages
> > > [I--] [ ] app-admin/python-updater-0.2 (0)
> > > [I--] [ ] dev-lang/python-2.4.4-r9 (2.4)
> > > [I--] [ ~] dev-python/compizconfig-python-0.6.0.1 (0)
> > > [I--] [ ] dev-python/dbus-python-0.80.2 (0)
> > > [I--] [ ] dev-python/python-docs-2.4.4 (2.4)
> > > [I--] [ ] dev-python/python-fchksum-1.7.1 (0)
> > > [I--] [ ] dev-python/qscintilla-python-2.1 (0)
> > > [I--] [ ] dev-python/wxpython-2.6.4.0-r1 (2.6)"
> > >
> > > should i emerge all of this again?? how can i tell if i have other
> >
> > python
> >
> > > modules
> > > installed??
> > >
> > > On 19/03/2008, birbilis <birbilis@gmail.com> wrote:
> > > > Re-emerge dev-python/sip and probably all the python modules you have
> > > > installed (?). There must be a script for this though i don't recall
> >
> > it
> >
> > > > Στις Τετ 19 Μαρ 2008, ο/η Danis Petkakis *γραψε:
> > > > > hello there...yesterday i did a major stupidity of mine...i
> >
> > accidentaly
> >
> > > > > unmerged python
> > > > > and borked my system...i managed to get my system back to work but
> > > > > since then
> > > > > "fusion-icon" doesn't work...here is what i get when running it
> > > > > from konsole
> > > > >
> > > > > "jrn23@ ~ > fusion-icon
> > > > > * Detected Session: kde
> > > > > * Searching for installed applications...
> > > > > * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
> > > > > * Using the GTK Interface
> > > > > * /usr/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so:
> > > >
> > > > undefined
> > > >
> > > > > symbol: PyUnicodeUCS4_FromObject
> > > > > ... Trying another interface
> > > > > * Using the Qt4 Interface
> > > > > * /usr/lib/python2.5/site-packages/sip.so: undefined symbol:
> > > > > PyUnicodeUCS4_AsWideChar
> > > > > ... Trying another interface
> > > > > * Using the Qt3 Interface
> > > > > * Interface not installed
> > > > > *** Error: All interfaces failed, aborting!"
> > > > >
> > > > >
> > > > > could someone tell me how to solve this?? after the crash and after
> >
> > i
> >
> > > > > recovered python in order to get 'emerge' to
> > > > > work i did 'emerge -vNuD world' and then 'revdep-rebuild' and
> > > > > re-emerged "fusion-icon"...what else should i do??
> > > >
> > > > --
> > > > gentoo-user@lists.gentoo.org mailing list
> >
> > --
> >
> > gentoo-user@lists.gentoo.org mailing list


--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 08:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org