FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 09-28-2011, 09:12 PM
Alex Sla
 
Default emake die by compling

On Wed, Sep 28, 2011 at 10:32 PM, Alex Sla <4k3nd0@googlemail.com> wrote:



On Wed, Sep 28, 2011 at 10:28 PM, Todd Goodman <tsg@bonedaddy.net> wrote:


* Florian Philipp <lists@binarywings.net> [110928 16:05]:

> Am 28.09.2011 21:39, schrieb Alex Sla:

> > I can't just compile anything. Getting all the time:

> >

> > * Call stack:

> > ** * * ebuild.sh, line * 56: *Called src_compile

> > ** * environment, line 3450: *Called gnome2_src_compile

> > ** * environment, line 2736: *Called die

> > ** The specific snippet of code:

> > ** * * * emake || die "compile failure"

> >

> > don't have any idea....

> >

> >

> >

>

> Usually, the actual error message is a few lines above this one. Please

> post it.

>

> Want a blind guess? My bet is you updated gcc from 4.4 to 4.5, then

> unmerged 4.4 but forgot to activate the new one using gcc-config.

>

> Regards,

> Florian Philipp

>



And to add a bit more to that (as I managed to do just that recently):



First do a:



# gcc-config -l

*[1] i686-pc-linux-gnu-4.5.3 *



if you don't see a '*' next to any of the entries then none is

selected.



To select one do:



* * * *gcc-config [CC Profile]



For example,



# gcc-config i686-pc-linux-gnu-4.5.3



Todd





Arg, i rember that there was something with the gcc .... got to mutch Gentoo System ~.~... i try it now again

I think it;s really to the libpng:
emerge --search libpng


Searching...[ Results for search key : libpng ][ Applications found : 2 ]

* *media-libs/libpng* * * Latest version available: 1.5.5
* * * Latest version installed: 1.5.5* * * Size of files: 679 kB* * * Homepage: * * *http://www.libpng.org/
* * * Description: * Portable Network Graphics library* * * License: * * * as-is


I just read in the Internet something about 1.2 -> 1.4 should i do this like this ?*http://gentoo-pr.org/node/22
 
Old 09-28-2011, 10:19 PM
Michael Mol
 
Default emake die by compling

On Wed, Sep 28, 2011 at 5:12 PM, Alex Sla <4k3nd0@googlemail.com> wrote:
>
>
> On Wed, Sep 28, 2011 at 10:32 PM, Alex Sla <4k3nd0@googlemail.com> wrote:
>>
>>
>> On Wed, Sep 28, 2011 at 10:28 PM, Todd Goodman <tsg@bonedaddy.net> wrote:
>>>
>>> * Florian Philipp <lists@binarywings.net> [110928 16:05]:
>>> > Am 28.09.2011 21:39, schrieb Alex Sla:
>>> > > I can't just compile anything. Getting all the time:
>>> > >
>>> > > * Call stack:
>>> > > ** * * ebuild.sh, line * 56: *Called src_compile
>>> > > ** * environment, line 3450: *Called gnome2_src_compile
>>> > > ** * environment, line 2736: *Called die
>>> > > ** The specific snippet of code:
>>> > > ** * * * emake || die "compile failure"
>>> > >
>>> > > don't have any idea....
>>> > >
>>> > >
>>> > >
>>> >
>>> > Usually, the actual error message is a few lines above this one. Please
>>> > post it.
>>> >
>>> > Want a blind guess? My bet is you updated gcc from 4.4 to 4.5, then
>>> > unmerged 4.4 but forgot to activate the new one using gcc-config.
>>> >
>>> > Regards,
>>> > Florian Philipp
>>> >
>>>
>>> And to add a bit more to that (as I managed to do just that recently):
>>>
>>> First do a:
>>>
>>> # gcc-config -l
>>> *[1] i686-pc-linux-gnu-4.5.3 *
>>>
>>> if you don't see a '*' next to any of the entries then none is
>>> selected.
>>>
>>> To select one do:
>>>
>>> * * * *gcc-config [CC Profile]
>>>
>>> For example,
>>>
>>> # gcc-config i686-pc-linux-gnu-4.5.3
>>>
>>> Todd
>>>
>>
>>
>> Arg, i rember that there was something with the gcc .... got to mutch
>> Gentoo System ~.~... i try it now again
>
> I think it;s really to the libpng:
> emerge --search libpng
> Searching...
> [ Results for search key : libpng ]
> [ Applications found : 2 ]
> * *media-libs/libpng
> * * * Latest version available: 1.5.5
> * * * Latest version installed: 1.5.5
> * * * Size of files: 679 kB
> * * * Homepage: * * *http://www.libpng.org/
> * * * Description: * Portable Network Graphics library
> * * * License: * * * as-is
>
> I just read in the Internet something about 1.2 -> 1.4 should i do this like
> this ?*http://gentoo-pr.org/node/22

Those steps should largely work. However, anywhere those steps say
"libpng14", think "libpng15" instead, and anywhere they say
"libpng12", think "libpng14" instead.

Also, some apps may break with libpng, even after all the libtool and
relinking stuff is taken care of. The current stable xemacs (-r1), for
example. There's a patch that fixes it, but that hasn't been made
stable yet.[1] (Or hadn't, when I tried --sync and --update earlier
today)

[1] https://bugs.gentoo.org/show_bug.cgi?id=384461

--
:wq
 
Old 09-29-2011, 12:38 PM
Alex Sla
 
Default emake die by compling

On Thu, Sep 29, 2011 at 12:19 AM, Michael Mol <mikemol@gmail.com> wrote:

On Wed, Sep 28, 2011 at 5:12 PM, Alex Sla <4k3nd0@googlemail.com> wrote:

>

>

> On Wed, Sep 28, 2011 at 10:32 PM, Alex Sla <4k3nd0@googlemail.com> wrote:

>>

>>

>> On Wed, Sep 28, 2011 at 10:28 PM, Todd Goodman <tsg@bonedaddy.net> wrote:

>>>

>>> * Florian Philipp <lists@binarywings.net> [110928 16:05]:

>>> > Am 28.09.2011 21:39, schrieb Alex Sla:

>>> > > I can't just compile anything. Getting all the time:

>>> > >

>>> > > * Call stack:

>>> > > ** * * ebuild.sh, line * 56: *Called src_compile

>>> > > ** * environment, line 3450: *Called gnome2_src_compile

>>> > > ** * environment, line 2736: *Called die

>>> > > ** The specific snippet of code:

>>> > > ** * * * emake || die "compile failure"

>>> > >

>>> > > don't have any idea....

>>> > >

>>> > >

>>> > >

>>> >

>>> > Usually, the actual error message is a few lines above this one. Please

>>> > post it.

>>> >

>>> > Want a blind guess? My bet is you updated gcc from 4.4 to 4.5, then

>>> > unmerged 4.4 but forgot to activate the new one using gcc-config.

>>> >

>>> > Regards,

>>> > Florian Philipp

>>> >

>>>

>>> And to add a bit more to that (as I managed to do just that recently):

>>>

>>> First do a:

>>>

>>> # gcc-config -l

>>> *[1] i686-pc-linux-gnu-4.5.3 *

>>>

>>> if you don't see a '*' next to any of the entries then none is

>>> selected.

>>>

>>> To select one do:

>>>

>>> * * * *gcc-config [CC Profile]

>>>

>>> For example,

>>>

>>> # gcc-config i686-pc-linux-gnu-4.5.3

>>>

>>> Todd

>>>

>>

>>

>> Arg, i rember that there was something with the gcc .... got to mutch

>> Gentoo System ~.~... i try it now again

>

> I think it;s really to the libpng:

> emerge --search libpng

> Searching...

> [ Results for search key : libpng ]

> [ Applications found : 2 ]

> * *media-libs/libpng

> * * * Latest version available: 1.5.5

> * * * Latest version installed: 1.5.5

> * * * Size of files: 679 kB

> * * * Homepage: * * *http://www.libpng.org/

> * * * Description: * Portable Network Graphics library

> * * * License: * * * as-is

>

> I just read in the Internet something about 1.2 -> 1.4 should i do this like

> this ?*http://gentoo-pr.org/node/22



Those steps should largely work. However, anywhere those steps say

"libpng14", think "libpng15" instead, and anywhere they say

"libpng12", think "libpng14" instead.



Also, some apps may break with libpng, even after all the libtool and

relinking stuff is taken care of. The current stable xemacs (-r1), for

example. There's a patch that fixes it, but that hasn't been made

stable yet.[1] (Or hadn't, when I tried --sync and --update earlier

today)



[1] https://bugs.gentoo.org/show_bug.cgi?id=384461



--

:wq



Maybe i just go back to the stable libpng. Don't have the time in the moment to go with some testing.*When i may get some time soon, i will try.
Thank you very*much
Greeting's from Germany A.
 
Old 09-29-2011, 12:43 PM
Michael Mol
 
Default emake die by compling

On Thu, Sep 29, 2011 at 8:38 AM, Alex Sla <4k3nd0@googlemail.com> wrote:
> On Thu, Sep 29, 2011 at 12:19 AM, Michael Mol <mikemol@gmail.com> wrote:
>> On Wed, Sep 28, 2011 at 5:12 PM, Alex Sla <4k3nd0@googlemail.com> wrote:
>> > I just read in the Internet something about 1.2 -> 1.4 should i do this
>> > like
>> > this ?*http://gentoo-pr.org/node/22
>>
>> Those steps should largely work. However, anywhere those steps say
>> "libpng14", think "libpng15" instead, and anywhere they say
>> "libpng12", think "libpng14" instead.
>>
>> Also, some apps may break with libpng, even after all the libtool and
>> relinking stuff is taken care of. The current stable xemacs (-r1), for
>> example. There's a patch that fixes it, but that hasn't been made
>> stable yet.[1] (Or hadn't, when I tried --sync and --update earlier
>> today)
>>
>> [1] https://bugs.gentoo.org/show_bug.cgi?id=384461
>>
> Maybe i just go back to the stable libpng. Don't have the time in the moment
> to go with some testing.
> When i may get some time soon, i will try.
> Thank you very*much
> Greeting's from Germany A.

libpng15 will eventually be stabilized, and the problems you're seeing
now, you'll see then. Just keep that in mind, and keep that list of
steps handy.

--
:wq
 
Old 09-29-2011, 05:23 PM
Carlos Sura
 
Default emake die by compling

On 28 September 2011 15:12, Alex Sla <4k3nd0@googlemail.com> wrote:



On Wed, Sep 28, 2011 at 10:32 PM, Alex Sla <4k3nd0@googlemail.com> wrote:




On Wed, Sep 28, 2011 at 10:28 PM, Todd Goodman <tsg@bonedaddy.net> wrote:


* Florian Philipp <lists@binarywings.net> [110928 16:05]:

> Am 28.09.2011 21:39, schrieb Alex Sla:

> > I can't just compile anything. Getting all the time:

> >

> > * Call stack:

> > ** * * ebuild.sh, line * 56: *Called src_compile

> > ** * environment, line 3450: *Called gnome2_src_compile

> > ** * environment, line 2736: *Called die

> > ** The specific snippet of code:

> > ** * * * emake || die "compile failure"

> >

> > don't have any idea....

> >

> >

> >

>

> Usually, the actual error message is a few lines above this one. Please

> post it.

>

> Want a blind guess? My bet is you updated gcc from 4.4 to 4.5, then

> unmerged 4.4 but forgot to activate the new one using gcc-config.

>

> Regards,

> Florian Philipp

>



And to add a bit more to that (as I managed to do just that recently):



First do a:



# gcc-config -l

*[1] i686-pc-linux-gnu-4.5.3 *



if you don't see a '*' next to any of the entries then none is

selected.



To select one do:



* * * *gcc-config [CC Profile]



For example,



# gcc-config i686-pc-linux-gnu-4.5.3



Todd





Arg, i rember that there was something with the gcc .... got to mutch Gentoo System ~.~... i try it now again

I think it;s really to the libpng:
emerge --search libpng


Searching...[ Results for search key : libpng ][ Applications found : 2 ]

* *media-libs/libpng* * * Latest version available: 1.5.5
* * * Latest version installed: 1.5.5* * * Size of files: 679 kB* * * Homepage: * * *http://www.libpng.org/

* * * Description: * Portable Network Graphics library* * * License: * * * as-is


I just read in the Internet something about 1.2 -> 1.4 should i do this like this ?*http://gentoo-pr.org/node/22






Hello,
I've read all emails -I Think-, This is what yo get:
---
** Messages for package x11-libs/gtk+-3.0.12-r1:
** ERROR: x11-libs/gtk+-3.0.12-r1 failed (compile phase):** * emake failed**
** If you need support, post the output of 'emerge --info =x11-libs/gtk+-3.0.12-r1',** the complete build log and the output of 'emerge -pqv =x11-libs/gtk+-3.0.12-r1'.** The complete build log is located at '/var/tmp/portage/x11-libs/gtk+-3.0.12-r1/temp/build.log'.
** The ebuild environment file is located at '/var/tmp/portage/x11-libs/gtk+-3.0.12-r1/temp/environment'.** S: '/var/tmp/portage/x11-libs/gtk+-3.0.12-r1/work/gtk+-3.0.12'----

Right?
Perhaps, we could help you out, if we could see what's on:/var/tmp/portage/x11-libs/gtk+-3.0.12-r1/temp/build.log

Also, I've already merged GTK+-3.0.12-r1 in ~AMD64 and no errors found.

Regards,

*

--
Carlos Sura.-http://www.carlossura.com/
 

Thread Tools




All times are GMT. The time now is 07:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org