FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 09-08-2011, 06:12 AM
"Casper Ti. Vector"
 
Default dev-lang/R: lots of "Error in strsplit" in using

When using R on my Gentoo machine, whether in interactive or in batch
mode, calling `help()' causes the following error:
Error in strsplit(txt, "
", fixed = TRUE) :
'split' string 1 is invalid UTF-8
When in interactive mode, typing any function with an opening bracket
(eg. `help(') and then pressing tab (intending to get a command
completion) causes the same error.

Above is the situation in the default locale on my machine,
`en_GB.UTF-8'; and with LANG=C, this does not happen.

My Gentoo system is updated daily with global ~amd64 keyword in use.
Available locales as following:
C, en_GB.UTF-8, POSIX
USE flags of dev-lang/R (version: 2.13.1) as following:
X bash-completion cairo jpeg nls openmp perl png readline -doc -java
-lapack -minimal -profile -static-libs -tk

Sorry to report this in the mail list, but there's some difficulties in
accessing <bugs.gentoo.org> for me. Please tell me if this is
inappropriate.

--
Using GPG/PGP? Please get my current public key (ID: 0xAEF6A134,
valid from 2010 to 2013) from a key server.
 

Thread Tools




All times are GMT. The time now is 11:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org