FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-16-2008, 03:02 PM
sean
 
Default Missing .config

I was updating my system and the nvidia drivers complained that there
was no .config in /usr/src/linux.

I looked at it was gone.
This has happened before.
Is this some bug?
I am running on amd64.

Unfortunately I do not have a current copy of .config.
Does anyone know a less painful way of rebuilding than through make
menuconfig?
I have got to remember to make a backup.

Thanks
Sean
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-16-2008, 03:06 PM
Volker Armin Hemmann
 
Default Missing .config

So, you have the symlink useflag enabled?

Just look into your old kernel-dir. And don't remove that stuff.

You might also find the config in /boot. If you used make install to install
your kernel.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-16-2008, 03:13 PM
"Alex Schuster"
 
Default Missing .config

sean writes:


Unfortunately I do not have a current copy of .config.
Does anyone know a less painful way of rebuilding than through make
menuconfig?
I have got to remember to make a backup.


You may have one, try "zcat /proc/config.gz". You need to have kernel option
"General setup -> Enable acces to .config through /proc/config.gz" enabled.
But I still copy the .config to /boot along with the kernel.


Wonko
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 01:52 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org