FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 08-25-2011, 01:38 PM
Mick
 
Default app-emulation/emul-linux-x86-* slot conflict

What's the solution to this slot conflict?
===================================
# emerge -uaDv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] app-emulation/emul-linux-x86-baselibs-20110722 [20110129]
USE="-development" 34,381 kB
[ebuild U ] app-emulation/emul-linux-x86-opengl-20110722 [20110129-r1]
USE="-development" 44,036 kB
[ebuild U ] app-emulation/emul-linux-x86-xlibs-20110722 [20110129]
USE="opengl -development" 2,586 kB
[ebuild U ] app-emulation/emul-linux-x86-gtklibs-20110722 [20110129]
USE="-development" 4,714 kB
[ebuild U ] app-emulation/emul-linux-x86-medialibs-20110722 [20110129]
USE="-development" 7,874 kB
[ebuild U ] app-emulation/emul-linux-x86-soundlibs-20110722 [20110129]
USE="alsa -development -pulseaudio" 5,966 kB
[ebuild U ] app-emulation/emul-linux-x86-qtlibs-20110722 [20110129]
USE="-development" 16,626 kB

Total: 7 packages (7 upgrades), Size of downloads: 116,180 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/emul-linux-x86-xlibs:0

(app-emulation/emul-linux-x86-xlibs-20110129::gentoo, installed) pulled in
by
~app-emulation/emul-linux-x86-xlibs-20110129 required by (app-
emulation/emul-linux-x86-motif-20110129::gentoo, installed)

(app-emulation/emul-linux-x86-xlibs-20110722::gentoo, ebuild scheduled for
merge) pulled in by
~app-emulation/emul-linux-x86-xlibs-20110722 required by (app-
emulation/emul-linux-x86-medialibs-20110722::gentoo, ebuild scheduled for
merge)
(and 2 more with the same problem)

app-emulation/emul-linux-x86-baselibs:0

(app-emulation/emul-linux-x86-baselibs-20110722::gentoo, ebuild scheduled
for merge) pulled in by
~app-emulation/emul-linux-x86-baselibs-20110722 required by (app-
emulation/emul-linux-x86-xlibs-20110722::gentoo, ebuild scheduled for merge)
(and 4 more with the same problem)

(app-emulation/emul-linux-x86-baselibs-20110129::gentoo, installed) pulled
in by
~app-emulation/emul-linux-x86-baselibs-20110129 required by (app-
emulation/emul-linux-x86-xlibs-20110129::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
===================================


Adding --backtrack gives this:
===================================
# emerge -uaDv --backtrack=30 world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

!!! One or more updates have been skipped due to a dependency conflict:

app-emulation/emul-linux-x86-soundlibs:0

(app-emulation/emul-linux-x86-soundlibs-20110722::gentoo, ebuild scheduled
for merge) conflicts with
~app-emulation/emul-linux-x86-soundlibs-20110129 required by (app-
emulation/emul-linux-x86-medialibs-20110129::gentoo, installed)

app-emulation/emul-linux-x86-baselibs:0

(app-emulation/emul-linux-x86-baselibs-20110722-r99::gentoo, ebuild
scheduled for merge) conflicts with
~app-emulation/emul-linux-x86-baselibs-20110129 required by (app-
emulation/emul-linux-x86-xlibs-20110129::gentoo, installed)

app-emulation/emul-linux-x86-opengl:0

(app-emulation/emul-linux-x86-opengl-20110722::gentoo, ebuild scheduled for
merge) conflicts with
~app-emulation/emul-linux-x86-opengl-20110129 required by (app-
emulation/emul-linux-x86-gtklibs-20110129::gentoo, installed)

app-emulation/emul-linux-x86-xlibs:0

(app-emulation/emul-linux-x86-xlibs-20110722::gentoo, ebuild scheduled for
merge) conflicts with
~app-emulation/emul-linux-x86-xlibs-20110129 required by (app-
emulation/emul-linux-x86-motif-20110129::gentoo, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

app-emulation/emul-linux-x86-qtlibs:0
app-emulation/emul-linux-x86-gtklibs:0

Total: 0 packages, Size of downloads: 0 kB

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No] Yes
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
===================================
--
Regards,
Mick
 
Old 08-25-2011, 02:18 PM
Mick
 
Default app-emulation/emul-linux-x86-* slot conflict

On Thursday 25 Aug 2011 14:55:29 you wrote:
> On Thu 25 August 2011 14:38:10 Mick wrote:
> > What's the solution to this slot conflict?
> > ===================================
> > # emerge -uaDv world
>
> > These are the packages that would be merged, in order:
> That upgrade should be seamless with recent portage versions.
>
> Do you have specific emul versions in world? Remove the versioning.

Hmm ... no I do not have any emul-linux packages in my world file:

# less /var/lib/portage/world | grep emul-linux
#

> Otherwise you can just unmerge all the 20110722 stuff and let portage
> figure it out. There's no rebuilding to be done, it just unpacks
> tarballs.

Thanks, I saw the warning about conflicting slots and wanted to make sure I
won't cause any (significant) breakage. Do you mean that I should unmerge the
previous versions (20110129)?

--
Regards,
Mick
 
Old 08-25-2011, 03:16 PM
Mick
 
Default app-emulation/emul-linux-x86-* slot conflict

On Thursday 25 Aug 2011 15:18:06 Mick wrote:
> On Thursday 25 Aug 2011 14:55:29 you wrote:
> > On Thu 25 August 2011 14:38:10 Mick wrote:
> > > What's the solution to this slot conflict?
> > > ===================================
> > > # emerge -uaDv world
> >
> > > These are the packages that would be merged, in order:
> > That upgrade should be seamless with recent portage versions.
> >
> > Do you have specific emul versions in world? Remove the versioning.
>
> Hmm ... no I do not have any emul-linux packages in my world file:
>
> # less /var/lib/portage/world | grep emul-linux
> #
>
> > Otherwise you can just unmerge all the 20110722 stuff and let portage
> > figure it out. There's no rebuilding to be done, it just unpacks
> > tarballs.
>
> Thanks, I saw the warning about conflicting slots and wanted to make sure I
> won't cause any (significant) breakage. Do you mean that I should unmerge
> the previous versions (20110129)?

Problem solved - I uninstalled app-emulation/emul-linux-x86-xlibs-20110129,
then emerged app-emulation/emul-linux-x86-xlibs and after I unmasked app-
emulation/emul-linux-x86-motif-20110722, portage took care of the remaining.

Thanks for the pointer!
--
Regards,
Mick
 

Thread Tools




All times are GMT. The time now is 01:35 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org