FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 08-20-2011, 09:39 PM
Philip Webb
 
Default emerging glib fails to create .la files

I've run into a strange problem updating my netbook.
I merged glib-2.28.8 successfully as part of a Revdep-Rebuild job,
it being a dep for one of the pkgs in the R-R list.
However after that, merging gtk+-2.24.4 librsvg-2.34.0 libglade-2.6.4
all failed with a libtool error : "libtool: link: /usr/lib/libgio-2.0.0.la
is not a valid libtool archive" or ditto for libgobject ;
indeed, those files do not exist in the netbook,
but in my already updated desktop machine, glib did create them.
The glib merge msgs did include a recommendation to remerge dbus-glib ,
but that required dbus & that too failed with a similar libtool error !
I tried remerging glib , but it still didn't create the needed .la files.

The only item thrown up by Google was a Gentoo forum thread
re a different problem, but recent & suggesting gcc needed updating
or users could run into problems with Gnome-type apps.
I'm presently updating to gcc-4.4.5 (previously 4.4.3),
but that will take > 3 hr in the netbook, so any advice is welcome.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 08-20-2011, 11:05 PM
Dale
 
Default emerging glib fails to create .la files

Philip Webb wrote:

I've run into a strange problem updating my netbook.
I merged glib-2.28.8 successfully as part of a Revdep-Rebuild job,
it being a dep for one of the pkgs in the R-R list.
However after that, merging gtk+-2.24.4 librsvg-2.34.0 libglade-2.6.4
all failed with a libtool error : "libtool: link: /usr/lib/libgio-2.0.0.la
is not a valid libtool archive" or ditto for libgobject ;
indeed, those files do not exist in the netbook,
but in my already updated desktop machine, glib did create them.
The glib merge msgs did include a recommendation to remerge dbus-glib ,
but that required dbus& that too failed with a similar libtool error !
I tried remerging glib , but it still didn't create the needed .la files.

The only item thrown up by Google was a Gentoo forum thread
re a different problem, but recent& suggesting gcc needed updating
or users could run into problems with Gnome-type apps.
I'm presently updating to gcc-4.4.5 (previously 4.4.3),
but that will take> 3 hr in the netbook, so any advice is welcome.




This is based on a quick read of your post. If you are just now
noticing that .la files are missing, you are in for a treat. They have
been removing .la files for quite some time now.


I would suggest running revdep-rebuild and it may take a few times. I'm
not sure if using a 2.2 version of portage would help on this or not.


Dale

:-) :-)
 
Old 08-20-2011, 11:28 PM
Philip Webb
 
Default emerging glib fails to create .la files

110820 Dale wrote:
> This is based on a quick read of your post.

Thanks for trying to help, but perhaps a bit too quick (smile) ?

> If you are just now noticing that .la files are missing,
> they have been removing .la files for quite some time now.

As I said, the files were created by the same 'glib' for my desktop.

> I would suggest running revdep-rebuild and it may take a few times.

As I said, I was in the midst of emerging the results of 'R-R --pretend',
when I got into this jam (it couldn't decide the pkg order anyway).

> I'm not sure if using a 2.2 version of portage would help on this or not.

My desktop machine uses 2.1.10.3 & there's no similar problem there,
so that seems unlikely to help.

I did update 'gnuconfig', which supports 'libtool',
so perhaps I need to remerge 'libtool',
but that still doesn't explain the missing .la files,
which I can only emphasise were created in my desktop machine.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 08-21-2011, 02:43 AM
Dale
 
Default emerging glib fails to create .la files

Philip Webb wrote:

110820 Dale wrote:


This is based on a quick read of your post.


Thanks for trying to help, but perhaps a bit too quick (smile) ?




I was actually on the puter to check the weather before leaving. I did
want to try at least. From the other post, it appears I did offer a
hint that helped tho. That's good enough sometimes. Wish I had a hint
to the next lotto numbers. o_O


Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 02:01 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org