FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 03-27-2011, 06:51 PM
Philip Webb
 
Default Xulrunner 2.0 seems to demand Alsa : any advice ?

Wanting to try Firefox 4.0 , I tried to emerge Xulrunner 2.0
& ran into this problem :

root:526 profile> emerge -pv xulrunner
...
net-libs/xulrunner-2.0 [1.9.2.15] USE="-alsa -crashreporter% -custom-optimization dbus -debug (-gnome%) -ipc (-java%*) -libnotify -startup-notification -system-sqlite -webm% -wifi"

root:527 profile> emerge xulrunner
...
checking for alsa... Package alsa was not found in the pkg-config search path.
Perhaps you should add the directory containing `alsa.pc'
to the PKG_CONFIG_PATH environment variable
No package 'alsa' found
configure: error: Need alsa for Ogg, Wave or WebM decoding on Linux.
Disable with --disable-ogg --disable-wave --disable-webm.

As cb seen, I have USE="-alsa -webm".
I tried adding 'alsa-lib' to 'package.provided' without any success.
I don't have sound hardware or sound enabled in my kernel.

Does anyone have suggestions or should I file a bug ?

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 03-28-2011, 12:23 PM
Florian Philipp
 
Default Xulrunner 2.0 seems to demand Alsa : any advice ?

Am 27.03.2011 20:51, schrieb Philip Webb:
> Wanting to try Firefox 4.0 , I tried to emerge Xulrunner 2.0
> & ran into this problem :
>
> root:526 profile> emerge -pv xulrunner
> ...
> net-libs/xulrunner-2.0 [1.9.2.15] USE="-alsa -crashreporter% -custom-optimization dbus -debug (-gnome%) -ipc (-java%*) -libnotify -startup-notification -system-sqlite -webm% -wifi"
>
> root:527 profile> emerge xulrunner
> ...
> checking for alsa... Package alsa was not found in the pkg-config search path.
> Perhaps you should add the directory containing `alsa.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'alsa' found
> configure: error: Need alsa for Ogg, Wave or WebM decoding on Linux.
> Disable with --disable-ogg --disable-wave --disable-webm.
>
> As cb seen, I have USE="-alsa -webm".
> I tried adding 'alsa-lib' to 'package.provided' without any success.
> I don't have sound hardware or sound enabled in my kernel.
>
> Does anyone have suggestions or should I file a bug ?
>

Definitely a bug.
 
Old 03-30-2011, 12:18 AM
Philip Webb
 
Default Xulrunner 2.0 seems to demand Alsa : any advice ?

110328 Florian Philipp wrote:
> Am 27.03.2011 20:51, schrieb Philip Webb:
>> Wanting to try Firefox 4.0 , I tried to emerge Xulrunner 2.0
>> & ran into this problem :
>> root:527 profile> emerge xulrunner
>> checking for alsa... Package alsa was not found in the pkg-config search path.
> Definitely a bug.

I have filed bug 361205.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 

Thread Tools




All times are GMT. The time now is 08:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org