FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-08-2008, 12:18 AM
Thufir
 
Default autounmask fails

Why would autounmask report that it had unmasked a package when emerge
reports that package still to be masked?


arrakis ~ #
arrakis ~ # autounmask dev-db/mysql-gui-tools-5.0_p12-r2

autounmask version 0.21 (using PortageXS-0.02.07 and portage-2.1.2.9)

* Using repository: /usr/portage

* Using package.keywords file: /etc/portage/package.keywords
* Using package.unmask file: /etc/portage/package.unmask

* Unmasking dev-db/mysql-gui-tools-5.0_p12-r2 and its dependencies..
this might take a while..

* done!

arrakis ~ #
arrakis ~ # cat /etc/portage/package.keywords
>=net-im/pidgin-2.0.2 ~x86
>=net-nntp/pan-0.131 ~x86
dev-java/sun-jdk ~x86
>=dev-ruby/rcov-0.8.1.2.0 ~x86
>=dev-ruby/ruby-debug-0.9.3 ~x86

# ---
# BEGIN: dev-db/mysql-gui-tools-5.0_p12-r2
# ---
# ---
# END: dev-db/mysql-gui-tools-5.0_p12-r2
# ---



arrakis ~ #
arrakis ~ # emerge --ask dev-db/mysql-gui-tools

These are the packages that would be merged, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "dev-db/mysql-gui-tools" have been
masked.
!!! One of the following masked packages is required to complete your
request:
- dev-db/mysql-gui-tools-5.0_p12-r2 (masked by: required EAPI 1,
supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page
or
refer to the Gentoo Handbook.

arrakis ~ #




thanks,

Thufir

--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-08-2008, 06:25 AM
Thomas Kahle
 
Default autounmask fails

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> arrakis ~ #
> arrakis ~ # emerge --ask dev-db/mysql-gui-tools
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies
> !!! All ebuilds that could satisfy "dev-db/mysql-gui-tools" have been
> masked.
> !!! One of the following masked packages is required to complete your
> request:
> - dev-db/mysql-gui-tools-5.0_p12-r2 (masked by: required EAPI 1,
> supported EAPI 0)

Is your Portage recent ? If not, try to upgrade to at least 2.1
The Message is misleading, should be:
"Package canno be installed" instead of "Package is masked"


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHrAPYrpEWPKIUt7MRAkzHAJ4jTtmAtx8NOl3WYdy3UD pLc/LPIwCgr938
1b6rxGqXtT0pXgmHzW6o51k=
=3gND
-----END PGP SIGNATURE-----
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-16-2008, 12:27 AM
Thufir
 
Default autounmask fails

On Fri, 08 Feb 2008 08:25:12 +0100, Thomas Kahle wrote:
[...]
> Is your Portage recent ? If not, try to upgrade to at least 2.1 The
> Message is misleading, should be: "Package canno be installed" instead
> of "Package is masked"

It did finally install. Thank you, though.

-Thufir

--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 09:58 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org