FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-08-2008, 12:15 AM
Erik
 
Default kdelibs-4.0.1 complaining about missing accessibility use flag

When I try to emerge kdelibs-4.0.1 it says: "x11-libs/qt-4.4.0_rc1 does
not actually support the accessibility USE flag!"
But if I do "emerge -pv qt-assistant qt-core qt-dbus qt-gui qt-opengl
qt-qt3support qt-script qt-sql qt-svg qt-test qt-xmlpatterns" I get this
list:
[ebuild R ] x11-libs/qt-core-4.4.0_rc1 USE="doc qt3support ssl
-debug -glib" 0 kB
[ebuild R ] x11-libs/qt-sql-4.4.0_rc1 USE="mysql odbc postgres
sqlite -debug -firebird" 0 kB
[ebuild R ] x11-libs/qt-script-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-dbus-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-test-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-xmlpatterns-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-gui-4.4.0_rc1 USE="accessibility cups dbus
mng tiff xinerama -debug -nas -nis" INPUT_DEVICES="-wacom" 0 kB
[ebuild R ] x11-libs/qt-assistant-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-opengl-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-qt3support-4.4.0_rc1 USE="-debug" 0 kB
[ebuild R ] x11-libs/qt-svg-4.4.0_rc1 USE="-debug" 0 kB


I do not see any "-accessibility" here, so it should work, right. The
package that has accessibility (qt-gui), has it enabled. What is wrong here?
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-08-2008, 06:15 AM
Uwe Thiem
 
Default kdelibs-4.0.1 complaining about missing accessibility use flag

On Friday 08 February 2008, Erik wrote:
> When I try to emerge kdelibs-4.0.1 it says: "x11-libs/qt-4.4.0_rc1
> does not actually support the accessibility USE flag!"

You should not try to link KDE 4.0.1 against Qt 4.4 but 4.3.

Uwe

--
Informal Linux Group Namibia:
http://www.linux.org.na/
SysEx (Pty) Ltd.:
http://www.SysEx.com.na/
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-08-2008, 06:24 AM
 
Default kdelibs-4.0.1 complaining about missing accessibility use flag

Erik <esigra@gmail.com> writes:
> When I try to emerge kdelibs-4.0.1 it says: "x11-libs/qt-4.4.0_rc1 does
> not actually support the accessibility USE flag!"
[SNIP]
> I do not see any "-accessibility" here, so it should work, right. The
> package that has accessibility (qt-gui), has it enabled. What is wrong here?

AFAIK, KDE 4.0.* only supports Qt 4.3.*. The Qt split ebuilds are
hardmasked not because of KDE4, but because of the release candidate
status.
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-08-2008, 08:22 AM
Erik
 
Default kdelibs-4.0.1 complaining about missing accessibility use flag

Zsitvai JŠnos skrev:
> Erik <esigra@gmail.com> writes:
>
>> When I try to emerge kdelibs-4.0.1 it says: "x11-libs/qt-4.4.0_rc1 does
>> not actually support the accessibility USE flag!"
>>
> [SNIP]
>
>> I do not see any "-accessibility" here, so it should work, right. The
>> package that has accessibility (qt-gui), has it enabled. What is wrong here?
>>
>
> AFAIK, KDE 4.0.* only supports Qt 4.3.*. The Qt split ebuilds are
> hardmasked not because of KDE4, but because of the release candidate
> status.
>
I thought that Qt 4.4 was source compatible with Qt 4.3 so that a
program written for Qt 4.3 would be buildable with Qt 4.4. I even
thought that source compatibility was only broken in major versions
(like Qt3 to Qt4).

I need Qt 4.4 because that is the first version where QMovie sort of
works (for showing animations, see
[http://bugs.kde.org/show_bug.cgi?id=142321]). The bug is said to be
fixed in Qt 4.4, but I still observed the problem that the animation
flickers after the first iteration and then it runs smoothly forever.
(Anyone else who observed this?)
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-08-2008, 04:44 PM
 
Default kdelibs-4.0.1 complaining about missing accessibility use flag

Erik <esigra@gmail.com> writes:
> I thought that Qt 4.4 was source compatible with Qt 4.3 so that a
> program written for Qt 4.3 would be buildable with Qt 4.4. I even
> thought that source compatibility was only broken in major versions
> (like Qt3 to Qt4).

You're right, sorry for the mistake. My next guess is that the kdelibs
ebuild is simply not prepared for the qt split. You probably need to
copy to your local overlay the 4.4 ebuild and edit in the dummy use
flags "accessibility dbus gif jpeg png qt3support ssl zlib". Or you
could edit it out of the kde4-base.eclass, but I'd rather not touch
that.
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 06:30 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org