Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Qemu-KVM on amd64: clock in Windows guest (http://www.linux-archive.org/gentoo-user/487992-qemu-kvm-amd64-clock-windows-guest.html)

"Stefan G. Weichinger" 02-11-2011 08:43 AM

Qemu-KVM on amd64: clock in Windows guest
 
Am 11.02.2011 10:12, schrieb Stefan G. Weichinger:

> Now they tell me they have clock issues in the guest :-(

[...]

> I don't know where to start.

Another fact:

When I access the guest via RDP, it is slower than when I access it via
the libvirt-console (which in fact is VNC, right?)

hmm

Petri Rosenström 02-11-2011 08:46 AM

Qemu-KVM on amd64: clock in Windows guest
 
On Fri, Feb 11, 2011 at 11:12 AM, Stefan G. Weichinger <lists@xunil.at> wrote:
>
> Greets,
>
> does anyone else run KVM on gentoo as well?
>
> I delivered a amd64-server these days and a Win7-pro-guest runs on it.
>
> Now they tell me they have clock issues in the guest :-(
>
> I found
>
> http://docs.fedoraproject.org/en-US/Fedora/13/html/Virtualization_Guide/chap-Virtualization-KVM_guest_timing_management.html
>
> and ran "bcdedit /set {default} USEPLATFORMCLOCK on", didn't help, even
> after reboot. Does it really have to say "{default}" ??
>
> I don't know where to start.
>
> The host kernel provides /dev/rtc, does currently have CPU_FREQ=y, but
> afai understand I don't use that behavior (no driver or governor loaded).
>
> Is CONFIG_HPET needed? ->
>
> # grep -i hpet .config
> CONFIG_HPET_TIMER=y
> CONFIG_HPET_EMULATE_RTC=y
> # CONFIG_HPET is not set
>
> -
>
> A kind of workaround is maybe using ntp in the guest?
> I will try that asap.
>
> Thanks for any help on this!
>
> Stefan
>
>

Hi,

I use kvm on gentoo, I really don't use the clock on the windows
guests (I don't use windows vm) :). But I could guess that the issue
might be with localtime, so you could try using "-rtc base=localtime"
parameter with starting the windows host.

Best regards
Petri

"Stefan G. Weichinger" 02-11-2011 09:39 AM

Qemu-KVM on amd64: clock in Windows guest
 
Am 11.02.2011 10:46, schrieb Petri Rosenström:

> I use kvm on gentoo, I really don't use the clock on the windows
> guests (I don't use windows vm) :). But I could guess that the issue
> might be with localtime, so you could try using "-rtc base=localtime"
> parameter with starting the windows host.

Where to put that? Can I somehow set that with virt-manager or where to
edit that?

We have the "benchmark" that one app-logo should be shown for 2 secs
when opening the app.

If I access the VM by virt-manager alone, it is OK. And the clock does
not drift.

As soon as the other guy connects via RDP or netviewer it gets bad.

The logo stays there for about 10 sec or so ... and the clock gets slooower.

S

"Stefan G. Weichinger" 02-11-2011 09:50 AM

Qemu-KVM on amd64: clock in Windows guest
 
Am 11.02.2011 10:46, schrieb Petri Rosenström:

> I use kvm on gentoo, I really don't use the clock on the windows
> guests (I don't use windows vm) :). But I could guess that the issue
> might be with localtime, so you could try using "-rtc base=localtime"
> parameter with starting the windows host.

I find that in virt-manager as well, it is set to localtime.
Next there is ACPI and APIC .... both inactive? Should I change that??

"Stefan G. Weichinger" 02-11-2011 05:44 PM

Qemu-KVM on amd64: clock in Windows guest
 
Am 11.02.2011 11:39, schrieb Stefan G. Weichinger:

> The logo stays there for about 10 sec or so ... and the clock gets slooower.

It *seems* solved now.

Enabled high res timers in host-kernel and DISabled "internet time"
(=ntp-client) in Windows7-guest. Now it is quicker and no drifting clock
(watched it 20 mins per RDP).

We'll see what the customer says ;-)

S


All times are GMT. The time now is 07:11 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.