FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-11-2011, 01:52 AM
Mike Edenfield
 
Default 32bit xulrunner version?

On Thu, 2011-02-10 at 18:32 -0500, Valmor de Almeida wrote:
> Hello,
>
> Is there a way to install a 32bit version of xulrunner?
>
> An application I am using on top of eclipse apparently needs a 32bit
> version. Don't know exactly why... Currently I have:

xulrunner is in the multilib layman overlay; I think you just need to
add multilib to the overlay and set the 'lib32' USE flag.

Note, however, that you'll end up building all of xulrunner's
dependencies as 32-bit, and their dependencies, etc. It could take a
while.

--Mike
 
Old 02-11-2011, 02:32 AM
Valmor de Almeida
 
Default 32bit xulrunner version?

On 02/10/2011 09:52 PM, Mike Edenfield wrote:
> On Thu, 2011-02-10 at 18:32 -0500, Valmor de Almeida wrote:
>> Hello,
>>
>> Is there a way to install a 32bit version of xulrunner?
>>
>> An application I am using on top of eclipse apparently needs a 32bit
>> version. Don't know exactly why... Currently I have:
>
> xulrunner is in the multilib layman overlay; I think you just need to
> add multilib to the overlay and set the 'lib32' USE flag.
>
> Note, however, that you'll end up building all of xulrunner's
> dependencies as 32-bit, and their dependencies, etc. It could take a
> while.
>
> --Mike
>
>

What will happen to the existing lib64 xulrunner on my system? will it
be replaced by lib32? Also will the USE flag lib32 show up after I add
the multilib overlay? At the moment I get:

-> euse -i lib32
global use flags (searching: lib32)
************************************************** **********
no matching entries found

local use flags (searching: lib32)
************************************************** **********
no matching entries found

Will a lib32 show up when xulrunner is emerged from the multilib
overlay? As of now no such USE flag exists

-> equery uses xulrunner
[ Searching for packages matching xulrunner... ]
[ Colour Code : set unset ]
[ Legend : Left column (U) - USE flags from make.conf ]
[ : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for net-libs/xulrunner-1.9.2.12 ]
U I
+ + alsa : Adds support for media-libs/alsa-lib
(Advanced Linux Sound Architecture)
- - custom-optimization : Fine-tune custom compiler optimizations
- - dbus : Enable dbus support for anything that needs
it (gpsd, gnomemeeting, etc)
- - debug : Enable extra debug codepaths, like asserts
and extra output. If you want to get meaningful backtraces see
http://www.gentoo.org/proj/en/qa/backtraces.xml
- - elibc_FreeBSD : ELIBC setting for systems that use the
FreeBSD C library
- - gnome : Adds GNOME support
- + ipc : Use inter-process communication between tabs
and plugins. Allows for greater stability in case of plugin crashes
+ + java : Adds support for Java
- - libnotify : Enable desktop notification support
- - startup-notification : Enable application startup event feedback
mechanism
- - system-sqlite : Use the system-wide dev-db/sqlite
installation with secure-delete enabled
- - wifi : Enable wireless network functions


Thanks for the inputs.

--
Valmor
 

Thread Tools




All times are GMT. The time now is 12:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org