FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-07-2011, 02:41 PM
 
Default possible portage or ebuild bug?

On trying my last world update with --deep and --newuse, etc. I get the
following message:

Calculating dependencies .. ........ done!

!!! All ebuilds that could satisfy ">=dev-libs/glib-2.27.5" have been
masked.
!!! One of the following masked packages is required to complete your
request:
- dev-libs/glib-9999::gnome (masked by: package.mask, missing keyword)
/usr/portage/profiles/package.mask:
# Gilles Dartiguelongue <eva@gentoo.org> (04 Feb 2011)
# New glib/gtk+ mask, for testing purpose
# Needs a new gvfs as well

- dev-libs/glib-2.27.93::gnome (masked by: package.mask)
- dev-libs/glib-2.27.93::gentoo (masked by: package.mask)

(dependency required by "x11-libs/gtk+-2.99.3" [ebuild])
(dependency required by "media-gfx/graphviz-2.26.3-r3[gtk]" [installed])
(dependency required by "app-doc/doxygen-1.7.3[-nodot]" [ebuild])
(dependency required by "media-libs/id3lib-3.8.3-r8" [installed])
(dependency required by "media-sound/id3v2-0.1.12" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Now I tried the following in my package.mask with no difference:
>=x11-libs/gtk+-2.25.0

So what am I missing here, or is something broke?

Thanks much for any help you can give.


--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
 
Old 02-07-2011, 08:04 PM
Michael Higgins
 
Default possible portage or ebuild bug?

On Mon, 07 Feb 2011 10:41:30 -0500
covici@ccs.covici.com wrote:

> On trying my last world update with --deep and --newuse, etc. I get
> the following message:
>
> Calculating dependencies .. ........ done!
>
> !!! All ebuilds that could satisfy ">=dev-libs/glib-2.27.5" have been
> masked.
> !!! One of the following masked packages is required to complete your
> request:
> - dev-libs/glib-9999::gnome (masked by: package.mask, missing keyword)
> /usr/portage/profiles/package.mask:
> # Gilles Dartiguelongue <eva@gentoo.org> (04 Feb 2011)
> # New glib/gtk+ mask, for testing purpose
> # Needs a new gvfs as well
>
> - dev-libs/glib-2.27.93::gnome (masked by: package.mask)
> - dev-libs/glib-2.27.93::gentoo (masked by: package.mask)
>
> (dependency required by "x11-libs/gtk+-2.99.3" [ebuild])
> (dependency required by
> "media-gfx/graphviz-2.26.3-r3[gtk]" [installed]) (dependency required
> by "app-doc/doxygen-1.7.3[-nodot]" [ebuild]) (dependency required by
> "media-libs/id3lib-3.8.3-r8" [installed]) (dependency required by
> "media-sound/id3v2-0.1.12" [installed]) (dependency required by
> "@selected" [set]) (dependency required by "@world" [argument])
> For more information, see the MASKED PACKAGES section in the emerge
> man page or refer to the Gentoo Handbook.
>
> Now I tried the following in my package.mask with no difference:
> >=x11-libs/gtk+-2.25.0
>
> So what am I missing here, or is something broke?
>
> Thanks much for any help you can give.
>
>

Not a bug, I'd suppose:

eix -Ic gtk+
[i] x11-libs/gtk+ (2.22.1-r1(2)@02/06/2011 2.99.3(3)[1]@02/04/2011):
Gimp ToolKit + [1] "gnome" /media/layman/gnome


Are you mixing stable and something else? Anyway, it is possible to
install it.

I think you need to modify package.keywords, not package.unmask, with
~dev-libs/glib-2.27.93, or the like, and add a use flag, maybe.

Try to emerge -pv --autounmask =dev-libs/glib-2.27.93 ..?? and good
luck. I have a mess of unmasked packages from the gnome overlay for
gnome-shell, so I do expect occasional breakage. YMMV, HTH.

Cheers,


--
| /| | | ~ ~
| / | |---| `|` ?
| |ichael | |iggins ^ /
michael.higgins[at]evolone[dot]org
 
Old 02-08-2011, 09:03 PM
Alan McKinnon
 
Default possible portage or ebuild bug?

Apparently, though unproven, at 17:41 on Monday 07 February 2011,
covici@ccs.covici.com did opine thusly:

> On trying my last world update with --deep and --newuse, etc. I get the
> following message:
>
> Calculating dependencies .. ........ done!
>
> !!! All ebuilds that could satisfy ">=dev-libs/glib-2.27.5" have been
> masked.
> !!! One of the following masked packages is required to complete your
> request:
> - dev-libs/glib-9999::gnome (masked by: package.mask, missing keyword)
> /usr/portage/profiles/package.mask:
> # Gilles Dartiguelongue <eva@gentoo.org> (04 Feb 2011)
> # New glib/gtk+ mask, for testing purpose
> # Needs a new gvfs as well
>
> - dev-libs/glib-2.27.93::gnome (masked by: package.mask)
> - dev-libs/glib-2.27.93::gentoo (masked by: package.mask)
>
> (dependency required by "x11-libs/gtk+-2.99.3" [ebuild])
> (dependency required by "media-gfx/graphviz-2.26.3-r3[gtk]" [installed])
> (dependency required by "app-doc/doxygen-1.7.3[-nodot]" [ebuild])
> (dependency required by "media-libs/id3lib-3.8.3-r8" [installed])
> (dependency required by "media-sound/id3v2-0.1.12" [installed])
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
> For more information, see the MASKED PACKAGES section in the emerge
> man page or refer to the Gentoo Handbook.
>
> Now I tried the following in my package.mask with no difference:
> >=x11-libs/gtk+-2.25.0


Do you have some gnome overlay installed? None of the high-versioned packages
you need (glib, gtk+) are in the regular tree.



> So what am I missing here, or is something broke?
>
> Thanks much for any help you can give.

My guess is something in the overlay depends on a version of gtk+ that isn't
in the overlay yet, except for the dev versions *99*. And those are hard and
keyword masked as usual for cvs/svn versions.

resync the overlay, try again.
It's an overlay. It's certain to break once a day. Less than that is a bonus.

--
alan dot mckinnon at gmail dot com
 
Old 02-09-2011, 10:41 PM
Alan McKinnon
 
Default possible portage or ebuild bug?

Apparently, though unproven, at 00:03 on Wednesday 09 February 2011, Alan
McKinnon did opine thusly:

> Apparently, though unproven, at 17:41 on Monday 07 February 2011,
>
> covici@ccs.covici.com did opine thusly:
> > On trying my last world update with --deep and --newuse, etc. I get the
> > following message:
> >
> > Calculating dependencies .. ........ done!
> >
> > !!! All ebuilds that could satisfy ">=dev-libs/glib-2.27.5" have been
> >
> > masked.
> >
> > !!! One of the following masked packages is required to complete your
> >
> > request:
> > - dev-libs/glib-9999::gnome (masked by: package.mask, missing keyword)
> > /usr/portage/profiles/package.mask:
> > # Gilles Dartiguelongue <eva@gentoo.org> (04 Feb 2011)
> > # New glib/gtk+ mask, for testing purpose
> > # Needs a new gvfs as well
> >
> > - dev-libs/glib-2.27.93::gnome (masked by: package.mask)
> > - dev-libs/glib-2.27.93::gentoo (masked by: package.mask)
> >
> > (dependency required by "x11-libs/gtk+-2.99.3" [ebuild])
> > (dependency required by "media-gfx/graphviz-2.26.3-r3[gtk]" [installed])
> > (dependency required by "app-doc/doxygen-1.7.3[-nodot]" [ebuild])
> > (dependency required by "media-libs/id3lib-3.8.3-r8" [installed])
> > (dependency required by "media-sound/id3v2-0.1.12" [installed])
> > (dependency required by "@selected" [set])
> > (dependency required by "@world" [argument])
> > For more information, see the MASKED PACKAGES section in the emerge
> > man page or refer to the Gentoo Handbook.
> >
> > Now I tried the following in my package.mask with no difference:
> > >=x11-libs/gtk+-2.25.0
>
> Do you have some gnome overlay installed? None of the high-versioned
> packages you need (glib, gtk+) are in the regular tree.

Looks like my sync yesterday was behind. Today's sync gives me the same error
you got.

Latest unstable gtk+-2.24.0 DEPENDS on >=dev-libs/glib-2.27.3 (hard masked).
$PORTDIR/profiles/package.mask lists

>=dev-libs/glib-2.27
=x11-libs/gtk+-2.24

So the gtk+ line is wrong. It should be either ">=" or version "2.24.0"

Pacho fixed it http://bugs.gentoo.org/show_bug.cgi?id=354275 so a resync again
should resolve your issue




>
> > So what am I missing here, or is something broke?
> >
> > Thanks much for any help you can give.
>
> My guess is something in the overlay depends on a version of gtk+ that
> isn't in the overlay yet, except for the dev versions *99*. And those are
> hard and keyword masked as usual for cvs/svn versions.
>
> resync the overlay, try again.
> It's an overlay. It's certain to break once a day. Less than that is a
> bonus.

--
alan dot mckinnon at gmail dot com
 
Old 02-10-2011, 01:37 AM
 
Default possible portage or ebuild bug?

Alan McKinnon <alan.mckinnon@gmail.com> wrote:

> Apparently, though unproven, at 00:03 on Wednesday 09 February 2011, Alan
> McKinnon did opine thusly:
>
> > Apparently, though unproven, at 17:41 on Monday 07 February 2011,
> >
> > covici@ccs.covici.com did opine thusly:
> > > On trying my last world update with --deep and --newuse, etc. I get the
> > > following message:
> > >
> > > Calculating dependencies .. ........ done!
> > >
> > > !!! All ebuilds that could satisfy ">=dev-libs/glib-2.27.5" have been
> > >
> > > masked.
> > >
> > > !!! One of the following masked packages is required to complete your
> > >
> > > request:
> > > - dev-libs/glib-9999::gnome (masked by: package.mask, missing keyword)
> > > /usr/portage/profiles/package.mask:
> > > # Gilles Dartiguelongue <eva@gentoo.org> (04 Feb 2011)
> > > # New glib/gtk+ mask, for testing purpose
> > > # Needs a new gvfs as well
> > >
> > > - dev-libs/glib-2.27.93::gnome (masked by: package.mask)
> > > - dev-libs/glib-2.27.93::gentoo (masked by: package.mask)
> > >
> > > (dependency required by "x11-libs/gtk+-2.99.3" [ebuild])
> > > (dependency required by "media-gfx/graphviz-2.26.3-r3[gtk]" [installed])
> > > (dependency required by "app-doc/doxygen-1.7.3[-nodot]" [ebuild])
> > > (dependency required by "media-libs/id3lib-3.8.3-r8" [installed])
> > > (dependency required by "media-sound/id3v2-0.1.12" [installed])
> > > (dependency required by "@selected" [set])
> > > (dependency required by "@world" [argument])
> > > For more information, see the MASKED PACKAGES section in the emerge
> > > man page or refer to the Gentoo Handbook.
> > >
> > > Now I tried the following in my package.mask with no difference:
> > > >=x11-libs/gtk+-2.25.0
> >
> > Do you have some gnome overlay installed? None of the high-versioned
> > packages you need (glib, gtk+) are in the regular tree.
>
> Looks like my sync yesterday was behind. Today's sync gives me the same error
> you got.
>
> Latest unstable gtk+-2.24.0 DEPENDS on >=dev-libs/glib-2.27.3 (hard masked).
> $PORTDIR/profiles/package.mask lists
>
> >=dev-libs/glib-2.27
> =x11-libs/gtk+-2.24
>
> So the gtk+ line is wrong. It should be either ">=" or version "2.24.0"
>
> Pacho fixed it http://bugs.gentoo.org/show_bug.cgi?id=354275 so a resync again
> should resolve your issue
>
>
>
>
> >
> > > So what am I missing here, or is something broke?
> > >
> > > Thanks much for any help you can give.
> >
> > My guess is something in the overlay depends on a version of gtk+ that
> > isn't in the overlay yet, except for the dev versions *99*. And those are
> > hard and keyword masked as usual for cvs/svn versions.
> >
> > resync the overlay, try again.
> > It's an overlay. It's certain to break once a day. Less than that is a
> > bonus.

Thanks much -- I had unmasked glib2.27.5, but I will get rid of that and
resync again -- did not really want to use that.

Thanks.

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
 

Thread Tools




All times are GMT. The time now is 07:04 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org