Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   --depclean complains that a package is not installed but it is installed. (http://www.linux-archive.org/gentoo-user/484177-depclean-complains-package-not-installed-but-installed.html)

netfab 02-02-2011 07:36 AM

--depclean complains that a package is not installed but it is installed.
 
Le 02/02/11 ŕ 01:23, Dale a tapoté :
> Is this a bug or am I missing something, again. ;-)
>

Bug #353362 : http://bugs.gentoo.org/353362

Nikos Chantziaras 02-02-2011 07:40 AM

--depclean complains that a package is not installed but it is installed.
 
On 02/02/2011 09:23 AM, Dale wrote:

I run --depclean every once and a while to see if anything is not needed
anymore. Sort of do a little house cleaning. When I run it, it gives me
this message:

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* media-sound/phonon[-aqua] pulled in by:
* x11-libs/qt-webkit-4.7.1-r1
*
* Have you forgotten to run `emerge --update --newuse --deep @world` prior
* to depclean? It may be necessary to manually uninstall packages that
no longer
* exist in the portage tree since it may not be possible to satisfy their
* dependencies. Also, be aware of the --with-bdeps option that is
documented
* in `man emerge`.
root@fireball / #

I ran this just before the above:

root@fireball / # emerge -uvDNa world --with-bdeps y


Not sure what's going on, but with weird errors it sometimes helped here
to unmerge the packages first and then running emerge world again. It's
as if portage needs to forget something first by unmerging it, and
re-emerging doesn't fix it.

Dale 02-02-2011 08:35 AM

--depclean complains that a package is not installed but it is installed.
 
netfab wrote:

Le 02/02/11 ŕ 01:23, Dale a tapoté :


Is this a bug or am I missing something, again. ;-)



Bug #353362 : http://bugs.gentoo.org/353362




Wow, it is a bug this time. Where is my Raid. Let's kill that bug.
lol Guess it will be fixed when I sync later on. Yeppie!!


Dale

:-) :-)


All times are GMT. The time now is 09:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.