FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-02-2011, 06:23 AM
Dale
 
Default --depclean complains that a package is not installed but it is installed.

I run --depclean every once and a while to see if anything is not needed
anymore. Sort of do a little house cleaning. When I run it, it gives
me this message:


Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* media-sound/phonon[-aqua] pulled in by:
* x11-libs/qt-webkit-4.7.1-r1
*
* Have you forgotten to run `emerge --update --newuse --deep @world` prior
* to depclean? It may be necessary to manually uninstall packages that
no longer

* exist in the portage tree since it may not be possible to satisfy their
* dependencies. Also, be aware of the --with-bdeps option that is
documented

* in `man emerge`.
root@fireball / #

I ran this just before the above:

root@fireball / # emerge -uvDNa world --with-bdeps y

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No] y
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
root@fireball / #

So, nothing needs to be updated but yet --depclean complains about the
package not being installed. Here is the kicker:


root@fireball / # emerge -pv media-sound/phonon x11-libs/qt-webkit

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] media-sound/phonon-4.4.4 USE="vlc -debug -gstreamer
-pulseaudio -xine" 0 kB
[ebuild R ] x11-libs/qt-webkit-4.7.1-r1 USE="dbus exceptions jit
kde (-aqua) -debug -pch" 0 kB


Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
root@fireball / #

Yep, it's installed. Just for good measure, I rebuilt them with -1 and
it installed them just fine. Same message as before tho. Still
complains that a package is not installed.


Is this a bug or am I missing something, again. ;-)

Dale

:-) :-)
 

Thread Tools




All times are GMT. The time now is 11:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org