FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-31-2011, 06:28 PM
"Walter Dnes"
 
Default Not getting video hardware acceleration

The system is an AMD-based Acer Aspire One 14" laptop with 4-gigs of
ram, running 64-bit mode. The video card, according to "lspci -v"...

01:05.0 VGA compatible controller: ATI Technologies Inc Device 9712
(prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Device 0372
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at c0000000 (32-bit, prefetchable) [size=256M]
I/O ports at 9000 [size=256]
Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
Memory at d0000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: [50] Power Management version 3
Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
Kernel driver in use: radeon

01:05.1 Audio device: ATI Technologies Inc Device 970f
Subsystem: Acer Incorporated [ALI] Device 0372
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at d0110000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 3
Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
Kernel driver in use: HDA Intel

mplayer can only run "-vo x11", not "-vo xv" which I see on every
other Gentoo machine I've had. Video playback suffers accordingly.
Here's a snippet from dmesg bootup stuff that looks relavant, especially
the last 6 lines...

[ 0.250870] [drm] Initialized drm 1.1.0 20060810
[ 0.250972] [drm] radeon defaulting to kernel modesetting.
[ 0.251009] [drm] radeon kernel modesetting enabled.
[ 0.251160] radeon 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 0.251204] radeon 0000:01:05.0: setting latency timer to 64
[ 0.253225] [drm] initializing kernel modesetting (RS880 0x1002:0x9712).
[ 0.253339] [drm] register mmio base: 0xD0100000
[ 0.253376] [drm] register mmio size: 65536
[ 0.253512] ATOM BIOS: Acer_JE40HM42DN
[ 0.253584] radeon 0000:01:05.0: VRAM: 256M 0xC0000000 - 0xCFFFFFFF (256M used)
[ 0.253632] radeon 0000:01:05.0: GTT: 512M 0xA0000000 - 0xBFFFFFFF
[ 0.253814] [drm] Detected VRAM RAM=256M, BAR=256M
[ 0.253856] [drm] RAM width 32bits DDR
[ 0.253972] [TTM] Zone kernel: Available graphics memory: 1899810 kiB.
[ 0.254010] [TTM] Initializing pool allocator.
[ 0.254061] [drm] radeon: 256M of VRAM memory ready
[ 0.254099] [drm] radeon: 512M of GTT memory ready.
[ 0.254174] [drm] radeon: irq initialized.
[ 0.254212] [drm] GART: num cpu pages 131072, num gpu pages 131072
[ 0.255276] [drm] Loading RS780 Microcode
[ 60.896232] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
[ 60.896274] [drm:r600_startup] *ERROR* Failed to load firmware!
[ 60.896313] radeon 0000:01:05.0: disabling GPU acceleration
[ 60.897418] radeon 0000:01:05.0: ffff88013ea6bc00 unpin not necessary
[ 60.897456] radeon 0000:01:05.0: ffff88013ea6bc00 unpin not necessary

Any ideas what's going wrong, and especially how to fix it?

--
Walter Dnes <waltdnes@waltdnes.org>
 

Thread Tools




All times are GMT. The time now is 09:32 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org