FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-16-2011, 09:26 AM
Peter Humphrey
 
Default Left hand yes, right hand no

Oh, very droll! I just had to laugh at this:

# emerge --sync
[...]
$ emerge -puDv world
[...]
emerge: there are no ebuilds built with USE flags to satisfy "~x11-
libs/qt-gui-4.7.1[accessibility=,aqua=,debug=]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-gui-4.7.1-r1 (Change USE: -accessibility)
- x11-libs/qt-svg-4.7.1-r1 (Change USE: +accessibility)
(dependency required by "x11-libs/qt-svg-4.7.1-r1" [ebuild])
(dependency required by "sys-auth/polkit-kde-0.95.1-r1" [installed])
(dependency required by "kde-base/kdelibs-4.5.5" [installed])
(dependency required by "kde-base/kfilereplace-4.5.5" [installed])
(dependency required by "kde-base/kdewebdev-meta-4.5.5" [installed])
(dependency required by "@selected")
(dependency required by "@world" [argument])

Currently the accessibility USE flag is unset. Portage is at
2.2.0_alpha15, python at 2.7.1.

--
Rgds
Peter. Linux Counter 5290, 1994-04-23.
 
Old 01-16-2011, 11:09 AM
Volker Armin Hemmann
 
Default Left hand yes, right hand no

On Sunday 16 January 2011 10:26:49 Peter Humphrey wrote:
> Oh, very droll! I just had to laugh at this:
>
> # emerge --sync
> [...]
> $ emerge -puDv world
> [...]
> emerge: there are no ebuilds built with USE flags to satisfy "~x11-
> libs/qt-gui-4.7.1[accessibility=,aqua=,debug=]".
> !!! One of the following packages is required to complete your request:
> - x11-libs/qt-gui-4.7.1-r1 (Change USE: -accessibility)
> - x11-libs/qt-svg-4.7.1-r1 (Change USE: +accessibility)
> (dependency required by "x11-libs/qt-svg-4.7.1-r1" [ebuild])
> (dependency required by "sys-auth/polkit-kde-0.95.1-r1" [installed])
> (dependency required by "kde-base/kdelibs-4.5.5" [installed])
> (dependency required by "kde-base/kfilereplace-4.5.5" [installed])
> (dependency required by "kde-base/kdewebdev-meta-4.5.5" [installed])
> (dependency required by "@selected")
> (dependency required by "@world" [argument])
>
> Currently the accessibility USE flag is unset. Portage is at
> 2.2.0_alpha15, python at 2.7.1.

yeah, that accessibility crap again *sigh*, just spare yourself a headache and
set >=x11-libs/qt-svg-4.7.1-r1 accessibility
 
Old 01-16-2011, 11:19 AM
Peter Ruskin
 
Default Left hand yes, right hand no

On Sunday 16 January 2011 10:26:49 Peter Humphrey wrote:
> Oh, very droll! I just had to laugh at this:
>
> # emerge --sync
> [...]
> $ emerge -puDv world
> [...]
> emerge: there are no ebuilds built with USE flags to satisfy
> "~x11- libs/qt-gui-4.7.1[accessibility=,aqua=,debug=]".
> !!! One of the following packages is required to complete your
> request: - x11-libs/qt-gui-4.7.1-r1 (Change USE: -accessibility)
> - x11-libs/qt-svg-4.7.1-r1 (Change USE: +accessibility)
> (dependency required by "x11-libs/qt-svg-4.7.1-r1" [ebuild])
> (dependency required by "sys-auth/polkit-kde-0.95.1-r1"
> [installed]) (dependency required by "kde-base/kdelibs-4.5.5"
> [installed]) (dependency required by
> "kde-base/kfilereplace-4.5.5" [installed]) (dependency required
> by "kde-base/kdewebdev-meta-4.5.5" [installed]) (dependency
> required by "@selected")
> (dependency required by "@world" [argument])
>
> Currently the accessibility USE flag is unset. Portage is at
> 2.2.0_alpha15, python at 2.7.1.

http://bugs.gentoo.org/show_bug.cgi?id=351829

--
Peter
================================================== ======================
Gentoo Linux: Portage 2.2.0_alpha11 kernel-2.6.37-gentoo
AMD Phenom(tm) 9950 Quad-Core Processor gcc(Gentoo: 4.5.2)
KDE: 3.5.10 Qt: 3.3.8b
================================================== ======================
 
Old 01-16-2011, 11:33 AM
Peter Humphrey
 
Default Left hand yes, right hand no

On Sunday 16 January 2011 12:19:38 Peter Ruskin wrote:

> http://bugs.gentoo.org/show_bug.cgi?id=351829

So it is. That was quick. I don't agree with his suggestion, which seems
to imply requiring all KDE systems to be built with +accessibility, like
it or not.

--
Rgds
Peter. Linux Counter 5290, 1994-04-23.
 
Old 01-17-2011, 03:41 AM
Mike Edenfield
 
Default Left hand yes, right hand no

On Sun, 2011-01-16 at 12:33 +0000, Peter Humphrey wrote:
> On Sunday 16 January 2011 12:19:38 Peter Ruskin wrote:
>
> > http://bugs.gentoo.org/show_bug.cgi?id=351829
>
> So it is. That was quick. I don't agree with his suggestion, which seems
> to imply requiring all KDE systems to be built with +accessibility, like
> it or not.
>
Not exactly. His suggestion is that everything should have the same
defaults. Some qt packages default to +accessibility, others default to
-accessibility. Then there's a third group that depends packages from
both groups having consistent US flags, meaning you're forced to set the
USE flag (either + or -) on at least one package or your build fails.

Since +accessibility doesn't appear to pull in any extra packages, just
enable some extra Qt widgets to be built, I don't really see any reason
it should *default* to off. You could globally set USE=-accessibility
if you really don't like it.

--Mike
 

Thread Tools




All times are GMT. The time now is 01:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org