FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-16-2011, 04:50 AM
Philip Webb
 
Default Boost & Openoffice

The other change led to a small improvement, but also a query.

I installed the latest stable boost-1.42.0-r2 + boost-build-1.42.0 ,
which go in new slots; I also updated to icu-4.6 + numpy-1.5.1
(the latter is probably irrelevant here, but Icu is needed for OO).
Using more haste than sense after 'emerge -cpv =boost-1.41.0-r3'
showed nothing depended on that version,
I unmerged it & the corresponding boost-build-1.41.0 ,
then trying to remerge openoffice-3.2.1-r1 , I hit a configure error.
After I restored the apparently unneeded versions of Boost(-build),
Openoffice compiled without any further complaint.

Can anyone explain why the latest stable Openoffice can't use
the latest stable slotted Boost(-build), which is used only for OO ?
Perhaps the devs have tripped up slightly in the sequence of updates.

After the updates described, the OO splash screen now appears
after c 2 sec , where before it took c 5 sec to show up,
so there's a very nice improvement in performance anyway.

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 01-16-2011, 08:20 AM
Peter Humphrey
 
Default Boost & Openoffice

On Sunday 16 January 2011 05:50:58 Philip Webb wrote:

> Using more haste than sense after 'emerge -cpv =boost-1.41.0-r3'

Did you mean 'emerge -cpv ...' or 'emerge -Cpv...' ?

--
Rgds
Peter. Linux Counter 5290, 1994-04-23.
 
Old 01-16-2011, 08:53 AM
 
Default Boost & Openoffice

Peter Humphrey <peter@humphrey.ukfsn.org> writes:

> On Sunday 16 January 2011 05:50:58 Philip Webb wrote:
>
>> Using more haste than sense after 'emerge -cpv =boost-1.41.0-r3'
>
> Did you mean 'emerge -cpv ...' or 'emerge -Cpv...' ?

Probably -c, which is the one that checks for reverse dependencies.

,----[ man emerge ]
| Depclean serves as a dependency aware version of --unmerge. When
| given one or more atoms, it will unmerge matched packages that
| have no reverse dependencies. Use --depclean together with
| --verbose to show reverse dependencies.
`----

Either way, shouldn't 'emerge openoffice' reinstall it?

--
Nuno J. Silva
gopher://sdf-eu.org/1/users/njsg
 
Old 01-16-2011, 12:52 PM
Philip Webb
 
Default Boost & Openoffice

110116 Nuno J. Silva wrote:
> Peter Humphrey <peter@humphrey.ukfsn.org> writes:
>> On Sunday 16 January 2011 05:50:58 Philip Webb wrote:
>>> Using more haste than sense after 'emerge -cpv =boost-1.41.0-r3'
>> Did you mean 'emerge -cpv ...' or 'emerge -Cpv...' ?

What I wrote.

> Probably -c, which is the one that checks for reverse dependencies.
> ,----[ man emerge ]
> | Depclean serves as a dependency aware version of --unmerge. When
> | given one or more atoms, it will unmerge matched packages that
> | have no reverse dependencies. Use --depclean together with
> | --verbose to show reverse dependencies.
> `----
> Either way, shouldn't 'emerge openoffice' reinstall it?

Please both of you, read my msg more carefully, then comment (smile).

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 
Old 01-16-2011, 01:16 PM
pk
 
Default Boost & Openoffice

On 2011-01-16 06:50, Philip Webb wrote:

> Can anyone explain why the latest stable Openoffice can't use
> the latest stable slotted Boost(-build), which is used only for OO ?
> Perhaps the devs have tripped up slightly in the sequence of updates.

eselect boost ?

Best regards

Peter K
 
Old 01-16-2011, 03:07 PM
Philip Webb
 
Default Boost & Openoffice

110116 pk wrote:
> On 2011-01-16 06:50, Philip Webb wrote:
>> Can anyone explain why the latest stable Openoffice can't use
>> the latest stable slotted Boost(-build), which is used only for OO ?
>> Perhaps the devs have tripped up slightly in the sequence of updates.
> eselect boost ?

That looks very relevant: thanks !

--
========================,,======================== ====================
SUPPORT ___________//___, Philip Webb
ELECTRIC /] [] [] [] [] []| Cities Centre, University of Toronto
TRANSIT `-O----------O---' purslowatchassdotutorontodotca
 

Thread Tools




All times are GMT. The time now is 07:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org