FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 02-05-2008, 01:10 AM
"Benjamen R. Meyer"
 
Default openexr vs. ilmbase

I went to update my system (emerge world -vuDNp) and noticed a block by
openexr (being updated) on ilmbase (new package). So, I was wondering
what they are and which one I should be using.

media-libs/openexr-1.6.1 [1.4.0a] Update!
media-libs/ilmbase-1.0.1 New!
<media-libs/openexr-1.5.0 blocking ilmbase-1.0.1

URL: http://www.openexr.com/
I noticed they are both ILM (Industrial Light & Magic) file format
stuff, and that OpenEXR split back in December 2006 into three packages:
ilmbase 0.9, OpenEXR 1.5, OpenEXRViewers 0.9. And then in August
everything upgraded to 1.0, 1.6, 1.0 respectively; with a further update
in October to 1.0.1, 1.6.1, 1.0.1 respectively.

So okay - openexr 1.4.0a needs to be removed and openexr 1.6.1 installed
instead with ilmbase 1.0.1 also installed, no?

But then why is emerge wanting to install openexr 1.5 too?

But what's the best way to do the update? I could just unmerge (emerge
-C) openexr and then do the update, and remerge openexr afterwards if
need be. Or is there a better way?

TIA,

Ben
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-05-2008, 07:10 AM
Alan McKinnon
 
Default openexr vs. ilmbase

On Tuesday 05 February 2008, Benjamen R. Meyer wrote:
> I went to update my system (emerge world -vuDNp) and noticed a block
> by openexr (being updated) on ilmbase (new package). So, I was
> wondering what they are and which one I should be using.
>
> media-libs/openexr-1.6.1 [1.4.0a] Update!
> media-libs/ilmbase-1.0.1 New!
> <media-libs/openexr-1.5.0 blocking ilmbase-1.0.1
>
> URL: http://www.openexr.com/
> I noticed they are both ILM (Industrial Light & Magic) file format
> stuff, and that OpenEXR split back in December 2006 into three
> packages: ilmbase 0.9, OpenEXR 1.5, OpenEXRViewers 0.9. And then in
> August everything upgraded to 1.0, 1.6, 1.0 respectively; with a
> further update in October to 1.0.1, 1.6.1, 1.0.1 respectively.
>
> So okay - openexr 1.4.0a needs to be removed and openexr 1.6.1
> installed instead with ilmbase 1.0.1 also installed, no?
>
> But then why is emerge wanting to install openexr 1.5 too?

It's not. Here's the exact line:

<media-libs/openexr-1.5.0 blocking ilmbase-1.0.1
^
Note this.

It's saying that your existing openexr (which is a version less than
1.5.0) is blocking ilmbase-1.0.1.

Simply unmerge openexr and remerge the versions you do want.



--
Alan McKinnon
alan dot mckinnon at gmail dot com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-05-2008, 07:37 AM
Michael Schmarck
 
Default openexr vs. ilmbase

Benjamen R. Meyer <bm_witness@yahoo.com> wrote:

> I went to update my system (emerge world -vuDNp) and noticed a block by
> openexr (being updated) on ilmbase (new package). So, I was wondering
> what they are and which one I should be using.
>
> media-libs/openexr-1.6.1 [1.4.0a] Update!
> media-libs/ilmbase-1.0.1 New!
> <media-libs/openexr-1.5.0 blocking ilmbase-1.0.1
[...]
> So okay - openexr 1.4.0a needs to be removed and openexr 1.6.1 installed
> instead with ilmbase 1.0.1 also installed, no?
>
> But then why is emerge wanting to install openexr 1.5 too?

It does not. It's telling you, that versions prior to openexr-1.5.0
block the installation of ilmbase-1.0.1.

> But what's the best way to do the update? I could just unmerge (emerge
> -C) openexr and then do the update, and remerge openexr afterwards if
> need be. Or is there a better way?

I'd do:

emerge -C '<media-libs/openexr-1.5.0' && emerge openexr

Michael

--
gentoo-user@lists.gentoo.org mailing list
 
Old 02-05-2008, 11:10 AM
Neil Bothwick
 
Default openexr vs. ilmbase

On Tue, 05 Feb 2008 09:37:23 +0100, Michael Schmarck wrote:

> emerge -C '<media-libs/openexr-1.5.0' && emerge openexr

Which will add openexr to your world file. Something you probably don't
want to do. If openexr is being installed as a dependency of something
else, then do

emerge -C <media-libs/openexr-1.5.0 && emerge -uav world

which will sort out the correct versions of everything for you.


--
Neil Bothwick

Illiterate? Write today for free help.
 

Thread Tools




All times are GMT. The time now is 07:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org