FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 01-05-2011, 01:19 PM
Mark Knecht
 
Default KDE - Could not create a python scriptengine

Hi,
Problems in KDE widget land.

I did a daily emerge -DuN @world yesterday. Everything seemed fine
until I booted up this morning. Now a number of my KDE desktop widgets
are all saying

Could not create a python scriptengine for the FadingCalendar widget.

(change the name for each widget on my desktop.)

I tried removing and adding the widget back but I get the same error.

Looking at my emerge log it seem that PyQt4 was emerged yesterday.
I see other reports on the web of this problem some 2 years ago on
some platforms where PyQt was presumed to be involved. I've made no
use flag or package changes on this system.

Is anyone else seeing anything like this?

Cheers,
Mark
 
Old 01-05-2011, 01:23 PM
ich bins
 
Default KDE - Could not create a python scriptengine

Am 05.01.2011 15:19, schrieb Mark Knecht:
> Hi,
> Problems in KDE widget land.
>
> I did a daily emerge -DuN @world yesterday. Everything seemed fine
> until I booted up this morning. Now a number of my KDE desktop widgets
> are all saying
>
> Could not create a python scriptengine for the FadingCalendar widget.
>
> (change the name for each widget on my desktop.)
>
> I tried removing and adding the widget back but I get the same error.
>
> Looking at my emerge log it seem that PyQt4 was emerged yesterday.
> I see other reports on the web of this problem some 2 years ago on
> some platforms where PyQt was presumed to be involved. I've made no
> use flag or package changes on this system.
>
> Is anyone else seeing anything like this?
>
> Cheers,
> Mark
>
>

Hi!

Try the remerge alle packages PyQt4 depends on: (equery d PyQt4)
 
Old 01-05-2011, 02:21 PM
Neil Bothwick
 
Default KDE - Could not create a python scriptengine

On Wed, 5 Jan 2011 06:19:26 -0800, Mark Knecht wrote:

> Looking at my emerge log it seem that PyQt4 was emerged yesterday.
> I see other reports on the web of this problem some 2 years ago on
> some platforms where PyQt was presumed to be involved. I've made no
> use flag or package changes on this system.

I had something similar recently that required re-emerging pykde4. at the
time, that wouldn't compile until I added a patch
to /etc/portage/patches/kde-base/pykde4-4.5.4 but the patch may be in
the potage tree now.


--
Neil Bothwick

Time for a diet! -- [NO FLABBIER].
 

Thread Tools




All times are GMT. The time now is 11:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org