FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 11-05-2010, 06:24 PM
walt
 
Default Anyone using consolekit?

When I turned on the consolekit useflag, all the nice auto-mounting stuff in
gnome stopped working.

The cause seems to be that when I'm using X, I'm listed by ck-list-sessions
as both non-active and non-local, so I can't mount e.g. a usb stick unless
I switch to a virtual console where I'm recognized as both local and active.

I don't know if this is a bug or a feature, or maybe I need to reconfigure
something.

Any opinions on how consolekit should handle this fairly common scenario?

I can fix my problem by turning off the consolekit useflag, of course, but
I'd rather learn something
 
Old 11-09-2010, 12:08 PM
李健
 
Default Anyone using consolekit?

I don't know how to solve this, but I hope the following messages may help you.

>>> Messages generated by process 14982 on 2010-10-18 23:54:00 CST for package
sys-auth/polkit-0.96-r1:

WARN: postinst

If you don't use GDM or KDM for logging in,
you must start your desktop environment (DE) as follows:
******* ck-launch-session $STARTGUI
Where $STARTGUI is a DE-starting command such as 'gnome-session'.

You should add this to your ~/.xinitrc if you use startx.

End.

2010/11/6 walt <w41ter@gmail.com>

When I turned on the consolekit useflag, all the nice auto-mounting stuff in

gnome stopped working.



The cause seems to be that when I'm using X, I'm listed by ck-list-sessions

as both non-active and non-local, so I can't mount e.g. a usb stick unless

I switch to a virtual console where I'm recognized as both local and active.



I don't know if this is a bug or a feature, or maybe I need to reconfigure

something.



Any opinions on how consolekit should handle this fairly common scenario?



I can fix my problem by turning off the consolekit useflag, of course, but

I'd rather learn something











--
Jian Li
 
Old 11-10-2010, 12:11 PM
walt
 
Default Anyone using consolekit?

On 11/09/2010 05:08 AM, 李健 wrote:

I don't know how to solve this, but I hope the following messages may help you.

>>> Messages generated by process 14982 on 2010-10-18 23:54:00 CST for package
sys-auth/polkit-0.96-r1:

WARN: postinst
If you don't use GDM or KDM for logging in,
you must start your desktop environment (DE) as follows:
ck-launch-session $STARTGUI
Where $STARTGUI is a DE-starting command such as 'gnome-session'.
You should add this to your ~/.xinitrc if you use startx.


I don't know how I missed that message after emerging consolekit ten times, but
I missed it. Thanks, I'll give that a try.



2010/11/6 walt <w41ter@gmail.com <mailto:w41ter@gmail.com>>

When I turned on the consolekit useflag, all the nice auto-mounting stuff in
gnome stopped working.
 

Thread Tools




All times are GMT. The time now is 09:32 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org